Sequential printing not working in Slic3r 1.2.9

Anyone else having trouble getting Slic3r 1.2.9 to print objects sequentially? I have been able to get it to work in the past, but lately it just seems to ignore the setting and generates the g-code for the whole bed as one part. Have I forgotten a step in laying out my parts?

Also, how do you contact the Slic3r programmers to request fixes and features? I’m kind of new to this git-hub and IRC thing and a little confused on how to navigate this stuff.

Thanks for any help and suggestions.

Maybe your parts are too big for sequential printing?

Here is the Slic3rs Github page:
If you click on “Issues” you can open a new ticket.


Don’t think the objects are too big, there are only two and they are just 17mm x 12mm x 69mm. Should work fine I would think.

I have set the ‘complete individual objects’ switch in the output options, and set my clearance sizes. I have checked to make sure the clearances are met in placement. I have placed the parts separately on the platen, as opposed to using the copy function, so they show up as two separate parts in the listing. I’ve even tried copying and renaming so there are two different part names in the list. I have tried the supposed superior .amf file format as well. All to no avail. Slic3r still slices them as one part.

Any suggestions?

Is that 17MM (X) by 12MM (Y) by 69MM (Z) ? if so that might be too tall.


Sorry, should be 17mm(X) 69mm(Y) 12mm(Z)
They are laid flat on the 17mm side. The parts are only 12mm high and 69mm long.