[SOLVED] Extruder motor not turning

I’m designing a toolhead for a bondtech extruder and e3d V6 and am half there.

Everything is done and connected but for some reason the motor won’t turn. It’s this motor:

I looked at the lulzbot motor datasheet specified in their BOM:

I was hoping that the motor would just be a drop in replacement but it seems that I’m missing something here. I can hear the motor driver whine but the motor doesn’t turn. I’ve swapped the wires to the harness and still nothing. I know the motor is good because when I connect it to another board of mine, it does rotate and the harness is still good because when I connect the old toolhead, the motor on that one turns.

My only thought left is that perhaps this motor needs more juice to turn, but looking at the datasheets, that doesn’t seem to be the case.

Does anyone have any ideas?

SOLVED- Turns out I just needed to switch the motor wires around to find the correct combo - ie map correctly from the 2 datasheets.

the bondtech is fantastic… isn’t it!

remember that the motor is geared down in its own right, rather than most extruders that gear down separately… so it takes 5 “clicks” to advance the equivalent of a standard setups 1 “click”… so it can appear not to move but really it is doing so.

I assume you are testing the motor unmounted and not bolted to the extruder… its the only way to check its the motor not the complete unit.

Have you tried removing the gearbox from the motor? and checking the motor on its own