Wierd extruder motor issue that just started

I just ran into an extruder issue I have never seen before, and it has me pretty well baffled. I’m hopeing that someone has seen this before and knows what it might be.

I’m printing a pretty standard part, when I notice that every 6th or 7th line of extrusion isn’t coming out. I figure it’s a loose gear or a missing tooth or something. So I do some troubleshooting and determine that the motor is turning fine for a few seconds, then it seems to loose all of its horsepower. it’s still trying to turn, I hear motor noise, it just doesn’t have enough juice. The gear, gear mesh, small setscrew, etc. are all fine. I can see the shaft, and the flat part isn’t rotating at all. The shaft itself doesn’t appear to be broken.

So i try a different motor, one that I know to be working. Same thing.

The fan on the controller box is working normally, and nothing major has changed in the last couple of weeks. I’m thinking it’s either a short in the wire harness, a fuse partially melted, or a rambo board issue.

None of the other axis motors are showing any signs of issues. i have more motors I can try on the extruder, but I’m pretty sure at least one of the two i already tried is functional. Nothing changed on firmware or controll software, and if i extrude direct from the LCD controller without being plugged into the computer it seems to do the same thing.

Any ideas? Has anyone seen this before? I’mhopeing it’s a fuse issue or a wire harness or something else I haven’t thought of, because I really don’t want to buy another rambo board.

Thanks in advance!

Stepper driver crapping out? Might have to switch from e0 to e1.

I hope its not the stepper driver. This isn’t even a particularily old rambo board compared to the age of the Taz, so i’m going to be annoyed at it if thats what it ends up being. I do have the dual extruder cables ran, so I guess I’ll try swapping the cable over first and see if thats the issue.

Both extruder harnesses appear to be doing the same thing on E0. Repetier isn’t wanting to let me use E1 for some reason, but that tells me it’s probably the board then. Damn.

Before you scrap the board try reflashing.

Only thing still the same is the driver chip. Different cable, and stepper motor with the same symptoms. M.T.B.F. bit you in the pocketbook.

The steppers all use the same fuse so the fuse would affect them all.
You could try and change over the firmware and see if E1 works fine for now.

Reflashing didn’t appear to affect anything. It looks like switching to E1 will work for the short term. Bummer though, i was hopeing someone would have an easy fix that doesn’t involve buying another board.

Alternatively you might be able to find someone local with the proper equipment to change out the driver chip. $10 chip +$20 labor VS $200 board.

Google “Motherboard repair service”, there are several places that can do this. I really didn’t expect so with todays “everything is disposable” attitude but there are many. If I were in your situation I would just start emailing them.