STL files opening small

I was sent files by another designer to print and when I open them in Cura they are tiny. A 10" tall item is less than and inch tall when I load it into the Cura workspace. Is this something that needs to be fixed when they are saved or when I open them?

Original file is created in Solidworks.

Thanks.

Most likely the STL file was exported using 1unit=1inch. Cura assumes 1unit=1mm, so between the export/import process your object is effectively scaled down by a factor of 1/25.4, making it appear really small.

The dimensions inside STL files are expressed in “units”. There is no specification within the STL that says whether each unit is an inch, a millimeter, a meter, or a mile.

When creating a STL file, the CAD program typically knows the actual size of your object because you have designed with absolute measurements. When exporting an STL, most CAD programs ask (or it is buried in options somewhere) what unit value the STL should be based upon. The actual size of your object is then expressed as the appropriate number of units in the STL.

So let’s say you create an object that is 10" high, then export it to STL and tell the program to use inches as the STL unit. The STL will contain references saying the object is “10 units” tall.

Now let’s say you import that STL into a program, like CURA, that assumes STL files to be based on millimeters. It will see the 10 units, assume they are millimeters, and – viola – you have a 10mm object on screen instead of a 10" object.

So there are two common “fixes” to this problem.

  1. If you are doing the export, it is best (at least for the 3D printing world) to tell the CAD program to base the STL file on millimeters, because this is the measurement most often expected. In the example above, if you export a 10" high object and tell the CAD program performing the export to us millimeters, then it will contain references saying the object is “254 units” high, because 10in is 254mm. When Cura (or something else which expects the STL units to be mm) reads the file, it will then be correctly interpreted as 254mm in height.

–OR–

  1. After importing the object to CURA and seeing that it is very small, click the object and choose the “Scale” option in Cura. Make sure the “Uniform Scale” function at the bottom of the dialog is locked, then enter “25.4” in the “Scale X” box and hit enter.

Hope that helps.

Thanks ScottW, that got me sorted out. I’ll forward this on to my counterpart to make sure we don’t have this issue in the future.