Taz 4/5 skipping steps?

So.

I’ve got a taz 4 with a metal hex hotend. I was getting GREAT prints for a long time. Now that I have been printing a lot (12 hours a day sometimes) more I’ve noticed there have been steps skipped. First it started in the y axis only. Then started in the x also. And even sometimes it happens in the z axis.

I have checked everything I can think of. Belt tightness, turned down speed, turned down acceleration, jerk, etc.

I have been thinking that maybe I need to look into either a new power supply, or a new RAMBO board.

I’ve got one of the squeaky power supplies but it stopped squeaking and now the fan barely runs at all, but the machine operates. I should note the power supply has been weird pretty much since I got the unit. (Bought it used)

Anyway. I’ve looked into lowering power to the steppers as they get EXTREMELY HOT during prints. I’ve tried swapping the motors, I’ve tried making sure the bearings slide smoothly on the axises. It’s definitely not that.

So, can someone tell me how to measure if a power supply is bad, and also how to check to see if my board is bad (I’ve read the stepper drivers sometimes need to be replaced)

Please, help. This is a picture of my latest godawful print. Note they are not always this bad but they have been slowly getting worse despite all my best efforts.


I’m losing my mind.


PS: tried later heights of .15, .2, .25.

All types of infill, rectangular/concentric patterns, I’ve tried fast, slow, I’ve tried all the settings I can possibly change, it’s definitely NOT just a print setting…


Quite honestly I can’t tell you much of anything from those pictures. Can you upload some much better pictures, preferably also of a rectangular object, like a 40mm calibration cube?

If the cooling fan for the power supply is barely working, then you can not really expect the printer to work very well either. It will fry the supply sooner or later and may take the printer at the same time.

I’m on my way to work now but I’ll print the cube later and upload it with a better camera. My iPhone camera is broken so I had to use an old android and it is terrible.

Regarding the power supply, so I guess that would be my next step…

I’m on my way to work now but I’ll print the cube later and upload it with a better camera. My iPhone camera is broken so I had to use an old android and it is terrible.

Regarding the power supply, so I guess that would be my next step…


Also, piercet, I’ve followed your build threads on your openrails x and y, and z anti-wobble nut, and after I get this issue sorted I hope to get that underway. I just ordered all the stuff to do it. So thanks for contributing so much to this community.

Finally thanks for both of your prompt replies.

Edit: crap didn’t mean to double post. Sorry!

Hello,

If you have the old Peng Chu (black plastic) PSU. you will want to unplug it and then take the cover off and blow it out with canned air.
Then if the fan does not work better, please use a desk fan to blow at it, or it will smoke a capacitor in it.
Here is a test for output:
If you have a digital multimeter available then plug the PSU (power supply unit) into a worked outlet, and then measure the DC output of the 4 pins on the output of the PSU. Pins 1 and 3 will be ground, while pins 2 and 4 will be live. You should get +4/- 24v DC output when testing a live and ground pin. If this does not happen for each set of live pins, it will indicate the PSU is failing.

Make sure to check your pulleys on the X and Y axis motors, for tight 1.27mm Allen set screws. Make sure that one set screw is tight on the flat of the motor shaft, so that you don’;t have the pulley slipping and shifting the model.

I hope this will help.

I’ve got a meter so I’ll check it later when I get home.


In other news, I’ve been looking to see how I can replace the powersupply, and it seems no one has one I can buy?? Itworks3d and lulzbot store are both out of the newer power supply style for the taz5. ITworks has the old black box style, but honestly, I don’t trust it after I’ve read all the issues people have had, so I don’t mind spending some money, but I’d like to make sure I get the right unit…

Can someone point me in the right direction?


Also, am I correct in that the stepper drivers are located on the rambo board? Or are they located elsewhere? I see Pololu A4988 Stepper Motor Driver on sale here but not sure if that is correct item for me?

Thanks!

…anyone?

Does anyone have an idea of where I can find a power supply? Seems like everywhere is out of stock.

And does anyone know if the stepper motors drivers are the Pololu A4988? Or is the driver on the RAMBO board? I looked at the bom for the taz and it doesn’t seem to have a stepper motor driver on it (unless I missed it?)

The drivers are on the rambo board permanently attached. The taz 6 power supply is a meanwell 500 watt 24v unit. You can find the core a variety of places. This is the specific unit https://itworks3d.com/product/mean-well-rsp-500-24-power-supply/ you are unlikely to find a taz 5 power supply housing for sale at the moment but there are plenty of front covers you can print.