TAZ 5 Bed doesn't reach Temperature with Flexy Dually on


I am having a problem with my TAZ 5. When I install the Flexy Dually head onto the printer and load the Arduino Add Ons software, the heated bed never gets to the proper temperature, and therefor never starts a print. It gets to 2-3 degrees under the set temperature and just stops heating up.

Not sure if it’s pertinent but I am using a raspberry pi with the OctoPi image to control the TAZ. I setup the dual extruders in the software and can control both extruders just fine. It is only the bed temperature that is having issue.

I believe I have followed the installation instructions properly, but just can’t figure this out. I have reloaded the default software through Cura once and restarted the process thinking I may have missed something to no avail. I am not sure if it has to do with the fact that the software is based on the TAZ4 instead of the TAZ5, but I doubt it since I have seen people say it’s working on the forums, and the simple fact that they wouldn’t advertise the dual extruder if it didn’t work. I have tried to search the forums for this issue and haven’t found it.

Any help is greatly appreciated.


Did you record the P.I.D. values for your bed/extruder before you changed the firmware, so you can plug them into the new firmware if needed. Otherwise you may need to do the PID calibration to make sure the default values you loaded and replaced the tuned values with when you change the firmware from TAZ 5 to Dual extruder. If I remember right your printer had a P.I.D. bed/extruder calibration done when it is built, but the software/firmware you use to replace the currently loaded firmware with has default values. So you may need to record and keep the P.I.D. values when you change firmware so you can plug the correct ones in when you do the firmware change(TAZ 5/flexyDually and back).

You may need to check your extrusion rate is correct also. They are different motors and hobbed bolts so the rate may be off.

Hi kmanley57

I did record the values and updated in the sketch before uploading them to the TAZ. I can’t even calibrate the new extruders either. I have downloaded the calibration file, which basically just extrudes 100mm of filament.

The Bed values are the ones you will need, the extruders are different, so you have to do the PID calibration on the two new extruders and then update them through the LCD panel. The bed PID is not update-able through the LCD, and thus has to be done via the firmware recompile. You will need to make sure you check/update the E-Steps for the different stepper motors that the Dual has. You have to calibrate both of them and input the settings in the LCD menu for both.

The bed P.I.D. you will use both in the Taz 5/hexagon, and in the Taz/Dual Budda firmware. The extruder P.I.D.s you need to keep if you plan to swap back and forth between them and input after every re-flash. At least you only need to do the calibration the one time. :slight_smile:

Did this work?
Have same issue with Taz5, Flexydually V1, reaches just 0.2 degrees shy of target bed temperature.
Ran PID autotune and stored values to eprom 3 times, still just under target temps.

Anyone know what else I can try short of getting a new bed?

To prevent this from happening, do not set any temperatures in your Gcode generation program. Leave extruder temperature and bed set to “0”. You will then need to manually set the temperature through your LCD screen or through pronterface/cura. Once you reach your temperatures for the bed and hot end, select print. This will start your print as soon as you hit print, whether you are at temperature or not.

That makes sense but is there a permanent fix, i.e. would a new heater bed likely solve this?

Due to the PWM settings that are used to heat the bed, it is going to oscillate with ~ 0.5c of the set temperature. In the overall scheme of helping print adhesion, this will not have any significant effect. On the computing side, if you set your temps in Gcode to exactly XXXc it will not print until it reaches and maintains exactly XXXc. (In some cases can take up to 45min) The PID tuning helps reduce the variation in the set temperature, but it will not completely eliminate this.

In general, it is best practice to watch your first layer go down. If something is going to go wrong with the print, it will usually present itself in this layer. Manually setting the temperature and hitting print when hot can be something that just becomes “normal routine” like watching the first layer.

Replacing the bed will not really help, as this is a software conflict. Are you able to get your bed to temperature when just setting it through the LCD screen while not running any Gcode?

I’ve had a similar problem with my flex dually but in regards to the bed temp. This is definitely a software issue and it does not seem to help to set the PID. The temp on the LCD will say 110. The temp feed back to the cura window is 109.7 to 109.8. It seems to have a +/- factor of .1-.4 in my case always a - factor. This causes an issue with the command to wait for bed temp. I can trick it by setting my bed temp higher via the LCD than I set in the software. For example, I tell the software 110. start the print and it just sits and waits forever. Then I modify the temp on the LCD to 111 and let it reach 111 on the LCD screen. Then change the LCD back to 110 and it immediately starts printing.

Running the PID auto-tune and feeding those values in has the same effect. I have auto tuned several times, each one giving slightly different result but in every case I end up a few 10ths short of desired temp even thought the LCD says 110.