Dual extruder firmware update issues Taz 5

Edit: issue resolved

I am following the update procedures for the Taz 4 figure they are the same.

I am stuck at the arduino part. I can’t get the extracted firmware for the dual extruder to work. I don’t get the tabs along the top of the arduino program after opening the firmware in arduino. What board am I supposed to select? I tried the one that it loads as the default (ardu mini / ATmega 328) and I’ve tried Rambo. When I load the firmware it just shows the source code it doesn’t run it. If I try to run verify it hangs, with lots of messages about Java. (I have java and it is up to date).

I’ve tried 1.05r2 1.06 and the newest version. Nothing works. Which version of the aduino am I supposed to run?

Also I get a weird question from winzip when I extract the firmware, it wants to know the file name of the compressed file. I am just leaving the same as the downloaded file and adding a .ino extension. Why is that happening, never seen that before.

Lot’s I don’t know. If someone could walk me through this step by step I’d appreciate it.

ps I am on win 7 64bit.

It says something along the lines of exception in thread 7 … java heap space. Tried to copy paste it but I can’t do that either. Apparently I am an idiot.

Solved it. Firmware wasn’t downloading properly to my computer.

Since changing firmware on my Taz 5 for dual extruders I am having trouble with the temperature sensor on my heated bed. If I set it to 105°C it stops heating at 103°C. Whatever I set the temp to it stops 2°shy and stays there.

How do I fix this?

Check out this thread. Pretty similar issue:


Printing in two colors! yay!

But there are still some odd issues.

One that’s really strange, if I measure the distance between my nozzles in Y I get 51.8 center to center with digital calipers. But when printing a recent file from simplify3d, I had to offset the second nozzle by 53mm in Y, and I probably could add another .2 to .4 mm to get the model lined up! The models are lined up perfectly in the slicer and my bed has been leveled with dial calipers. Bizarre!

Have you calibrated the dual extruder? The process with printing squares inside each other using each extruder? The process has you update the printer config so the two should line up.

Yes that’s the strange part. When I did the calibration I ended up with -.06 for X and -51.79 for Y. I set Slic3r for that and got perfect results. And it agrees with my caliper measurement closely (for Y).

I guess it’s either something in the simplify3d slicer or something odd in the model. But in order for it to print perfectly I had to use -.3 for X and 53.8 for Y (simplify3d reverses the Y axis). That Y value ended up hugely different, over 2mm! I will ask the S3d folks if they have an explanation.

I haven’t tried a different two color model yet (my other one is huge and still printing). Will see if other models behave the same when I can.

Pretty happy with the dual extruder results so far. Working pretty good. But need to figure out a way to keep bleed from the standby nozzle off of the print.

You need to check the box in Simply3D to reverse the Y table.(Tools, Options, Machine)

For the bleed - more retraction distance

Yes it’s already reversed by the Taz 4 profile I am using. That doesn’t explain the 2mm difference does it?