Taz 5 Temperature Drops

I’ve repeatedly tried and failed to run a 54 hour 400G print. Everything starts fine, but a few hours in the actual temperature drops below the melting point of my eSun PLA and it starts printing in air. I’ve run the print both from the SD card and from my Octopi. The last time I ran it without filament loaded and took some screen caps to verify the timing, but I think it’s a little different each time - I’ve seen it go for over 8 hours before failing a couple times. At just short of the 2 hour mark it drops from the set 210 to 194. Then at about the 3 hour mark it drops again to 180. By the 4th hour it settles at 184 and stays there for the remaining 50 or so hours. The whole time the target temp still shows as 210 regardless if printing from SD card or Octopi.

I’ve replaced the heater cartridge to no effect. I’ve also run it with the bed heater disconnected. I’m running off an APC battery backup with a fresh battery and the Octopi (battery side) and lamp (surge only side) plugged into it don’t show any issues, so don’t think it’s the power source, must be internal.

Have you taken resistance measurements for your thermistor? With the printer turned off and unplugged, disconnect the hot end from the wiring harness and test hot end for the proper resistance. The smaller black and red wires coming from the hot end are for the thermistor and should read ~100k ohms at room temperature. The larger red wires are connected to the heater cartridge and should read ~20 ohms.

Took some time to get my hands on a reliable multimeter, but the resistances check out. At room temperature I got about 19.9 ohms for the heater cartridge, as well as the old one I had previously replaced, and about 108k ohms for the thermistor.

But I don’t think there was reason to suspect it since the displayed temperature drops have coincided with the filament no longer extruding, as it drops below the melting point. I’d say that’s a sign that the reported temp is accurate, or at least close enough to not be a problem. I think the issue is with the control board, but IDK what to check there.

Do you have any way to capture the console messages? Octoprint has a pretty small buffer, but maybe turning on Serial Logging would capture it all?

It would be interesting to see the temp reports coming from the firmware when the drop occurs (to see what the firmware thinks current target temp is), and whether it correlates with any specific gcode sequence. It really looks like the firmware thinks it’s temp target was changed, because it drops and then holds pretty steady at a lower level. But Octoprint still shows the higher target, which means it never saw any outgoing temp command in the gcode.

I’ll try recording my screen with the console up on one computer while watching the temp graph on another. I’ll post some results tomorrow.

If that doesn’t work out, I just confirmed that Octoprint’s serial logging (“Settings, Serial Connection, Log communication to serial.log”) captures everything sent/received, and timestamps each entry. There is a warning about the performance hit, but I ran a print with it enabled and didn’t see any problems (at least on an Rpi3). File could get pretty big with the hours-long print you’re capturing, though.

Perfect! I was looking for this. I’m on a pi3 too, and I’ll stop it after 1 or 2 temp drops, so it should be less than 8 hours of logging.

See attached Serial.log. It looks like line 7186 (2018-02-04 17:45:10,640) is the last good temp “209.6 /210.0”. Then it clearly starts going down at line 7432 (2018-02-04 17:45:16,100). This is when (+/- a few seconds) I saw the OctoPrint temp graph start to drop.

I searched and couldn’t find an “S189” commands that might have set the temp to the 189 it settles at. Also no “S186” - “S190”. The only hit I got for “S191” was way down on line 11251 (2018-02-04 18:45:27,425) which looks like it was to set the fan speed if I understand correctly. “N5392 M106 S191*83”
serial.zip (287 KB)

I don’t see any reason for the drop, either – No change in fan operation or extrusion rate, and the firmware still shows the correct target (210) and is applying power as the temp continues to drop. It’s like it just suddenly “can’t keep up”, even though demand didn’t change.

Other thing I did notice… is how long it takes to reach temperature. Your initial heatup took over 5 minutes to get to 200c (where printing started) and another 4 minutes after that to finally reach the 210c target. I think my hexagon can go from room temp to 200 in about 2 minutes. That makes me wonder if the heater is getting all the power that’s being sent to it. You’ve already checked the thermistor and replaced the heater, so those are assumed good.

All I can think of to try:
(1) Check your wiring harness and plugs/connectors and crimps, including the plugs at the power supply. Perhaps there’s a high-impedance connection intermittently preventing the heater from getting full power.
(2) Compare your PID values (visible in M503, as current M301 values) to those from an AutoTune (“M303 S210”). If they are off by a lot, try setting the autotune values with M301. (I doubt this will help, as it appears the firmware is setting sufficient power level when temp is dropping – but worth a try if all connections look good).

Thanks ScottW.
Just to make sure I didn’t make a mistake, I recently replaced the thermistor and heater cartridge with the following parts.


I’ll check the resistances/connections. But, you lost me on 2). Are you talking about writing a custom gcode file? Can you give me a little more instruction or example on that? I haven’t done that before.

You could double-check with Lulzbot tech support, but those certainly look like the correct parts to me.

There are PID controller values the firmware uses to help stabilize and prevent overshoot/undershoot of target temperature. There are defaults in the firmware which are usually fine, but you can also set your own values. The firmware also includes a testing routine, called “PID Autotune”, which will test different power levels while watching temperature behavior and then spit out recommended PID settings based on those tests.

Beware that other problems (like bad connections, insufficient power, bad thermistor, etc) can cause Autotune to return bad numbers. So those things need to be ruled out first. I really don’t think PID values are your problem – because it is so intermittent.

But to check and set PID values for the hotend:

  • If you go to console and enter a “M503” command, the firmware will respond with current settings. Look for a line that starts with “M301” and jot down the numbers for P, I, and D values shown on that line. I think the firmware defaults for the standard Hexagon are P28.79, I4.83, and D108.51, so that’s probably what you’ll see.
  • Then with the hotend at room temp, send the command “M303 S210”. The hotend will heat up, then hold around 210 for a while, and issue several messages over a period of a few minutes with P, I, and D values. When the command completes, look for the last set of those numbers and jot them down.
  • If the values from autotune are far different than firmware defaults (particularly if there is a really big P number) with a standard Hexagon, I would again suspect some other problem – like power or wiring (or thermistor/heater, but you’ve replaced those). Otherwise, you can enter the new values by going to the console and sending “M301 Pxx.xx Ixx.xx Dxx.xx” command (where you replace the “xx.xx” values with those suggested by Autotune).
  • After setting the new values with M301, send an M500 command to store the values to memory – otherwise they will be lost at next power cycle or connection. Finally, run the M503 again and verify that the values you entered are now shown.

I run my taz 5 with octoprint also. I had temp issues also. Mine had to do with the thermistor. I was able to fix the one I had. It was a bad soldier joint. It read fine with the dvm but during certain movements it showed itself. You mentioned that it’s a very long print does it show up at the same time every time? I’d check that whole wiring run if possible. Good luck

Thanks so much for your replies. After a YEAR (I moved and had to put this on hold for some months), I finally found the issue. I added a 2nd fan for the hotend heatsync in parallel with the mini blower. It was causing too much draw it seems and it was pulling power away from the thermistor somehow? As soon as I disconnected it, the temp shot up to what it should be in seconds. I figured it out by running a print and disconnecting one component at a time and monitoring the temp. Took a quite a while.

A little explanation so you don’t think I’m dumb… I was getting constant filament jams and assumed it was heat creep, so I printed a duct ( https://www.thingiverse.com/thing:1039016 ) and got this 40mm 5v 0.19a fan from ebay ( https://www.mouser.com/ProductDetail/ADDA/AD0405HS-G70?qs=VMzaZUw2lw9eJRwRGJ%2bn%2FA%3D%3D ). I connected it in parallel to the mini blower (also 5v) and everything seemed to work. I still got the filament jams and eventually noticed the temp drops, and I assumed they were always the problem and I just hadn’t noticed before adding the fan, but now I guess some other factor was causing jams before adding this fan.

Now I found that my mini blower is dead - I cut the lines and confirmed it’s still getting 5v. But even with just the 40mm fan connected, there’s still drops. So I need to power it another way. Is there anywhere on the control board where I can get constant 5v, or somehow in conjunction with the thermistor being activated? I’d prefer not to down grade back to the less effective mini blower at a crazy cost of $18+shipping.

If you have access to a digital multimeter you may want to test the voltage of the PSU.

Plug the PSU (power supply unit) into a worked outlet, and then measure the DC output of the 4 pins on the output of the PSU.

Pins 1 and 2 will be live, while pins 3 and 4 will be ground. You should get 24V DC output when testing a live and ground pin.

PSU pins 1+3 and 2+4 are 24.16VDC on each. I connected the new hotend heatsync fan to a dedicated 5V power supply. Would be nice to connect to the control board. Please let me know if anyone knows how I might do this other than the pins for the mini blower. I still have to clear the last filament jam. Will update after that.