Taz 5 X and Y Axis Calibration

Hi Guys,

So I recently got the Taz 5 for a project where I have to make specific dimensioned parts to fit. However, the x and y axis seem to be a bit off. I’ve been testing out printing a 1 inch circle ( 25.4mm ). On cura it says 25.39mm. However, when it does print out, the measurements are at 21.7mm.

Is there a way where I can calibrate the X and Y axis on the machine so it’ll print the right dimensions?
Test Cylinder.STL (22.7 KB)

The proper way to calibrate the machine is to tell the axis (only 1 at a time) to move 100mm and measure the actual amount it moves. If it’s off then you can adjust the “steps” for that axis, it’s pretty easy on a TAZ but rather than me going through the whole thing here I am sure it’s documented on this site.

You can tell the axis to move 100mm either through the built in controller (display) or through whatever software you are controlling the machine from, it needs to be exact so if you tell it to move 100mm and it measures 99mm then it needs adjusting.

If it does measure correctly, then it’s possible there is a translation error somewhere between your design software and the slicer you use. You could test this by downloading any of the calibration prints off Thingiverse and print to see if they print correctly.

Now, it’s not unusual to have slight variations in print size due to many factors but normally it’s less than 1mm difference and it sounds like you are getting 4mm or more difference.

Now, holes are a whole other can of worms and basically they will always come out a bit smaller (around 1-2mm) and there have been many, many discussions on that matter and until there is some compensation in the slicers we just need to design around that limitation.

From what I saw in this forum. I found this post from ORIAS

Download the firmware: http://download.lulzbot.com/AO-101/soft … lin.tar.gz
Extract (unzip) the package so you have a folder called “Marlin”.
Install the Arduino IDE: http://download.lulzbot.com/AO-100/soft … indows.zip
Open the Arduino IDE
FInd the tab “Configuration.h”
Find the line “#define DEFAULT_AXIS_STEPS_PER_UNIT {50.25,50.25,756,408} // default steps per unit for AO-101”
Change the 408 value within {} to your specific extruder steps per unit (found on your Test Acceptance Sheet)
Save the changes
Plug in the printer and power it on
In the Arduino menu, select Tools > Serial Port and select the port for your printer
In the Arduino men, select Tools > Board and select “Arduino Mega 2560 or …”
Select File > Upload to compile the sketch into firmware, then automatically upload to the board.

I repeated the same steps, but using the Taz5 Firmware, and an updated Arudino program. However, when I open the Marlin File, there is no Configuration.h tab. I only get a “Marlin_2015_TAZ5_0” tab.

For starters, don’t upload the firmware from those links to your Taz 5. The old AO firmware goes to a different printer.

Yea, I didn’t download the A0-101 files. I’ve finally able to open the file with all the tabs in the arduino program. (After putting all the files in a same folder, within the folder, dunno why but it worked). It’s already connected to Port 9. But now I just need to find out what kind of Arduino board is used on the Taz 5.

It’s the Rambo variant 1.3 board (ATMega 2560). Specifically it’s a board proviede by ultimaker.

I believe X/Y steps can be adjusted through the LCD panel or through terminal… Good for testing, but will be lost on powering down machine. Once you get things accurate, modify sketch, compile and upload.

So I followed all the steps and tweaked the AXIS_STEPS_PER_UNIT a bit, chose port 9, and chose Mega 2560.

But when I try to upload the new sketch, I get this Error.

Arduino: 1.6.4 (Windows 7), Board: “Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)”

Marlin_2015Q1_TAZ5_0.ino:44:101: fatal error: U8glib.h: No such file or directory
compilation terminated.
Error compiling.

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.

Hey kcchen_00

So i tried adjusting the x/y steps through the LCD panel and see what’s up. And it turns out you can save changes, so you don’t lose the adjustments after you power down, you just need to go back outside a step, and click on “Store Memory” once, and it’ll save the changes even after you power down.

Going to start test printing now to see if any changes occur. Will keep you guys posted.

The Taz5 firmware download is missing the subfolder files. If you look at the Taz 4 firmware there is an “ArduinoAddons” folder that contains U8glib.h, which is part of the driver for the LCD display. You can safely copy that folder from it’s location in the 4 directory to where it should be for the 5, and it should work.

Here’s an easier firmware flashing guide:


Looking at the available firmware I see there is a “Taz4 Single Extruder, Hexagon” Is there any difference between this firmware and the “Taz5 Single extruder” firmware? When I replaced my Budaschnozzle with the Hexagon hot end I was instructed to flash the firmware to the Taz5 Single extruder firmware…


The only difference between the TAZ 4 and 5 is the hot end and bed surface. There may be preset bed temp differences, for PET vs PEI.

Sorry to bring up this old thread, but look at your measurements more carefully, the caliper is showing right at 1" (maybe 26mm). The 21.71 mm is off from what the printed measurements are showing.