TAZ 5 Z axis issue

Hello community,

I’ve got a problem with my TAZ 5, it doesn’t go up or down with a terrible noise.

  • I tried to remove the X carriage, the problem is the same.
  • I tried to with the left motor only (right unpluged) : same issue.
  • With the right motor only (left unpluged) : same issue.
  • When I turn the left or right axis by hand, it turns without problem.

What can be the problem ?

See the video of the problem (with sound) : https://youtu.be/fdMvMKXjpKw


The only thing I can think of that would do that is if you have some of the z axis wiring harness pins swapped. It looks like you have both motors with coils in opposition to themselves, or possibly crossed between the motors. It’s either that or the firmware or rambo board is having issues.

I didn’t do anything with the wiring, and the problem occurs with only one motor plugged

I tried to flash firmware, doesn’t solve my issue. I hope its not the rambo board :frowning:

It could be a bad firmware flash, but only if you had the firmware for a completely different printer type. Any of the Taz firmwares should still turn the motors correctly.

A stepper motor works by powering two separate electromagnetic coils with the 4 wires that enter it. Two for one coil, two for the other coil. In normal operation, both coils get sent a specific amount of current for a specific amount of time to make the motor turn. One coil powered will still turn, but will feel very week and will not hold position. Two coils powered turns the shaft as normal. But if one coil is in opposition to the other, you get that grinding shaking noise. Under normal circumstances unless the pinout has been altered, the Z motor pinout is pretty well set and harcoded on a Rambo. it is possible to alter it, but again that would be unusual.

I’d try reflashing again with a differnt method (with cura if you flashed directly, directly if you flashed with cura, etc.) and see if that helps. If not, the only time i’ve ever seen that particular issue is when the coils were in opposition due to incorrect wiring. If there is another cause, I don’t know what it is. Also check the rambo board to see if one of the stick on chip heat sinks fell off and is shoritng things that are important?

I’ll try to reflash directly, I did by cura. My taz is my only printer, and I didn’t flash it recently (except after the problem occurs).

I also tried to unplug one motor, then the other one, directly from the board to be sure there is not a shortcut in the wiring, but it’s the same issue…

I didn’t see anything strange in the board box, all seems in place.

Thanks for the explanations, it’s interesting.

What are the reference of the board, i’d like to check prices…

The boards new are $170 from the source https://ultimachine.com/products/rambo-1-3 you can get a used board cheaper than that from itworks3d.com . You may also contact ultimachine directly, they may be willing to warranty exchange the board it even if your printer itself is no longer under warranty.

Thank you piercet :wink:

Just ordered the RAMBo board, hope that is the problem…
After changing it, I juste have to flash the firmware like a stock printer ?

Yes. You’ll need to know your e-steps value to modify that, it should be written down on the manual or a piece of paper that came with the printer, if not, the default values should be close but you will need to calibrate to get the best print results.

If your stepper goes back and forth like that it tends to be a bad driver chip on the control board.

What do you mean ?

look at how the coupler in the video changes direction(bounces back/forth) and not in a ‘smooth’ motion.

in fact, I don’t understand this part « it tends to be a bad driver chip on the control board », sorry

The driver, or “stepper motor driver” Is a physical circuit chip on the rambo board that makes the steppe motor go. If it’s fried you need a new rambo board. It has nothing to do with software device drivers like you install in a computer. It’s literally the chip that tells each magnet coil pair in the attached stepper motor how much current it gets at any given time.

ok, the term driver was confusing to me, I thought the driver was a software, not a hardware, thanks for the explanation !

A test to check if the motor are correct, I plugged the Z axis motors into the plug of the X axis motor, the motor works fine, so it seems it is the RAMBo board :frowning:

I ordered one, probaly will receive it this week.

Finally received my RAMBo board from ultimachine, all works fine now.

Warning, the board from ultimachine has (at least) 3 differences :

  1. no heatsink cooler for the Z chip driver

  2. no connector for the second extruder heatsink fan :

  1. Lulzbot support told me to plug the RAMBo box fan into another plug to make the fan running permanently because of the Z chip driver has no heatsink, but the pins are not available on the ultimachine board :

Also, Lulzbot support tell me to set the Zmax speed to 3 instead of 8 in the advanced configuration, they tought the default speed is too high.

Thanks to all for your help !

Huh, wierd, I’d reach out to Ultimachine and ask them why they omitted those pins. It may just be a manufacturing error. All the ones I have ever bought from them, which is an admittedly small amount, have had those pins.

Ultimachine support exchange the board, this is there response :

Hi Daniel,

I apologize for the inconvenience.

We make several “custom” versions of our RAMBo board for different distributors. The version we sell through our site is our “standard” board.

Last week we added a disclaimer type note on the order pages that reference this.

NOTE: If purchasing this board as a replacement for one received in another distributor’s printer kit, please leave an order note upon checkout regarding your printer’s name/version/distributor details. We may need to install custom pins or firmware compatible for your printer. Thank you!

If you are able to solder the pins in your self, I can ship them to you. Or, we can do an RMA return to get the board back here so we can fix it.

Great service!