Taz 6: Large prints shifting while dual extrusion printing

Hello,

We’ve been having a weird problem. We’ve been trying to print a large (30ish hours) dual extrusion print and we the print keeps shifting about half an inch on either the x or y axis. It only does this once on the print and either does it after the 2nd layer or near the top. We’ve also been able to successfully print far more complicated dual extrusion prints without any problems (though they were only a couple hours long).

We’ve checked the belt tensions and they’re all even and right, the guide rods are all straight, we’ve checked the g code in a visualizer, and we’ve tried printing at half speed. We’ve also tried setting the files up for dual extrusion in both tinkercad and 123d design, but get the same results for both.

We’re out of ideas on what could be wrong and any help would be greatly appreciated.

Did you check the belt pulley? if those setscrews are loose, the belt can shift about half an inch even with the belt otherwise fully tensioned.

The other things that can cause that are control box overheating, or computer USB port lag if you are printing from the computer directly.

Ok, I don’t know which set screws you mean, so I checked all of them and none seemed loose. We also tried printing from an SD card and it happened again, but in the middle of the first layer. The control box doesn’t feel hot, but the x and y motors do.

The setscrews are in the rim of the belt pulleys mounted to the end of the motor shafts, they hold those in place.