TAZ 6: Y motor only works in one direction! HELP!

Greetings All,

I recently purchased a used TAZ 6 to compliment my Mini.

Upon arrival I tested it out on a few small prints and everything worked fine except the PEI was terribly worn. I ordered and installed the new TAZ Etched Modular Print Bed Heater and PEI/glass print surface. I tested the new bed heater with a few small prints. Everything worked.

Yesterday I began a large two day print and was available to check on the TAZ 6 for several hours and everything was fine.

Then, early this morning I heard a terrible grinding noise that woke me up and I ran to the printer. The build plate was full forward and the grinding noise was from the belt slipping on the Y motor gear. I shut the printer off.

Later, I checked the movement of the Y motor. It moves the build plate forward but not backwards. I swapped the connection from the Y motor to the X motor and gave commands to move via the Y motor and the same problem happened on the X motor: it moves only in one direction.
Thus I’ve eliminated the Y motor as the problem.

Next, I opened her up and checked that all four wire leads to the Y motor were conductive and functional. I reconnected everything and rechecked the Y motor functions: no luck.

Then I flashed the firmware. No change. The Y motor still only works in one direction.

I read somewhere that there are 3 fuses on the RAMBO board but I could only find the one 15 amp main fuse. If there are more to check, where are they located??? (Mine is a RAMBO rev 1.3L)

With my limited tech knowledge, do you think the next step is to order a new RAMBO board?
Any and all HELP would be greatly appreciated!

Agree, your X/Y motor swap eliminates the motor as the problem. However, it could be the cable. Can you repeat that test, but swap the “board end” of the X/Y cables? A bad conductor in the cable could cause the problem you describe. Sounds like you tested the cable (“all four leads to Y were conductive and functional”) but the problem may be intermittent, or high resistance that your test didn’t catch.

If you swap the cables at the board end and the problem follows the cable… Bad cable.

If you swap the cables at the board end and the problem stays put… My next suspect would be a bad motor driver chip.

Thank you for your reply.
On the board I just tried putting the Y cable into the X connector slot.
I started the TAZ 6 and gave the command to move X and the Y build plate moved freely in both directions eliminating the Y cable (and Y motor) altogether.
I believe it’s definitely board related and the only “fix” I can think of at this point is to replace the board. I’ve since also found the two small fuses and checked them: both OK.
***Would you agree then that I will need to purchase a new RAMBO rev 1.3L Board? I’ve found the exact replacement at MatterHackers for (gulp) $180 with free shipping. Happy Birthday me! :frowning:
It seems like my bargain TAZ 6 isn’t as much as a bargain as I had hoped!

What does your end-stop status look like? Manually move the bed so it is away from the end stops (i.e., roughly centered on Y axis). Then fire it up, go to console, and send an M119 command. The response should show Y-min and Y-max both OPEN.

If either of them show TRIGGERED when the switch isn’t closed, that could be the issue. If firmware thinks it is already at Y-Min or Y-Max (due to false TRIGGER status), it won’t move the axis any further in that direction (but will move in the other direction). While you’re there, might as well also move the bed to Min and Max, running M119 each time to make sure the endstops say Triggered when they should as well.

A falsely OPEN endstop is usually a broken wire or bad switch. A falsely TRIGGERED endstop could be a short or bad switch, but usually it’s a bad board.

If endstops function okay, and given that you’ve eliminated motors and cables and firmware… Then I’m out of ideas and would lean towards replacing the board. You might hang out here a bit longer and see if anyone else has another idea to check.


Shock & Awe! M119 was the key to hunting down the problem!
The Y-Min showed TRIGGERED so I removed the build plate bracket and turned it over. There it was, barely noticeable, a detached wire from it’s connector to the rear switch caused by three of the four bracket screws missing! That allowed the entire bracket to swivel just enough to put pressure on the wire and detach it from the lower rear switch connector. I replaced the three screws and tightened the tension of the Y belt. Then I reattached the wire to the connector and slid it back on the switch. I tested that all wires were conductive and functional.
I put everything back together and tested all movement operations and everything worked as it should! I’m printing a test part now.
THANK YOU so much for your knowledgeable advice! You saved me time and money ($180.00+) by not purchasing a new Board that wouldn’t have solved the problem. I am so grateful for your help!

1 Like

Great job tracking that down!

These machines are pretty tough, but all the repetitive motion takes it’s toll on the wiring and switches. The wiring is usually the first place to look for a movement problem or intermittent heating problem. You were very methodical in your process of elimination, and that’s essential to tracking down the root cause.

Glad I saw your post and was able to assist. I don’t stop by here often, and just happened to see your post in the “weekly email” feed. Sorry for the delay – the forum used to be much more “active” than it is now.

Congrats and happy printing!


I want to make a clarification/correction for future readers of this thread. In part of my comments on end stops, I was confusing the Lulzbot TAZ6 wiring with the MINI wiring.

The MINI has it’s endstops wired “normally open”. With the switch actuated, the circuit closes and THAT is what causes the “triggered” state. On the MINI, a false “triggered” state therefore means “circuit is closed when it should be open”. That generally means either a short somewhere (unusual), bad switch (also unusual), or a bad mini-Rambo board (very common on the mini, due to people shorting the heater wires to the nozzle and sending current from the heater to the Z endstop circuit, which then always senses closed circuit).

But the TAZ6 has it’s endstops wired “normally closed”. With the switch actuated, the circuit opens and that is what causes the “triggered” state. On the TAZ6, a false “triggered” state therefore means “circuit is open when it should be closed”. That most often means a bad switch (unusual), or a broken wire (common), or a loose/disconnected connector.

For the TAZ6 in this thread, the problem was a loose (disconnected) connector at the limit switch, meaning the circuit was constantly open. For a TAZ6, that means “triggered” so the printer thought it was at the limit when it wasn’t. On a Mini, that would cause the opposite problem – an open circuit there means “un-triggered” and the firmware would keep trying to move past the endstop.

Sorry for any confusion. Original poster here valiantly read past my confusing remarks and fixed the TAZ6 in question, but I wanted to clarify for future readers who may come across this thread!