Taz5 Extruder Driver Failed...Can I trick it?

Appears that my Rambo board Ex0 stepper driver has failed. I swapped my extruder stepper to the X axis harness it it spun using the manual axis adjustment.

Anyone know how I can run off the Ex1 driver output? There must be a way either in the gcode or in the firmware to trick it…

Unfortunately I don’t think it is as easy as some gcode commands, but it can be done by downloading the Lulzbot Marlin source, changing the pins from Ex0 to Ex1 in one of the files, compiling it, and flashing it. I have done this many times so if you need help with any of that just let me know.

Yes I would appreciate that! I have never worked with Arduino code before, but I’m am pretty sure I can handle it. Any links to the right downloads would be helpful.

Thanks!!

If you want, I could build an image for you quickly so you can flash it and test it. All I would need to know is which toolhead you are using. If you want to do it yourself, the easiest way is probably getting Arduino for linux (I have had major issues on windows when doing this, but thats not to say it wont work) and downloading the Taz 5 source from here: http://download.lulzbot.com/Software/Marlin/1.1.9.28. Configure the “Configuration_LulzBot.h” for the Taz 5 and then search for the file “pins_Rambo.h”. It looks like Lulzbot already has it set to switch the pins with just one argument, so you could also look into doing it this way. But changing the whole block in pins_Rambo.h to this

#if defined(LULZBOT_SWAP_EXTRUDERS)
#define E0_STEP_PIN        33
#define E0_DIR_PIN         42
#define E0_ENABLE_PIN      25

#define E1_STEP_PIN        34
#define E1_DIR_PIN         43
#define E1_ENABLE_PIN      26
#else
#define E0_STEP_PIN        33
#define E0_DIR_PIN         42
#define E0_ENABLE_PIN      25

#define E1_STEP_PIN        34
#define E1_DIR_PIN         43
#define E1_ENABLE_PIN      26
#endif

should work just fine.

I don’t have Linux up and my PC so that would save me a lot of time. I am running the e3d v6 hot end on the original carriage.

Thank you so much! Can’t believe this is the second board in 6 months, last time was the z axis…

Ian

Thats really unfortunate. You could also reduce motor current and it might make the board last longer. I switched the motors, so here is a hex file you can flash. It should work, but please assume that this firmware is not functional and may have issues until you have fully tested it.

Modified Firmware:
https://drive.google.com/file/d/1WdA8zL6w_xE71_Gkyx0_tZWJFdNgQKSs/view?usp=sharing.

Morning Johnathan,

So it worked yesterday during a short test print. But when I started my typical print that is about 9 hours, it failed again halfway. It appears the extruder stepper is no longer working again. Could something with that motor be damaging the board driver?

There could be something about the motor or possibly a loose connection. From what I understand, loose connections can kill stepper drivers. I would say start by verifying that every motor connection is tight by pulling on each of the individual wires gently. If all of the wires are tight, it may be a stepper motor issue and not wiring. Could you also go into your printer’s configuration menu and look around for a stepper current menu? If your printer has that, tell me what your extruder current is. If it’s too high you may risk burning out the drivers, but if it’s too low you risk skipping steps.

So looking in the advanced settings printer menu I have the following:

Velocity

Acceleration

Jerk

Steps/mm

Endstop abort on/off

Are any of those the stepper current?

When I get a break from my work meetings today I will do a continuity test on the extruder harness.

Just ran the resistance test while flexing the harness and each wire was 1 ohm or less for the extruder harness.

Someone on Reddit recommended the Archim2 board to replace my Rambo board. Have you heard of this swap on lulzbot printers?

Archim2

Archim2

This is Archim2. The Archim2 board is an all in one 3D printer motherboard. It is an original RAMBo style design with the 32bit Atmel SAM3X8E processor (same as Arduino Due) and TMC2130 stepper drivers all on one integrated PCB. Archim is named afte

The Archim2 would be a great choice. I have one and I really like it, especially since it has quiet TMC2130 drivers. I did a similar swap to what was suggested on Reddit because I was initially going to buy a RAMBo 1.4, but opted for the Archim2 instead. It is a 32 bit board, has better stepper drivers, and is the same price. Just know that this will require modified software to run, but it really isn’t that difficult or tedious to get it working. I do not use Cura Lulzbot myself, but it could have minor issues connecting to the printer, although this can be fixed by clicking the “Allow connection to wrong printers” box in the settings if that happens.

Overall I think it would definitely be worth it to upgrade, knowing that it might require some work to swap them.

I use S3D myself. I’m weighing weather or not switch, sourcing that custom firmware is the tough part so far. If end up with the Rambo 1.4, I will also change the stepper in case that is the root cause.

Does the extruder need the full height Nema 17, or will the half height provide enough torque for the stock toolhead?

Thanks

Ian

I don’t know whether or not it will have enough torque, so unless you have a specific reason for the smaller motor, go with the regular sized one. Replacing that motor sounds like a good plan though.

@SpaceCowboy, the more “non-original” mods you make to your printer, the more comfortable you will need to be with the process of building and installing firmware.

The best way I found to get comfortable with the process was not change the printer at all and go through the steps of building the firmware that is currently loaded. This allowed me to make sure I had the software installed and configured properly and once I loaded “my” version of the firmware, if it didn’t work correctly (i.e. exactly like the original firmware) then I knew exactly where the problem must be. I didn’t get the build right.

In your case where the printer isn’t completely functional, you may have to improvise a little, but don’t change everything at once and then try to make it all work together (hardware and firmware).