Taz6 Marlin Firmware LCD Blank after uploading


I’ve been trying to upload Marlin to my taz6 and I’m getting a blank LCD after uploading.
I’m downloading Marlin from here: https://github.com/MarlinFirmware/Marlin and I’m trying to follow these instructions: http://reprap.org/wiki/Rambo_firmware

I added the Addons with all the corresponding libraries and nothing.
I’ve also install Rambo in the boards selection.

I go back to the factory settings by installing the hex file through Cura, but I want to be able to upload it using the Arduino IDE.

Any suggestions? Anything will help.


You can find builds of https://code.alephobjects.com/diffusion/MARLIN/ here: https://devel.lulzbot.com/software/Marlin/

Marlin uploading instructions can be found here: https://ohai.lulzbot.com/group/firmware-flashing/

I tried this suggested tutorial and I’m still getting a blank LCD.
I tried to do this with Arduino 1.0.5 and also the most recent version and nothing.
I even tried to use other Addons and other Marlin versions from different websites and I can’t upload the program properly. I’m not even making any changes to the code yet. I just want to be able to uploaded and see if it is working.
I don’t know what else to do. Any other idea or suggestion will be greatly appreciated. Thanks for your time

I fixed the upload problem. I watch this video and got the answer: https://www.youtube.com/watch?v=0pt_b2ZizQM

I uncommented this line to get the sounds from the button in the Configuration.h tab:

#define SPEAKER

and also this line: