Temp Reading Stuck

Hi guys,

I’m having some trouble with my AO-101 atm; The temp reading for the extruder in pronterface is for some reason stuck at around 93.2C. It does vary slightly when I set the temp, but not nearly as much as the actual change in temp. The range of readings is between 93 and 95 C more or less, and even when totally cool the reading never drops below there. At a temperature high enough to contact melt ABS pronterface read 95.5 degrees.

My first thought was a bad heater fuse, but that isn’t the case, and it doesn’t really make sense because the heater is still functional and responsive to settings but any setting above 96 sets it into an infinite heating loop because the reading never reaches 96. Also the fuse had no burn marks.

Next I figured it must be the thermistor, because that’s in charge of the extruder temp sensing, so I replaced it and checked the connections and everything looks fine, but the issue is still happening.

I tried hard and soft restarts on the printer and computer, and I’m pretty well out of ideas. Anyone have an idea what’s going on?


Also, the thermistor’s resistance is 84 kOhms

What kind of thermistor did you replace it with?

I replaced it with another of the same 100k Honeywell Axial Thermistors, like this:


Was a solution found to this? Mine is currently stuck around 127 C. I did all the steps that Solaiss did (except replacing the thermistor) to no avail.

I used a DMM to measure the voltage for the bed thermistor pins on the board and it was 5V. I did the same to the extruder thermistor pins and it was only about 2.2V. I would guess they are both supposed to have 5V and I don’t know why the extruder one would be halved. Both fuses on the board are fine and I don’t see any damage on the back of the board. I’ve tried resetting the board using the button next to the USB port. I tried restarting my computer. I’m at a loss as to what would cause this.

So are you saying it can’t get up to temperature?

Could it be some sort of short with the resistor?

I don’t know much about them but I wonder if your PID settings could be off.

No, that’s not the issue. When the extruder heater is set to off rather than reading room temperature it reads about 127. The bed reads room temperature just fine. When I switch the extruder and bed thermistor pins, the extruder thermistor (which is now in the bed slot on the board) reads fine so I think it must be an issue with the board - bad pins where the extruder thermistor is usually plugged in. If this is the case, do I need to get a new board or is there a way to use a different set of pins on the board?

Also, when I try to set the temp to 190, the nozzle heats up fine but it doesn’t show the correct temp. I know this because I let it heat up a while and when I switched the pins to check the extruder temp (as described above) it read almost 250, while it said only 134 using the normal extruder pins on the board.

Are your still within the warranty period? If so, contact support at Support@Lulzbot.com and we’ll do what we can to get you up and running. In the meantime, I’ve shown this thread to one of our fleet technicians, they’ll be responding soon with the recommended pin changes/assignments.


Hey guys!

Sorry to hear about the issue, we’re looking into it. In the mean time, here’s a workaround that I’ve used in the past to salvage a rambo with some damaged contacts.

In marlin there’s a page called pins.h, which stores the pinouts for a bunch of different printer control boards. Open this up and scroll down to the rambo pin assignment section (line 2068). Here you can view and change any of the pin assignments you like.

The bit you care about is:
#define HEATER_BED_PIN 3
#define TEMP_BED_PIN 2

#define HEATER_0_PIN 9
#define TEMP_0_PIN 0

#define HEATER_1_PIN 7
#define TEMP_1_PIN 1

This tells the firmware which inputs serve the different functions, so you can modify it to change which input is used for the thermistor. Since T0 isn’t working and T2 is used for the bed, I’d swap the pin assignment between T0 and T1. I’d keep the same heater output, so the modified section should look like this:

#define HEATER_BED_PIN 3
#define TEMP_BED_PIN 2

#define HEATER_0_PIN 9
#define TEMP_0_PIN 1

#define HEATER_1_PIN 7
#define TEMP_1_PIN 0

Here’s a great resource on the Rambo pinout: http://reprap.org/wiki/Rambo_development

Let me know if you have any issues implementing this.



Thanks for your help. I tried doing what you suggested. After switching the pin assignment from T0 to T1, I still have an incorrect value, except it is 166 C rather than the 127 C.

I tried assigning it to 3 and that went back to 127.

The last thing I did was I switched the bed thermistor pin (in the code) to T0 and the extruder thermistor pin to T2. That, as you would expect, made it so that the extruder temperature was reading properly, but the bed wasn’t (127 again).

I should have mentioned this in the first post, but I’m working with a AO-101, not a TAZ.

Anyway, from what I can tell, all the thermistor pin locations are bad except T2. I’m not sure how that happened but it looks like I might just need a new board…

Also, thanks Orias for contacting a tech about this. Unfortunately, it’s not under warranty.