thermistor change problem

I recently changed my thermistor to a 100k epcos thermistor in my orginal hotend from my taz5. I was printing a part to my elastic powered dart gun that need a built in rubber band. I created my own g code to stop the print at a certain height so I can insert a rubber band. While doing that my extruder was oozing pretty good and it solidified on top of the part so when resuming the print it pulled off the part from the print bed and some how it pulled out my thermistor. I followed the directions on OHAI to put in the thermistor correctly. When it was finally put in correctly I found out I burned out the resistor. so I bought three more thermistors of the mouser site(extra just in case). When I replaced the thermistor I used glue with graphite infused to paste the wires together. It worked great because it was able to withstand the high temp with easy application. The only problem was that the extruder was reading 60c hotter than it was suppose to. The first thing I thought its was was the graphite glue I got at radio shack causing to much resistance giving me inaccurate readings. I then cut off that thermistor to solder a new thermistor(same type) to the wires. Surprisingly I got the same readings as the last thermistor setup. I did some research and found out that I needed to change the thermistor type in the firmware. when I did I found out that the values changed very little when switching to the right thermistor in the marlin firmware. My first thought was that I picking the wrong epcos thermistor so I tried all of them(which is three of them , 1, 6, and 61 in the thermistor settings). The closes one was setting 6 which was only 50c off. my question is what do I do now? Can I change the table for the thermistor in the config.h and what is the processes of doing that. I’m positive I picked the right thermistor because they gave me the name and product number. It isn’t how a fused the wires together because I would be showing different readings between the electrical glue and 60/40 rosin core solder, unless they used silver solder or something which I highly doubt. Can you gentlemen give me some assistance in solving my dilemma it will be greatly appreciated .

Order the correct one from Lulzbot and solder it in. 50C is a lot of difference.

If you read the full post he stated -

“I’m positive I picked the right thermistor because they gave me the name and product number”

A runaway of the resistor is a potentially dangerous situation. I urge you to stop offering help when you have no knowledge of what you are talking about.

Now to the original question.

There must be a reason the resistor blew to begin with. Can you please post the config.h settings you currently have?

If aleph have given you the mouser part numbers I’m sure they are correct parts. You could verify this by looking at the extruder BOM that is in the development server. It might be worth posting links to the thermistor and resistors you ordered.

Be careful with what you cover the thermistor with as it can insulate the thermistor and cause bad readings. If there is something left inside the hot end, that could cause it to.

It sounds like you have done everything right. It’s probably going to come down to something blocking the thermistor inside the hole thermaly, or wiring.

Be careful and monitor your results closely and frequently. Thermal runaway can result in fire.

Since the thermistor is reading 50C higher than that actual temperature of the head, over heating will not be an issue. The heater will not be on. The extruder will be too cold.

PS Chris its a thermistor not a resistor, you said…
A runaway of the resistor is a potentially dangerous situation. I urge you to stop offering help when you have no knowledge of what you are talking about.
Now to the original question.
There must be a reason the resistor blew to begin with

Someone gave the OP the wrong part number or the wrong parts. I would start with a new one and solder it in correctly. Since I have been working with electrical from 1962 and of course electronics as I am also a licensed radio amateur I know a thing or so about troubleshooting. Did not get my master electricians license off the internet. I have built CNC controllers and converted machines over to modern controls, and lots more.
I made a very good living fixing other peoples problems and screw ups.

reading 60c hotter than it was suppose to.

You are correct, I interpreted this backwards. For some reason I thought he was reading hot end temp from a external probe.

I did not confuse a resistor with a thermistor. A runaway thermal situation can easily occur with an improperly set up thermistor. The reading of the thermistor sets the pid of the resistor.

I too am an electrical engineer currently working at a well known high end electronics company.

I have built 3d printers as well as several robots that use many of the same principals 3d printing (pid, pwm, etc)

Everything I said still stands.

Oh. I almost forgot. I’m also very experienced in avr c.

I’ll assume you know the controller boards are atmel chips…

In the interest of solving the original problem that Mep11 posted, I would suggest purchasing a digital ohm meter- multi meter and checking the thermistors sent and compare to the spec’s required. If they are the same as OEM then I would go looking for a high resistance someplace in the circuit. I am assuming it is a PTC 100K thermistor but a look at the diagram or spec’s would confirm. Since a PTC would see a higher resistance as a higher temperature that would be the logical place to start. The glue used in place of solder I am not familiar with but that might be a place to start. It would be difficult to get a good solder connection on wires coated with the stuff.

A little info on the adhesive > http://www.twi-global.com/technical-knowledge/faqs/process-faqs/faq-can-i-replace-solder-with-conductive-adhesives-as-an-attachment-material/

http://www.mouser.com/ProductDetail/Semitec/104GT-2/?qs=wgO0AD0o1vvQ2Rm%2FPgvFdg%3D%3D

It seems you could not have purchased this from mouser as it is now obsolete.



Below is the thermal settings. If you bought the same one from the BOM, Which is still available from other sources, you would have left the option at 5.

//--NORMAL IS 4.7kohm PULLUP!-- 1kohm pullup can be used on hotend sensor, using correct resistor and table
//
//// Temperature sensor settings:
// -2 is thermocouple with MAX6675 (only for sensor 0)
// -1 is thermocouple with AD595
// 0 is not used
// 1 is 100k thermistor - best choice for EPCOS 100k (4.7k pullup)
// 2 is 200k thermistor - ATC Semitec 204GT-2 (4.7k pullup)
// 3 is mendel-parts thermistor (4.7k pullup)
// 4 is 10k thermistor !! do not use it for a hotend. It gives bad resolution at high temp. !!
// 5 is 100K thermistor - ATC Semitec 104GT-2 (Used in ParCan & J-Head) (4.7k pullup)
// 6 is 100k EPCOS - Not as accurate as table 1 (created using a fluke thermocouple) (4.7k pullup)
// 7 is 100k Honeywell thermistor 135-104LAG-J01 (4.7k pullup)
// 71 is 100k Honeywell thermistor 135-104LAF-J01 (4.7k pullup)
// 8 is 100k 0603 SMD Vishay NTCS0603E3104FXT (4.7k pullup)
// 9 is 100k GE Sensing AL03006-58.2K-97-G1 (4.7k pullup)
// 10 is 100k RS thermistor 198-961 (4.7k pullup)
// 60 is 100k Maker's Tool Works Kapton Bed Thermister
//
//    1k ohm pullup tables - This is not normal, you would have to have changed out your 4.7k for 1k
//                          (but gives greater accuracy and more stable PID)
// 51 is 100k thermistor - EPCOS (1k pullup)
// 52 is 200k thermistor - ATC Semitec 204GT-2 (1k pullup)
// 55 is 100k thermistor - ATC Semitec 104GT-2 (Used in ParCan & J-Head) (1k pullup)

#define TEMP_SENSOR_0 5
#define TEMP_SENSOR_1 5
#define TEMP_SENSOR_2 0
#define TEMP_SENSOR_BED 7

Chris I had assumed it was a PTC but the part number crosses over to a NTC? Is it possible they sent him the wrong one and it will not work? A DVOM may be the only way to find out what he really has.

Well, again,
He said he got it from mouser, but I don’t see how that is possible.

http://www.amazon.com/3D-Printer-Thermistor-Semitec-104GT-2/dp/B00GWA2TZ6

It seems like the GT is not the same as the NT according to the datasheets, or at least the math is different. I didn’t convert it.
http://www.semitec-usa.com/product/index.html
The NT is however the replacement to the GT.

But looking even further into this,
according to the firmware which I posted above and took from the dev pages, they have it set to be 5, which is the thermistor I posted above that is not available from mouser. (though it is available here http://www.amazon.com/3D-Printer-Thermistor-Semitec-104GT-2/dp/B00GWA2TZ6)

Looking at the website, they sell the epcos B57560G1104*, which should be 1 or 6 according to the code above.

So, I’m a bit lost on this, and it seems someone screwed something up somewhere…

So Mep, I guess try #5 with the thermistor you have? I don’t know why they would sell a replacement thermistor that is different than the one installed. I know they changed thermistors between the budda and the all metal hex hot end. Maybe the one on the website is for the Budda and NOT for the hexagon.

One thing is for sure, and that is if you download the Taz5 firmware from the dev site (what I posted) the amazon link to the semitec GT is the one the firmware is set up for.

Looking even further…

the TAZ 4, which would have been the budda (and I double checked by looking at the software for that extruder) uses #7 in the firmware - the Honeywell.

So, I don’t know what to tell you here, but if I were you I would order the 104GT from amazon and use that with #5.

Alternativly,
Reprap discount (which I believe is where lulzbot gets their hot ends) uses the - 1x EPCOS B57560G104F NTC Thermistor (most used thermistor in the reprap community)
Which is option #1
http://www.digikey.com/product-search/en?keywords=EPCOS%20B57560G104

Interesting. I wonder what the Official replacement answer is from Taz?

Well, you can replace the original with any of the supported, you just need to remember to set it every time you flash your firmware.

I think you are looking at the wrong ones, plus it is actually a AO hexagon hotend the TAZ uses. Using a semitec thermistor, and you will find that the epcos is a different diameter and does not fit in the AO hexagon. So I wonder if you have a hexagon hotend if the Epcos fit.

If you check with i-t-w.com they have some replacement Semitec 104GT thermistors for the AO hexagon.

Yes, its a AO hexagon, but according to the BOM its sourced from reprap discount.

It’s the reprap discount hex modified for AO. What the mod is, im not 100% sure, but it does come from reprap discount.

One of the ‘mod’ is a different heat block that has a smaller thermistor hole, and is a larger thermal mass. If you look at pictures of the Hexagon and the AO hexagon you will see the block is different and the thermistor securing is done differently. One has a aluminum plate that screws down and holds the thermistor and helps hold the heat cartridge in and the other uses a piece of kapton tape that is used to hold the thermistor in and relies on the set screw in the back of the block to hold the cartridge.

alright guys it turns out I got suggested the wrong thermistor. When searching for part on mousers website I saw the thermistor I needed but I couldn’t click on the link to bring it to my cart so I just thought that it was a broken link or some bug. I called customer service and 30mins later they send me a link to a product page in which I assume is the link to the original product number I searched but it turns out they just sent me a close enough match and called it a day. The part I needed was discontinued. After I read your replies I went back to the link and saw the product numbers didn’t match sooo am I able to use these thermistors(datasheet provided) or should I try to get a refund or something. Like I said before I don’t know a lot about coding but while looking at marlin firmware I saw that you can add thermistor tables. Can I just enter the datasheet table in the firmware because the thermistor can handle temps tp 300c but what I’m wondering is it accurate enough. I’m sure the datasheet tells me everything I need to know but to me it looks like an alien language haha. Thank you guys for all your help specially since this could of been all avoid if I didn’t try to outsource the part to save a couple of bucks.
NTCThermistor_NT-461415.pdf (329 KB)

What I suggested in my first post. Lulzbot still stocks the correct one and this is a TAZ 5 correct?

According to this in your post it is " I recently changed my thermistor to a 100k epcos thermistor in my orginal hotend from my taz5" .

No, the one on the Lulzbot store does not appear to be the correct thermistor for the all metal hot end.

It doesn’t match the budda either.

Do not replace with the one from the Lulzbot store if you want the original. Order the pair from the amazo. Link I posted.

Plus it is not available in the store to be ordered anyway. :open_mouth:

The Epcos is spec-ed about .2 MM bigger in diameter than the hole in the heat block. The link I pointed to check out is the Semitec, and not the Epcos the link has in it.