TPU Filament on TAZ Pro with M175 V2 Machine Head

Hi all,

I’m working with a TAZ Pro with a M175 V2 machine head. I am wondering if anyone has advice on printing 1.75mm TPU filament without switching or modifying the machine head?

It seems like it is possible (Reddit - Dive into anything) but I’m wondering what those wiser than I would advise. It also seems that buying more expensive TPU (like NinjaTek Cheetah) makes a difference as well, does anyone have advice on which TPU to try?

This is in a public library setting, and we do prints for the public. Someone came in and asked if we could print something in TPU for them, and I didn’t know how to answer. Since I’m not an expert on 3D printers, I would hate to break my machine attempting it if it’s risky.



The m175v2 is fine for TPU. You only need to select the correct filament in the slicer.

I would stay away from the super flexible, like chinchilla, but any 90A or harder should be no problem.

@Wrathernaut Thank you! That is very helpful.

Check out Ninjatek Cheetah, it works fine in Bowden and Direct drive just fine. It depends on the hardness rating you are looking for

@WhereNerdyIsCool Thank you! I’ll mention that material to the person who is asking about printing with TPU.

I used Cheetah to print small tires for a droid project a while back and I was impressed how easily it printed.

The person who I’m doing the print for brought in 1.75mm Overture TPU, which has a shore hardness of 95A. There wasn’t a stock material profile for Overture TPU in Cura, so I selected the Ninjaflex (Ninjatek) material profile.

I kept that profile’s settings except after doing some reading about TPU filament I made the following changes:
-I changed the layer height from the default 0.32 to 0.16
-I changed the initial layer heigh from the default 0.42 to 0.28
-I turned off Enable Print Cooling
-I changed print temperature (hot end) from 225 to 235

The print started out well, the surface was smooth with no bubbling or large gaps. But I came back this morning, and the print head was about 1.5 inches above the actual object–still “printing” but no filament actually extruding. It appears that at some point the part of the machine head that grabs onto the filament and advances it had lost its grip on the end of the filament and it wasn’t extruding anymore. Thankfully there appeared to not be any clogs or anything.

So I have 2 questions:

  1. Is there a place I can find a material profile more specific to Overture PLA and import it into Cura? Or are the Ninjaflex settings close enough?

  2. Any ideas could be a cause of the machine head losing the end of the filament? Was my hotend temp too high, or do you think one of the other settings I had changed could have caused it? Any other settings I could adjust to try to reduce the possibility of that happening?


With TPU, you’ll need tension on the filament a lot higher than PLA or ABS, so make sure that tension is tight.

Your layer height seems a bit low, but not unreasonable. Temp may be slightly high for the speed you’re going. Standard Ninjaflex is 85A, while you were running 95A. You may be printing a little too slow and having filament swell and jam. Ninjaflex Cheetah is 95A. Try that profile, or semi-flex (98A hardness) was an option in older versions.

Thank you!

On the M175v2 machine head, is tension maintained just by the print settings (print speed, retraction speed and distance, etc.) or is there a was to adjust tension via hardware on the actual machine head itself?

These are the Material Profiles I can see in my version of Cura:

So it looks like the only TPU profiles I have are NinjaFlex and Armadillo. Is there a place I can go to download printer profiles? I found this page of Taz 6 Cura Profiles, but can’t find a corresponding page for Taz Pro.

Tension is done with the black knob on the spring-loaded tensioning lever on the front of the toolhead.

The steps for this are almost ridiculous, but stick with me.

The number of 1.75mm filaments is severely lacking in Cura LE. Create a new machine profile with the SE 0.5mm toolhead (a 2.85mm toolhead).

Open the materials manager. Select SemiFlex and click Duplicate up at the top.

Select the Custom SemiFlex at the top of the list. Enter 1.75mm as the diameter. THE PROFILE WILL DISAPPEAR IMMEDIATELY. This is normal.

Close Cura LE.

The profile is now in C:\Users\YOUR USERNAME HERE\AppData\Roaming\cura-lulzbot\3.6\materials
Open that folder and open the xml file for SemiFlex.

Change the first machine product to “lulzbot_quiver_lutefisk”.
Don’t change other things in this file, as even doing something that seems simple, like changing the filament name can confuse Cura to where it won’t load.

Save, close, and re-load Cura LE. Change your printer back to the Pro M175v2.

You will now have that material in your custom list at the top.

Awesome, I got it. Thank you!

That tension screw: I am assuming that tightening the screw means more tension on the filament?

Yes, turning the screw clockwise increases the tension on the filament.


I have tried a couple of prints with the new Semiflex (Ninjatek) print profile, and I seem to be running into underextrusion issues. The prints start well, and then a few rows in they start to get patchy/nonexistent, and then start back up again.

In the second picture, you can see that the skirt and the outer edges of the first layer printed well, and also the first several passes in the lower-right corner. Then it started to get patchy.

Any ideas for what could be causing this? Is it the tension issue still? I think I have the tension as tight as I can make it and still extrude. I tried adjusting the Semiflex profile to up the flow rate to 120%, but I didn’t see any difference.

Perimeters on the first layer are the slowest part. Take the speed for that and use that as the base speed for everything else, and reduce that perimeter speed down a touch more.

Thank you so much! I slowed the overall print speeds down to the perimeter speed and that helped. I also reduced the print temperature down to 210 C and that seemed even better. Here is what my first layer is looking like now:

The under-extrusion issue seems to be fixed, but now I am getting some rough layering (to the left and below the current position of the printer head in the picture). It almost seems like I’m getting over-extrusion at certain points, and the layer builds and and gets too high/thick momentarily. I haven’t ever seen this with PLA or PETG. Any ideas what might be causing this? Am I now going too slow?

Thank you for all your help troubleshooting, and I hope this thread will be useful for anyone else printing with Overture TPU: slow it down and bring the temperature down as well.



You could be a little close to the bed. If you’re laying down a .35mm layer from .25mm, there’s .1mm of overextrusion that has to go somewhere, which makes ridges to the sides of the nozzle.