trouble with z axis homing

i’m having a problem getting the z axis to move downward when it’s trying to home on a taz 4. it’s like the steppers are binding up somehow. i can run it manually from the display up and down with no problems. but when i tell it to home the x and y work be then it binds up. i’m measured both sides and they’re ok. it’s not twisting. the esteps are at 1600. i’ve swapped around the motors and still get the same thing. tried reflashing the firmware too. to 2014q3. i’m not to sure where to look at this point.

What is your Z axis vmax set to on your Graphical LCD controller? That value can be found at Control/ or Configure > Motion > Z vmax

I have been having this same problem. I can move just fine in 1mm increments but not in 10mm increments with a jog speed of 20mm/s. I made sure the x axis bars were level, lowered the speed, and checked the x axis belt’s tension. Nothing helped.

One thing I did notice some improvement on was after tightening the bolts holding the z-axis motor’s in place it allowed me to move in 10mm increments at up to 7mm’s. While this was an improvement, I still can’t auto home the z axis because the speed that requires is much higher than the jogging speed at 7mm/s. I am going to try to lubricating the lead screws.

If you know of a way to manually control the autohome’s speed it would be great to hear. I’ll keep you posted if I figure anything out!

for me, this turned out to be a problem with the ramps board. when I replaced that, everything worked fine (with all the same settings). had it happen a second time too. I figured I was getting some spikes in the power from something. I put a power conditioner on it and it’s been fine since.

i figure that whatever crapped out on the board wasn’t allowing it to put out enough amperage to push the stepper fast enough ( that’s my guess anyways)

Just to clarify, that is the RAMBo board?

I will look into it as we started running into problems right after a power outage. If you don’t mind me asking if you got it any cheaper somewhere else? $220 is a bit much imo on their website. Thanks

ya, the Rambo board was what I meant. I had originally ordered a cheap one from China, but the connections didn’t match up, and I didn’t want to go through soldering wires to the pins. i just ended up paying for the one on the site. :neutral_face:

I bought a refurbished (mini) RAMBo at UltiMachine (assembled board, no kit). Was a good deal for me.