Wildly inconsistent extrusion at start of print

Currently I am having to run my skirt at 15mm distance and 500mm min length because extrusion randomly doesn’t work reliably anywhere from the first 50-300mm of extrusion (rough estimate, I know it has gone over the default 250mm sometimes). I know that’s what a skirt is for but this seems extreme

Moreover, when it does start to extrude, it’s not extruding well, it often doesn’t adhere and forms into a blob/tangle that can get integrated into the print and mess it up.

Taz 6, Single Extruder v2.1, nGen, happens on default settings

I also have another thread on z-seam issue I am having, the two issues may be related.

Any advice would be greatly appreciated!

Something surely isn’t right. I print the minimum skirt I can, 25mm or 1 perimeter whichever is larger is how I think it works. Sounds like you may have a bit of a clog. Probably the best solution would be to heat up the extruder to about 160C, pull out the filament snip it clean above where the gear digs into the filament, heat the extruder back up to the max filament temp then feed it back into the extruder and keep extruding filament through until you get a good flow. I have to do this from time to time after a few prints and sometimes in the very next print. You can’t just blindly print, stop, and move on to the next print job (unfortunately), you need to do a little maintenance to keep everything working smoothly. After a print job I usually heat the extruded back up to the filament’s minimum temperature or 5 to 10C below and wipe the nozzle and area with a dry paper towel or rag.

If this doesn’t resolve your issue you may want to replace the nozzle with a new one and get a clean start, the old one may be too far gunked up.

That looks to be over 100 lines of text. Where do I have to type all this at. I tried to copy and paste it to my computer, but that dosent work. Do I have to create something and replace the driver?

I’ve been having this issue since my very first rocktopus print on a brand new printer (got it 1 month ago).

I’ve gotten some clogs which I’ve resolved via cold pulls, but this issues has been ongoing, which makes me think either software or hardware defect.

Is the screw that pinches the filament and the roller that pulls the filament into the extruder tight enough? At the hobbed bolt. Perhaps its slipping there? Can you shoot a short video of this problem and upload it or provide a link to the video? What’s the temperature of the extruder as the skirt is being laid down? Have you tried another type of filament?

If the bolt is tight enough and this happens with other filaments lets take a look at your Machine’s Start Gcode commands:
Preferences > Configure Cura… > Printers > Machine Settings, Printer tab, Start Gcode text box. (I doubt there’s a problem here but won’t hurt to take a look at it).

You mean the 2 idler screws? The springs are compressed to be 5mm, as I was instructed by Lulz support.

I’ve tried 3 filaments, 2 types of PLA and nGen, and had similar issues. Using default temps for everything with some experimentation withing the range.

I’ll try to do a video tonite.The gcode is all bone stock, its does that big retraction before touching off and then (tries to) extrude back to 0 before it starts to print.

All signs point to some issue whenever extrusion starts, but I’ve done the extrusion tests (e.g. mark/measure/extrude/confirm) and it seems to be spot on, and I’ve manually retracted/extruded and it seems to start extruding exactly when expected, so I 'm stumped.

Take a good look at the printed gear on the extrusion motor. Those will crack out at the grub screw hole and cause crazy extrusion problems sometimes.

I’ll check! Fwiw, the extruder seems to work flawlessly once its up and going, e.g. I can get flawless vase mode prints, so the issue would seem to be something that specifically affects the beginning of extrusion

Theres another PC in that location that works well including a fan. Its a PC though and not a laptop and the other machine is clone so its power supply would be different so not sure.

(tries to)

Maybe it’s retracting too much and loses it’s grip on the filament when it tries to put it back to point 0? I think the default retraction is 15mm? I would try commenting out the two sections, retraction & extrusion, for testing purposes. Or set the values to 5mm and give it a try.

Yes, I was talking about the two idler screws. You can also try tightening them a little more than a 5mm gap. You can tighten them all the way and then back them off a turn or two. Can’t hurt to experiment a little, worse you can do is grind the filament because they’re too tight.

Nopick also makes a good point, look for cracked components on the print head. I had to send my printer back for warranty repair, turned out that one of the 3D printed components used on the Z-axis lead screw was cracked.

I physically inspected the gears, didn’t see or feel anything amiss. I can try tighter tension.

As for modifying the g-code, I may just do like Prusa does do a “trash” extrude on the edge of the plate before the skirt, but that won’t solve what I feel like is a mechanical issue.

Yeah my gut feeling is that something is damage somewhere, I just can’t nail it down. If I just let it sit there and manually extrude/retract it never misses a beat.

What is your Z-offset set to? The nozzle being too close to the bed can can cause your problem because of too much back pressure.

Z is at the factory default, my first layer looks great after it actually starts printing

After some testing, the issue seem related to something happening either when cooled down or on the previous print. If I manually heatup and click extrude before a print, it doesnt extrude at first, but if I continue until it does, the skirt issue isn’t nearly as bad (it extrudes pretty early but still some adhesion issues on the first portion)