Filament not extruding right starting print

I recently purchased a taz 6 and ran through my first prints using eSUN abs without a problem. On the 4th print I had an adhesion failure that I didn’t catch until the print was done. Since then I have been having issues with the way my taz prints for the first minute or so. No filament is extruded of about 10 seconds which I have accounted for by making 2 laps for the skirt. But The first bit of filament that extrudes always sticks to the nozzle causing it to be dragged around the print surface and then gets in the way of the print. The problem is magnified when I turn the flow rate down to 85%. ( I was trying this for a planetary gear that I can’t seem to get to print right). I have tried cold pulling with PLA but it just breaks off in the extruder and hasn’t helped anything. Can someone please help. Thank you in advance

Quick and easy thing to rule out first - could be a partial nozzle clog, switching from abs to pla can be difficult; pla burns at abs temps and abs doesn’t want to know at pla temps. If you have any nylon or petg try cold pull with that as it’s a little stickier and do it 4 or 5 times. I think strimmer wire is nylon based if that can help. Can also be caused by an externally dirty nozzle, both by blocking/grabbing the filament as it’s extruded and by influencing the Z probing.

The other cause which I suspect it is is under extrusion, don’t mess about with flow rate just yet, and 85% is way too low for abs. If you’re cutting it down to achieve dimensional accuracy, I would suggest just printing for now and worrying about tolerances later if you’re new to printing, there is so much that can affect the final part you will give yourself headaches chasing it.

I understand Exactly what you are observing.
I see this on most of my prints and end up chasing the little goober and resulting string around
at the beginning of my prints.
Most of the time, it does not interfere with the end result, but sometimes I need a clean bottom.
From research through this forum and other places, I’ve concluded that there is something in the
TAZ6 startup script that is slightly off.
Since I’m pretty new to printing with my taz6, I hesitate to fiddle with the gcode startup script, but
here is what I truly believe what is happening.
When the print starts, quite a bit of retraction happens before the bed leveling sensor routine does it’s thing.
After the bed is level, Not enough material is pushed through the hot end to make up for the retraction that happened
for bed leveling purposes.
The result of that, is exactly what both you and me are seeing.

Maybe one day soon, I’ll build enough confidence to edit the Start Gcode.
Until then, I’ll continue to chase the little goobers around the print bed.

I hope my ramblings here helps you in some manner.

I started having the same issue with my TAZ6 so I just tweaked the starting code a tad at the end.

I replaced:

G1 Z2 E0 F75 ; extrude filament back into nozzle


G1 Z2 E5 F75 ; extrude filament back into nozzle < changed this so it pushes back an extra 5mm
G92 E0 ; set extruder position to 0 < added this to reset extruder so it doesn’t try and go back 5mm’ish to start first layer

What I think is happening is the ending script is retracting the filament 6mm:

G1 E-1 F300 ; retract the filament a bit before lifting the nozzle, to release some of the pressure
G1 Z+20 E-5 X-20 Y-20 F3000 ; move Z up a bit and retract filament even more

then when you start a new print it resets the absolute position to zero, retracts 30mm for cleaning/leveling, then returns back to 0 before printing, but that doesn’t compensate for 6mm retraction at the end of the previous print.


Just something I noticed, if you look up G92 on the reprap wiki, while it does reset coordinates, I don’t think you’re doing anything with your:

G92 E0 ; set extruder position to 0 < added this to reset extruder so it doesn’t try and go back 5mm’ish to start first layer

It doesn’t serve a purpose. E is always 0 by default. Reading the reprap site what you really are trying to do, I think, is say

G92 E5;

Which, if I’m reading it correctly, sets E5 to be the new zero. Here is the example from the site:

G92 X10 E90
Allows programming of absolute zero point, by reseting the current position to the values specified. This would set the machine’s X coordinate to 10, and the extrude coordinate to 90. No physical motion will occur.
A G92 without coordinates will reset all axes to zero.

That being said, I just ran into this problem with PETG yesterday and did exactly what you did. From what I can see, you don’t need your G92 line at all. The printer accounts for your extra G1 E5 F75 offset. I’m printing a part at the max bed size so I can’t print a skirt. The print started immediately and didn’t try to re-suck up the filament at the first layer fwiw.

Hope this helps!

Thanks for the reply, and very interesting. When just used the G1 E5 F75 right before it started printing the skirt it would roll back a bit and then start extruding again. Almost like it was rolling back from the E5 mark to the E0.2 or whatever the first layer height was.

I didn’t actually look into the code documentation I just played with putting that line in and it seemed to work well for me. Perhaps it has something to do with relative vs absolute since the first G92 E0 is prefaced with an M82 ; set extruder to absolute mode? I just interpreted that as meaning it would “remember” the position of the axis (in this case the extruder) and when the first G0 was passed it would move back to that position.

The original line told the extruder to extrude the filament back to the starting point 0(30MM) - amount pulled up during wipe process.

yours says to retract to 5(25MM) leaving 5 MM filament gap in the extruder hot end.

That isn’t the case, at least not for the TAZ 6 extruders, I can even directly put in a positive move and it will extrude, not retract. Even the notation in the provided starting and ending g-code indicates this. Perhaps you are used to working with an extruder with a reverse geared motor?

G1 E-30 F100 ; suck up XXmm of filament

G1 Z2 E0 F75 ; extrude filament back into nozzle

and I can confirm that changing the E0 to a positive number does indeed extrude more before the print starts. I tried way too high of a number at first and ended up with a giant blob on the corner of my bed and a nozzle and heatblock that needed some cleaning.

Yes, first line says move to extrusion position 30 MM and the next says move to extrusion position 0. So yes I was off on what position it goes to for a E5.