z AXIS moves are inconsistent

I’ve been having problems with he Z axis lately. I first noticed the issue when the two side were unmatched enough to bind. I leveled them and thought all was ok except a little overextrusion. While watching closely as a small disk grew ib height I noticed the Z axis motors moved in inconsistent amount. The layer size was set to 0.15 mm. Normal movement seemed to be about 10 degrees of motor rotation, but every second or third layer increase was either no rotation, or maybe 5 degrees,

I have searched the website and the web and haven’t seen anyone else mention this behavior. I’ve loosed every mounting bolt holding the Z rods in place but it still seems to skip or understep every other layer. A larger layer height misses much less. Is there an optimal “step” amount the the motors and or controller like better? I’m also wondering if it’s a rounding problem in the firmware.

I’m new to stepper controllers so it will take a while to figure out how many steps are needed for various heights, then try those out in the slicer. If someone has any insight please let me know. Fine printed objects are much poorer in quality than fast prints because the faster print doesnt miss every other step.



I’m using a reprap hexagon hot end with a .40 nozzle on my TAZ5 , getting ready to convert to bowden for dual extruders becasue the flexydually is simplly too heavy and poorly balanced. Ideally one extruder on each side of the X axis rods might work better Any weight not being pushed around constanty has to be better. At least with ABS and a 20mm fan and shroud on the hex fins keeps the filiment cool going into the hotend so a bowden setup should be ok.

After more searching this appears to be fairly common but with no real solution. This happens on the lowest layers of a print and I don’t think the stepper drivers are shutting down. I;m getting half steps or no steps and I think it’s a software issue. It should not be too hard to monitor commands sent to the stepper driver . I find it hard to believe more people haven’t noticed this.

Thats not a normal or common issue at all. it shouldn’t be doing that. Both motors recieve the same voltage, and should turn the exact same amount. Check the set screws on both sides of your coupler, make sure they are down, tight and lined up with the flat spots on the shaft. Also check that they are alligned properly. Also lubricate the leadscrews with white lithium greese if you haven’t already. Then check the motor wiring harness and see if both motors are well connected and have no loose pins.

i have checked everything i can think to check, tried different retraction settings and layed settings. With retraction z holset at .2 mm the stepper motor can move anywhere from 0 to over 90 degrees whether going up or down. With 0 z hop layer changes seem to fall short every 2nd and or third row. I dont know what to do now. I may swap stepper motors and im going to debug via the serial interface to see exactly what is being sent

You mention a retraction of .2mm, that should actually be 2mm without the “.”. Not sure if that was just a typo or not.

Hmm, ok unbolt both z motors from the machine and put 2 pieces of tape on each shaft to act as a movement indicator flag. Now simulate run the z axis up and down without the motors attached to anything. Do the flags turn at the same rate and in the same direction?

If not you have a motor, electrical or firmware issue. If they do work right you have a leadscrew, bearing, allignment, or couple issue and should concentrate your efforts there first. Determining which it is will tell you your next steps.

i get very consistent behavior using the lcd controller, but that is only moving the Z axis and doesnt use the same firmware routines except at the lowesT level. What is the rod pitch. I think its one rotation equals o.2 mm change . Time to print some values .

No one else has ever seen this? My last test print made it to layer 3, but apparently missed the reverse moves on some z hops, ending up with the nozzle against the glass, obviously destroying everything. I replaced the left stepper as a test. I used grep to get all the retract Z movements from a GCODE file, then ran the results as a gcode file. I could not detect any missed steps. The issues only occurs if there are other X axis moves happening at the same time. I am assuming from looking at the default Marlin2015Q1_TAZ5 firmware that both the left and right Z steppers are running off the third stepper driver on the Rambo board. Would it be worth to use one driver per side? I realize some rewiring would be necesary and I would lose the driver for the second extruder. I was going to increase the amperage via #define DIGIPOT_MOTOR_CURRENT {175,175,240,135,135} // Values 0-255 (RAMBO 135 = ~0.75A, 185 = ~1A), but it looks like they are close to maxed already.

Does anyone have any suggestions? There is very little resistence when manually turning the lead screws. Oh yeah. when the X carriage is moving the right hand Z stepper oscillates about 2-3 degrees, very steadily. I don’t see that on the left side. I have no idea what it means either :slight_smile: Does lulzbot support monitor these forums, or should I contact them directly ?

Thanks in advance for any help anyone can offer. I can’t print anything at all.

Support does monitor these forums, but for quicker service you will want to call them.

in an effort to better monitor the Z axis I changed the code in dogm_lcd_implementation.h to print two decimal places for the Z axis. Around line 322

u8g.drawPixel(89,35);
u8g.setPrintPos(90,37); // DGP want to see more digits
u8g.print(ftostr32(current_position[Z_AXIS]));


This shows somewhat unexpected values for Z not normal increases of the z hop distance added to a multiple of layer height. I think this is because the z axis is sometimes in the middle of a move when the screen update is triggered, but the Z axis steppers are definiftely not keeping up with the movements, often ending up against the print bed as the Z hop up wards steps are skipped but the downward hops are performed. I;ll call support tomorrow since no one else is seeing this. I can mininimize the missed steps by eliminating Z hop on retract, but that leads to stringing on some prints, and I still miss random layers in a print. Im thinking of ordering higher torque steppers as that seems to be the common fix for missed steps. I’m also going to get real linear rolloer bearings insteead of the printed plastic ones the come with the TAZ 5. For the price these should come stock. Im pretty disappointed with the TAZ 5 right now, but this seems to be an issue with all reprap printers with no actual measurement of steps to verify they took place, but the consensus seems to be that with enough torque the steppers don’t fail so adding hardware encoders isn’t not worth the added cost since that doesn’t save a print from failing if a step is missed. I’m not sure I agree and I may try adding encoders to the Z axis at least to verify that correct height is being met.

ok, i fixed it. before I tell you how lets try to guess. I even know what right thing was wrong. "The problem started after i tightened all the bolts on the printer. That is what you should do with a device that depends on a rigid frame? Wrong!! Because the X carriage hangs on only one side of the lead screw it torques it back. At some point the stresses line up and you get a bind.

Here’s my problem. If I leave the screws loose the print has the wobbles, if miss Z steps. There must be a happy medium because many TAZ printers don’t have issues. A slightly warped Z top plate could cause this, as could many other things. I think a horizontal Z carrriage is where I’ll go eventually to better distrbute the weight, as well as going to a bowden setup if I can find a better system then 4mm TPFE and retracting a foot and a half. I tried a simple set up with the Wades extruder at the top and just a hex hot end at the bottom, but it continued to exude long after the stepper stopped. There was too much stored pressure, I think from the PTFE stretching slightly. That is just a guess right now.

Has anyone had alignment issues?

David