Z-axis retraction after printing

Sometimes after printing the head retracts to home position without stopping - one smooth satisfying movement. Other times it moves up in 2-3 second spurts with a 1/2 second delay between each upward movement. It “can choose” either method of homing with the same print, so it must be related to the machine, and not the file being printed. Also (and this might be related) sometimes the z-axis fails to move the required distance up when printing, resulting in the top of a print being “smushed” by the hotted crashing into just laid layers. I have greased the threaded rods (lithium based) and cleaned the smooth rods (IPA), but to no avail? I’m reticent to put a dab of the lithium great on the smooth rods, but thinking of doing so. Any suggestions or advice please?

I’m glad you posted this since I was just about to post the same issue. My mini does the same thing. After a print, when the Z carriage moves up, it will pause on the way up. I’ve been searching on what can cause it and have found nothing.

These are some of the things I’ve tried to try to isolate where the fault (if it is a fault) is located:

  1. Use the same Gcode file: an oval base with a 12 mm high cylinder which is 10mm in diameter. Simple and takes only 10 minutes to print. Designed using Fusion 360.
  2. Scrap the print. Start again from scratch with the same design to check no inherent error in the code.
  3. Change from High speed to Standard to High detail. (profile) print in Cura. (3.6.20)
  4. Switched off Mini between any two identical printings.
  5. Pressed the re-set button between any two identical printings.
  6. Greased the threaded rods (lithium); cleaned the smooth rods (IPA).
  7. Checked both z-axes are working together, and that the build plate is horizontal to within 0.1mm
    None of the above show up the reason why on retracting the Z-axis after printing the head might run up continuously to home, or move up in a halting fashion (albeit it still gets to home).
    My Mini type 1 is fitted with the GLCD. I can run the head down the Z-axis and then up again by manually controlling it (you can do the same via Cura too, using the Manual control on the monitor page).
    The head zips up and down without halting. So if I bring the head near the build plate, and then set it to move up +140mm, the head rises in one uninterrupted movement (so long as I don’t pause when programming the +140mm, if I do it interprets it as 2 commands). The head rises without any sign of mechanical impedance. No sign or sound of the guides on the smooth rods binding - no hesitation or change of note from the stepper motors.
    From this I conclude that the halting Z-axis motion on retraction, which sometimes occurs, is not do to mechanical problems, or to anything in the G-code of the item being printed. So surely it must be in the code resident on the Rambo board in the printer. (Also: I have reloaded the firmware into the printer - cleared the cache etc, but that didn’t cure it).
    Finally, is this “fault” anything to do with the Z-axis not always rising up the required distance and so “smushing” the top of the print. Any ideas??

Cannot say much about problems with the mini but the squished layers issue I am having with a brand new Workhorse. I’ve been trying to find an answer on this forum for days so its reassuring to hear I am not the only one.

I have re-leveled by bed using the corner shims described here: SOLVED: Taz 6 auto leveling is >0.5mm off (NOW PERFECT TO 0.01mm!)

Even went as far as to re-calibrate z-steps and e-steps. Still having squished layers, only now they occur a bit higher up the print, maybe an inch off the print bed. I hope someone has a fix for this soon. Starting to lose it!