Autocad editing of freeCAD files

Does anyone successfully and easily edit the freeCAD files in Autodesk Autocad? It seems that I have to export an *.stl file from freeCAD, open it in Autodesk Inventor, then export it from Inventor as a *.dwg to open it in Autocad. Even then, I am only left with a mesh object that I can’t dimension or edit. If I export a *.dwg file from freeCAD, it never opens in Autocad as a three dimensional object, just some lines and circles flattened down to a two dimensional plane.

I feel like an idiot admitting it, but I can’t figure out how to take a dimension in freeCAD so I can redraw the parts in Autocad. In freeCAD, I use the blue measuring tape icon, click a point, go the next point and then it deselects the first point once I select the second point, and on and on.

I am running V0.13 for freeCAD, and 2012 or 2013 for Autocad. Thanks in advance for any advise.

STL is a mesh format as as such can only be considered an output-only format for CAD software, or what I call “garbage out”. You degrade your model when you export it to STL, and it’s a one-way trip.

FreeCAD can export to open CAD formats such as IGES (*.igs, .iges) and STEP (.stp, *.step), the latter being an ISO standard. (STEP has superseded IGES)

The problem is that AutoCAD cannot import either of those, through Autodesk’s own fault. They prefer to restrain their users’ liberty by offering only undisclosed proprietary file formats like DWG, DXF or ACIS (*.sat).

FreeCAD being open source, it cannot license existing commercial translator libraries. It has limited DXF and DWG compatibility (the latter through the use of the Teigha Converter, a free commercial program that has to be installed separately as including it in FreeCAD would be a license violation). Since 3D data in DWG and DXF is embedded in ACIS format, it cannot be read or written by FreeCAD, I think it can only import/export the mesh data that a 3D DWG file includes.

But you have access to Inventor, and unlike AutoCAD it does support STEP and IGES. So you just need to export a FCStd file to STEP from FreeCAD, import it in Inventor and export it back to a file format that AutoCAD recognizes.

The current measurement tool has very limited use because all it can do is give a straight distance between 2 points. But it should work reliably. When selecting a point, make sure you click and release the mouse button, then click again to select the next point.

I find it’s easier to use the Dimension tool in the Draft workbench. It has better snapping (OSnap), it is a little buggy but still much more useful than the measurement tool. For best results, select your working plane before using the Dimension tool.

You may also find that the latest “unstable” version of FreeCAD actually runs better than the “stable” v0.13.1828.

Gemini64, thank you for the short breakdown on exportable file formats and which program opens which. I was hesitant to ask any questions about AutoCAD because I know it isn’t open, it just happens to be the tool I’ve used for the last 21 years; I guess I’ve been in the Autodesk bubble for quite a while. I am now trying to learn freeCAD, but get frustrated sometimes when I don’t know if it is operator error or software error. For example:

I figured out I have to hold down the shift key (I am running Windows 8 64bit) while clicking points in freeCAD to take a measurement or dimension. So, operator error there, I have no problem admitting it.

I exported a STEP file from freeCAD, opened in Inventor (not everything transferred over but more than nothing did) and exported it as *.DWG, opened it in AutoCAD and had something to work with. So then I uninstalled freeCAD v.13.1828_x86 and installed the latest unstable version v.14.2370_x86_RC and tried to export again, but it wouldn’t export. It would bring up the dialog window, and ask what format, and you can type your file name, but after you do the save, you go to the location where you saved the exported file and nothing was there, no matter which type of file I exported it as. So uninstalled the v.14 and reinstalled v.13 and had no problem exporting. So I’ll have to stick with v.13 for now. But then I could not figure out why everything would not transfer in the STEP export from freeCAD. Sometimes when I opened it in Inventor, it would just be a 3 dimensional block, sometimes it would look almost like the piece but be missing a few things. I know freeCAD asks you to select an object before you can perform the export, sometimes I would do a CTR+A (control all) in the small window that lists (Pad, Pocket, Pad001, etc.) and do the export, sometimes I would select the bottom one of the list and do a shift+click to the item at the top of the list to select them all, or the opposite, select top item then shift+click the bottom item, and each way would produce a different output STEP file. So, I finally figured out that I have to select the last item on the list, and the last item alone, and perform the export with just that item selected, and it would properly output the entire model in the STEP file. Then the hop, skip, and a jump to Inventor then AutoCAD gave me a completely workable DWG.

Gemini64, thanks again for your initial help that pointed me in the right direction.

Parametric modeling is very different to AutoCAD. And FreeCAD is not a finished product, so I understand it can lead to frustration.

That one puzzles me. How did you export the file? From the File – Export menu? Did you select the file type in the File dialog window? There are two options, STEP or STEP with colors. Did you try both?

If you decide to have another try at v0.14 (maybe when the stable version is released?), there is another way to export to STEP. With the Part workbench active, select your part and go to the Part menu --> Export CAD.

I’m glad you figured out this was wrong.

Some explanation: when working with the Part Design workbench, you do not create different solids, but features (or operations) of a single part. Those Pad, pocket represent steps in the creation of your part. So you should not select everything, but only the last feature at the bottom of the tree. So the tree is actually your part’s timeline.

When you create a pocket on top of a pad, you will notice that the pad is automatically hidden in the 3D view, and in the Project tree. That’s because it is superseded by the last feature which is pocket. You should not go back to that prior pad, unless to apply a change to it.

Don’t hesitate to ask if you have more questions.



Yes, used File – Export menu, selected the file type from the list, gave it a file name, tried both STEP and STEP with colors. Sometimes I would type the file name first then select from the list of file types, sometimes I would type in the file extension after the file name. I tried with other file types also, OBJ, PDF, SVG, etc. and no combination would ever actually create an exported file. I would click the save button and the dialog window would close as though it created the file, but when I went looking for the file, it wasn’t there. Even tried checking to make sure it wasn’t creating hidden files.

For now though the stable version allows me to export and I think I’m going to have to take a few days to sit down and practice some freeCAD tutorials and read up to understand it better.

If I have more freeCAD centered questions, I’ll bring them up on the freeCAD forums.

Here is a short video demo of taking measurements:

It’s on an older Linux version, but the current Mac version works the same. What you can’t see is that when hovering over a line, I press the ctrl key (linux) or command key (mac). Anyway, hover over a line with the modifier key pressed and when you are on target, it will turn yellow. Then select the other line. Sometimes it can be helpful to change position or zoom in. You can see on my second measurement I had a little trouble getting the line in the corner to select.

Useful video, hemocyanin. I’d like to add the following information : you are using the measurement tools available in the Part workbench, those tools did not exist in 2013 when this topic was started.

You are probably using the Inventor navigation mode? It’s the only mode that requires use of a modifier key to be able to select geometry. If you select any of the other available modes (CAD, Blender, Touchpad) you do not need a modifier key.

To switch navigation mode, you can right-click in the 3D view and select “Nagivation style” in the contextual menu, or go to Edit --> Preferences / Display and change the “3D Navigation” setting. Besides the drop down menu, there’s a “mouse” button that opens a dialog listing what the buttons do.

And a friendly heads up: current release of FreeCAD is 0.15.4671, but v0.16 is soon to be released.

Wow – didn’t notice the date! :wink: And yes, I realize my version is a little behind the times – running on Debian Wheezy and don’t really want to do a manual install.

For what its worth, I have used AutoCAD off and on for years but nothing in the 3D world. I find if I do the standard non 3D part in either QCAD or AutoCAD 2008 LT to the correct dimensions and then Import into Fusion 360 it works well for me. I can then Extrude and finish as needed. Fusion can take DWG and DXF files and its a Autodesk product.

I never did really get the FreeCAD interface but I can see the value and work that has gone into it and understand it works for a lot of people.