Best way to align Z axis on a TAZ?

I’m sure this must be documented somewhere. Because there are 2 motors and 1 could be turned without the other when the power isn’t on.

What is the best way to align or check the alignment of the Z axis?

Certainly, you could adjust the bed leveling to account for an offset in one side or the other, but I’d prefer to be square to start with.

Can the shipping tabs be used, is there a reference point that can be used to adjust both motors to create a square relationship to something with the z axis?

Also while on this topic… I’ve noticed that when the Z axis is down close to the bed that there is a tendency for the screw shafts on the Z motors to have not be straight. Let me explain. When you home if you have the Z axis up off the bed a good ways, you’ll see at the tip of the threaded rod, that it will not be straight as it turns, it will have a wobble to it this wobble is much more pronounced when the head is down towards the bed, and less pronounced when it’s up off the bed. As you might image, the threaded part that is tracking that rod is dampening the wobble the closer it gets to the end. I would expect that this wobble will show as a slight offset in the X or Y axis as the Z axis moved up and down…

To see this, all you have to do is home the Z axis, then watch the tip of the threaded rod on both sides and move the Z axis via rapid movements up a few inches and then hit the home Z again… you’ll immediately see what I’m talking about.

Maybe I’m just used to .00001" tolerances on CNC equipment as those equipment have support on both ends of any threaded movement devices.

Anyway, figured I’d ask.

i actually had to level my X axis when I got my machine. the right side of the x axis was about 3mm lower in z compared to the left. i used a pair of digital calipers to measure the distance from the base of the machine to the bottom of the smooth rod on both the left and right side of the x smooth rod.

jebba recommended that i grasp the z threaded rod down near the base of the stepper motor (where the zip ties and plastic sheath are) and give the rod a couple gentle turns. i would run that advice by someone with more experience just to double check.

When you say “measured the distance from the base of the machine”? What did you use as the base reference point? The flat on some 80/20 or something else.

I understand how to adjust one side vs the other, just looking for the best way to in effect square up the Z (and X) axis.

Thanks I need to noodle on what you said, if you have a reference point for me I would appreciate it… I’ve got a couple of days until my bed comes back and want to get things squared away and verified while that is holding me up from printing anything.

Ideally the only portions of the printer that need to be square are the three axes to each other. You can ensure the Y axis is level across the smooth rods on either side of the bed. You could then level the x axis to the plane of that axis by measuring with a digital caliper on each side of the x axis.

The threaded rod has a dampener in the x axis to prevent any of the sway from being transferred to the print. The X axis assembly (from the motor mount to the X idler) is tight enough and well constrained.

This is how I did it.

With the machine off I removed the glass bed, and then used calipers to measure the extreme right and left sides of the X-axis smooth rod to the aluminum base of the Y-axis. Slowly rotate one of the Z motors until the rod is parallel to the aluminum base. If you rotate the rod too fast, it will also rotate the other Z-motor rod.

now that the X-axis is basically parallel to the aluminum Y-axis base. Put the glass bed back in place and turn the machine on. If you have an indicator, mount it to the X carriage. I used a long M3 screw, and a spacer and bolted it to one of the brass M3 insert nuts on the right side of the X- carriage. then just go to all 4 corners of the glass (or as close as you can get) and use the adjustment screw on the glass clamps to level it.

if you do not do the paralleling to the aluminum base first, you might run out of adjustment on the glass clamps.

We received out Taz 4 last week and we have yet to have a successful print.

It seems we are having an issue similar to what is described here, where the Z axis (supporting the x-axis carriage) is not level.

We have tried several time to level this, but it appears that, for some reason, our machine is constantly coming out of level. We can level the machine and start a print (the octopus for instance), but by about midway through the print it starts to degrade and you can see the z-axis coming out of alignment.

I’ve found that if I re-level and then place a spirit level on the gantry and run the z-axis up and down, I can watch the right side of the unit drift higher. This issue is repeatable, I can re-level the machine and repeat the drift, with the right side always ending up higher than the left.

I’m not really sure what could be causing this, but it doesn’t look like it’s something as simple as the right motor turning faster than the left. If it were, the right side wouldn’t end up high every time as it should spin the same ‘faster’ speed up as down. We’ve put in a support ticket for this, but we are under a time crunch to get some parts made so hopefully someone on the boards has an idea on what we might be able to try.

Try turning down the Z axis travel speed by using the Graphical LCD controller.

The setting can be found at;
Standby screen > Configuration > Motion > VmaxZ and reduce the value by one unit. Let us know how that changes things after doing a manual move up and down by going to: Prepare > Move Axis > Move Z : go up and down 50mm or so in 10mm, then larger increments.

Also, does your TAZ have washers on the Z axis drive nut mounting screws?

I am running into this exact issue. But I think I might be on to the cause. If I home everything from Printer Interface through usb then everything stays level.

But the moment I start using the Taz by itself to move the Z at all, it starts to get uneven and after a few moves can be off as much as a quarter inch from one side of the x to the other. For example, if I get everything right and square by turning the z bars and go into prepare>Move axis>1>z and move the z up about 100 mm, it is instantly getting all off.

But if I do the same thing from printer interface. Re-level and move 100 mm up, everything stays level. The auto home on the TAZ is really bad and messes things up quicker than anything else i’ve done. So I’m guessing so far (and I could be way wrong) that it has to do with the local control rates.

Can anyone else verify this or just prove that I am going mad from spending an entire day, like 10 hours trying to level this z axis and make it stay where I put it?

I had a similar issue with the right z motor. place a finger on the motor durring a print when the z is holding. I was feeling a very slight pulse on the rignt side. I was able to print to an extent, but had to re adjust the right side after each print as it would be high.

After quadruple checking alignment of frame and axis (I had upgraded to lead screws on my taz 3.1) support suggested some beta firmware. I was able to get rid of that pulse and the drift went away,

See if you can feel this pulse, turn off any auto leveling and run a quick print . the pulsing would start maybe 3/4 the way through the first layer. I could only feel it and didn’t hear any slipping.

I am running

Changed the
DEFAULT_AXIS_STEPS_PER_UNIT and DEFAULT_E1_STEPS_PER_UNIT to my settings my extruder rate. its different for each printer. document it before doing the upload. default is 800.

also changed these to completely rid the issue on my machine. These may only be necessary on my upgraded machine vs a stock 4.0


in configuration_adv.h

#define MICROSTEP_MODES {16,16,4,16,16} // changed 16 to 4 for the z microsteps

#define DIGIPOT_MOTOR_CURRENT {175,175,225,135,135} // changed the current for the z motors from 240 to 225.
I stepped it down 5 at a time till I could not feel any pulses on teh motors.

also changed the configuration.h only change it to match the microstepping if you changed it above.
#define DEFAULT_AXIS_STEPS_PER_UNIT {100.5,100.5,400,976.4} // changed z to 400 to match the microsteps.

also changed in configuration.h
#define DEFAULT_MAX_FEEDRATE {800, 800, 6, 50} // changed the 8 to a 6

Hope this all makes sense and it what I did to get rid of a problem with very simular symptoms.

We’ve been testing a version of Marlin with a bit higher torque on the Z axis. An archive can be found here: