Can't get any version of Cura LulzBot Edition to launch (Resolved)

Hello,

I just received my LulzBot Mini today and started to set things up. However after installing and launching Cura LulzBot Edition 19.12, the splash screen appears, disappears, then nothing happens. The drivers appeared to successfully install as well. The odd thing is, the regular version of Cura (15.04.5) boots up fine.

I’m on a Lenovo Y500 w/ Nvidia GTX 650m SLI and did a fresh install of Windows 10 but still can’t get things working. I also tried 18.03 and 17.10 but can’t get past the splash screen on those versions either. I’m about to do a fresh install of Windows 8.1 as a last ditch effort, unless anyone has any better ideas.

Does anyone have any suggestions? I’m super frustrated and all I want to do is get this printer up and running :frowning:

EDIT: I was able to get LulzBot Edition 15.02.1-1.03 past the splash screen but the “Control” option to warm up the extruder is grayed out despite the drivers successfully installing.

Try running cura from a command line. It might show the error messages that could help.

If you don’t see the control option, the software can’t talk to the printer. It’s usually a driver problem. You might try going to the machine settings and trying all the ports. The auto detect usually works, but it’s worth a try. Also try running as administrator, sometimes permissions are messed up. You might need to check device manager to make sure the printer driver got installed properly.

At least one version didn’t show the control option if a model wasn’t loaded. So load up the rocktopus or something to make sure that’s not the problem.

Thanks for the help. It actually seems to be a Windows 10 issue, as I did a fresh install of 8.1 and Cura booted straight up. The first rocktopus came out great, and now I’m eagerly awaiting for one of my own designs to finish printing.

It’s still a windows 10 issue.

I’ve tried a few versions (various 19.xx), including the latest (20.01) and either they do not load or, once I fiddle around and get them to load, they give me an error about loading the user configuration file.

Maybe related is that Cura keeps trying to create %HOMEDRIVE%%HOMEPATH% in the program folder (C:\Program Files (x86)\Cura_20.01) rather than simply browsing to that directory directly. I’ve even tried making a directory junction (mklink /j) so it can find the destination directly but it doesn’t help.

I’ve tested and used 2.1 a little, but it’s more of a hacky workaround at this point and print quality isn’t as dialed as my lulzbot editions of Cura.


Plaes halp.
y8s

What if you run Cura as an administrator? It looks like the app might not have write permissions for that path for the current user. Try right clicking on the Cura icon and choosing “run as administrator”.

I am in the admin group.
edit: nevermind, I had not tried running the program as admin.
edit2: just for fun I did this but windows restricts access to mapped network drives from within Cura–and that’s where I store everything. Doesn’t matter now though I guess.

I rebooted and it seems to work properly now. I’m not sure what’s different between that particular reboot and prior reboots since I last used Cura. it could be that some windows updates (anniversary?) have reset permissions on some folders or something and launching the program fixed them and required a reboot. I have no idea.

Unfortunately when it does this, it doesn’t create a proper logfile… unless I just can’t find them. Where are they?

I suspect when running as administrator, it was able to successfully create the file that it was complaining about. Then when you rebooted, it was able to read the file since it now exists. Speculation…

I’m sorry, I don’t know about the logs.