Why wont Cura start on my laptop

I have an Aorus X5 laptop with windows 10 on it. For some reason, Cura wont start. It will display the logo, but then it disappears. I look at the task manager and all I see is python32. What is wrong with it? Are there software that could cause Cura to shut down? I asked this on the wrong section, so I am reposing my question here.

A few basic questions -

  • What version of Win 10 are you running?
  • What version of CURA are you running?
  • Where did you download CURA from?

Best regards,

I have the Cura Lulzbot edition version 19.08, but this problem also occurred with the 18.03 version. I downloaded it from the lulzbot website. I have windows 10 pro version.

OK. When you say that Cura “won’t start” are you talking about the entire program or just the Print Controls?

The Print Controls (top image) only appear if you have a model present.
It is a bit counter intuitive as you may want to do things like Bed Leveling that don’t require a model.

If nothing shows up, there is likely something wrong with your installation.
Uninstall all Cura programs from the Control Panel and then Reinstall cleanly.

Best regards,
Screen Shot 04-23-16 at 08.15 AM.PNG

Do you have a lot of USB ports and things plugged in? I would agree with the uninstall advice and then follow the directions as installing for the first time. Is the printer being recognized when you plug in the cable? If not start with that problem. Windows 10 has issues with USB ports. IF you ever do get it recognized and working then always plug the printer into the same port. Sometimes USB cables can be bad, or work on one machine and not another.
If that’s not the issue, does Win 10 have a compatibility mode if so try running as Windows 7 program.

I had this happen to me, there is an issue with Python and your graphics drivers. I installed some python development tools so that I could try to track down the issue, and it resolved it. I wish I had more for you, but from what I could find online, it is a python graphics issue.

What was ultimately the problem AardvarkMan? I’ve read on other forums it has something to do with OpenGL. I have a Surface Book, and installed the latest nvidia drivers, removed them, reinstalled, uninstalled a bunch of stuff, nothing I do seems to matter. I tried looking for any logs that would tell me what’s causing it to no open, but I didn’t find anything useful. Any information anyone has would be super helpful! I got it working on my Surace Pro 4, but I would prefer not to use that one since it’s a company laptop. It works on my desktop, but its not co-located with my printer.
Some people said it was the MSVC++ redistributables, but i uninstalled all of them with no luck.

penn1793, are you still experiencing this problem? We’ve identified something to try which should help identify what is broken. Could you try the steps listed here: https://code.alephobjects.com/T434#5031

Not trying to hijack, but I’m having the same issue. I am on a Dell Venue 11 (i3) with Windows 10. Killed my Windows install after it ran fine once. Tried to open the next day and it would not open, and neither would many other apps on my computer. Did a ‘restore’, reinstalled Cura and it is doing this exact thing. Uninstalled and reinstalled several times. Opens to the start screen and then closes. Tried running it as Administrator and fails the same.