Cura 2.6.66 layers problem?

There I am, and I open a stl file directly in Cura 2.6.66- no problem there, however I enlarge the object by 300% and in solid its perfect with all of the bits, however when I go to layers the side bits are missing? when saved to card and I start printing out those missing bits are still missing- bit of a problem if ones printing time is 10 hours plus… I’m probably missing something in the settings any help please.
See photos:300% solid all there, 300% layers side bits missing, 100% layers all there?
If your wondering its a lego shark for my great nephew- side bits are the side fins- mouth is a movable part and thus missing to print out separately.

Is that this design from Thingiverse?

I downloaded that, and the STL has some problems. My guess is that at 100%, the holes and non-manifold issues are small enough that Cura corrects them – but when enlarged to 300%, it can no longer cope.

I ran the file through the online Netfabb service (, and that seemed to fix it up. Give the attached file a try.
shark_fixed.stl (95.2 KB)

Thanks for that! the file was actually pinched from PrintABrick- but it is the same thing- although now I have to work out shrinkage in ABS to make the two bits work together? I just wish that the time taken to print was a bit shorter! something like 13 hours and 21metres of filament! Hope the kids understand what a pain its been-
But I do wonder if Cura has problems like that surely it should be reported to the people who developed Cura? I do have a lot of pieces quite similar to that one too to do, what is this netfabb site- I had a quick look and one has to login first to use it- details please. (And how did you find it! could be very useful in the future)
many thanks for the help-

It’s not really a problem with Cura. That model renders incorrectly in Simplify3d as well (and I expect Slic3r, but didn’t check). The problem is that the model has holes (called “non-manifold”) and surfaces facing the wrong way (i.e., some surfaces are “inside out”), among other things. All the popular slicers have some ability to “repair on the fly” for minor problems, but they aren’t designed or intended to handle everything. The model needs to be fixed.

You can read all about Netfabb here: It’s pretty expensive stuff, but they provide the online “model repair service” for free – you just have to login using the secure login authenticator from Google or WindowsLive.

I just had a look at that link- wow £246 a year- you’d have to be serious about 3d printing to login on that site- I mean if you do it as a job everyday fair enough- but if you’re like me (noob) my new found hobby really only does its thing on the weekends, useful tool though- and its made me rethink about choosing difficult objects to print- perhaps there might be a cheat I could learn and then repair later, like chopping the model in half or something?
I’ve just reread your bit at the bottom “but they provide the online Model Repair Service for free”. So if I had another model in the future, I could make a new account, login and not pay the £246? But still use their service…( I think I’m liking this service even more!) They didn’t mention that on their website! I suppose if one doesn’t take the Michael- they would be ok with that? It looks like a site for professionals, and I’m far from that right now…interesting find- when I get more time I’ll give it a really good look at.
Many thanks.

I wasn’t recommending you sign up for a Netfabb account.

No Netfabb account or fee is needed for the online repair service. Just go to and login with a Microsoft or Google account. (If you have neither of those, just go create a free Google/Gmail account.)

For splitting models apart, do a google search for Blender. It’s another free (and powerful) software tool can manipulate STLs in a variety of ways, including splitting or combining models.

oop’s! I think I might have done exactly what you said not to do- I didn’t get round to reading your last message, however the site does say one can opt out after the 30 day trial and still use the software with a free non-licenced version, bugger I wish I had read your message before I started a netfabb account- hopefully I can delete that part when the trial is over.(as far as I know I haven’t given them any of my financial details- I mean what can they do?)
That software is very complicated, took me at least an hour to get use to it- lots on there I have no idea what it does? just a case of trial and error, practicing and clicking on allsorts of things I’ve never heard of before…well if I do something wrong, just delete and start again…
I wish I had seen your link instead of the free download button- I have to say it didn’t mention anything about a trial period until I had already downloaded it- and took several hours, hope I’ve not done an “amazon prime” like 4 million people did last year- and found they had clicked on the wrong thing and then finding out they owed amazon £80? because they had forgotten to opt out of the trial afterwards…if I remember rightly amazon got into a bit of trouble for that, a lot of people complained- another story for another day.
Oh c**p I hope I don’t own them any money!
After I finished this post I found I could use your link without any difficulties at all, apparently my windows account is fine opening that website- I wish I had done that first! bugger!

Found another piece that needed repairing- however the repair software can’t do anything with this piece? I’ve tried several things but no luck- its looks wrong, but I can’t verify it unless I actually print it out. And at 10hours 44 minutes at this scale that would quite a waste of time, money and filament, Cura can’t show any other detail than a slight thinning of the shell on the layers option- and netfabb online service says its fixed but when I reopen in Cura shows the same error in the layer option- however the print time has gone up by a minute? Its not a massive problem- just would have been nice to have a perfect part for my project- which if your wondering is a super sized Apollo lego set 21309 at 300% original size- which makes it just over 3 metres high. (I know its crazy!)

That’s block 6222 from printabrick, correct? I took a look at it, and it has a multitude of problems (holes, self-intersecting faces, etc.). After a netfabb repair, the entire bottom surface is still missing but Cura is fixing that on-the-fly. There are also areas where the skin is missing or incorrectly dimensioned, and that’s what you are seeing in the Cura layer preview.

It is also not “solid”. The external holes are “open” to the interior of the part, which means Cura sees the model as hollow and doesn’t provide any infill, leaving the entire top surface unsupported. You may be able to print it with Cura supports turned on, but the part strength will be severely compromised. I doubt you’ll get an acceptable print from that model.

You will find a LOT of .stl files on the internet that have problems which make them unprintable. The automatic repair routines built into Cura, and even the Netfabb service, are pretty good but can only do so much. For models with minor problems, they can usually make corrections. This particular model is just beyond their ability. It essentially needs to be re-drawn or imported to some CAD package and manually fixed.

Unless someone else here has a better suggestion, I think your best bet is probably trying to find an alternate (better drawn) copy of that STL created by someone else, or a copy that someone has manually hand-corrected (i.e., by importing into some drawing package and painstakingly fixing all the issues).

The only way of getting round this part as it stands is too ignore it and use other lego parts that do a similar thing- although I have to admit I wasn’t looking forward to printing that one- a 13hour print.
Actually your right there are a lot of errors in a lot of files I’ve found- too many for my liking and one can only do so much- I’ve often found layers missing- and repaired as far as I can see- although there’s still an issue with wall thickness- should be ok there in bits and places no one can see on the finished project any way. Perhaps I should have a long look around and try to as you advise find other places with better stl files for these pieces.
I am surprised that no one else has mentioned this problem before- as on thingiverse, people on there are starting to supersize things now and have never added any commits on any problems that have arose? But then again not everyone is doing what I’m doing so maybe we’re the first to discover this?
I’ll do what you suggest and find better files- I’m sure that someone has more updated files than I have found already- or my projects dead in the water…