Cura 2.6 is a turd (for the Mini) - had to downgrade

Hi all,

I’ve been successfully printing on the Mini for almost two years with maybe only a handful of fail prints (mostly user error) vs. two hundred plus great prints and I finally upgraded to 2.6 with new firmware… and had 10 bad prints in a row (warped objects, Cura crashed half-way, etc). I tried two version of 2.6 and also two versions of the firmware with no success… weird problems like it not extruding any filament. I tried tweaking bed and head temps with no improvement.

I decided to downgrade back to Cura 21(?) and re-flash to the last compatible firmware and the print was perfect. Also the new Cura is sloooow and had wacky issues like locking material edit for no reason (had to export/import to change settings) and lots of general unresponsive UI.

Anybody else feel the same?

We have a Taz 5 and our story is identical. We have been fighting 2.6 for a month now. Reloaded the old software and firmware and bingo, we are back in business!

Cura 2.6.66 is a disaster. It takes a lot of nerve to release something so screwed up. The GUI fails to update the screen after practically every little change to any of the settings. Worst piece of software I’ve ever seen. Reported temperatures while nozzle is cooling start going up sometimes, and prints failures with temperature errors are common. “Turd” is putting it mildly!

Thank you for your patience and understanding. We pay attention to all the feedback we see and every submitted bug report & feature request. We strive to make each release better, faster, and more reliable. You can track our progress on submitted bug reports and feature requests here:

A new version of Cura LE has been released and is now available at This version includes automatic EEPROM updating during firmware updates to help ensure the printer loads the latest firmware settings. Here’s the changelog.

@voxel which older build have you found works for your mini? I’ve lost at least half a week of work (or more) with every Cura update. I am not even sure why I upgraded again, every print has failed. The Mini is such a great machine, but the Cura software really needs a lot more in-house testing before being called production ready.

I downloaded the oldest 21.x version -

and the firmware -

Cura LE 2.6.69 update is still a turd. Just installed it this morning and it is not usable. Mac OS 10.11.6 with TAZ6 DualV2 Glad I still have my Cura 20.01 profiles

I agree with the previous posts. The newest software does not work. Printer will not print the Rocktopus at at all. Other files I have that I know to work will only print to about 21%. I have wasted SO much time on this. We have reached out and our responses have been VERY unhelpful. One response said to use the SD card; however, the mini doesn’t even have an SD card!

They should remove the newest updates and go back to the old software!!!

I guess I will have to downgrade the firmware and the software and start over AGAIN!

I tried the 21.08 software that was recommended above however it would not work. I had to downgrade to the 21.02 for the printer to work!

Finally have a successful print!!

I too have had nothing but trouble with the latest ‘Lulzbot Cura’ software and had my printers on Craigslist until discovering this post. THANKS TO ALL FOR YOUR HELP as I’m printing perfect again!!! The key for me was to uninstall ‘Cura Lulzbot’ and clear the cache and then convert to ‘Cura 21.08’. I have wrecked PEI on a mini, maybe damaged a head, and can’t get the Aerostruder to work.

Here’s my story…

I have owned a Tax 6 since November 2017 and the Mini for the last month. Just by accident I started out using the ‘Cura version 21.08’ (MacBook 2017) from day 1 and have NOT had one single issue with it. However, when I installed software on the kids Macbook for some reason I installed Cura Lulzbot 2.6.66…easier to find on website. In retrospect all three computers with the ‘Cura Lulzbot’ version are a mess. Especially the Airbook that runs my Mini. I have had the following issues; interrupted prints, leveling failures, Z-axis issues, and dry extrusion. Erratic extrusion seems to be the biggest issue. It seems like anytime I use a setting other then the “standard” it turns into a huge mess. It looks like it may retract too much during leveling but what do I know. I was super excited to use the Ninjaflex with the new Aerostruder. I had huge hopes it would fix everything, but I give up and I’m going to try and return it Monday.

For the last 2 days I have been using the “Cura 21.08” exclusively on both printers and the prints have turned out perfectly each time. The only problem with Cura 21.08 is sometimes it locks up in the middle of the print. The good thing is the print is fine. I just ‘force quit’ and restart and it’s all good.

Now, my employer has multiple Taz 5 and 6’s and I also noticed that none of my prints turn out there…guess what? My work computer has Lulzbot Cura on it!!

Question: Does anyone know if Cura 21.08 will be upgraded and supported in the future? Right now it doesn’t support the Aerostruder, which is a huge bummer. Also, I think I have to be done with the Lulzbot version…I think I have over 80-90 hours into figuring it out and I’m exhausted. I did everything tech support asked with no improvement (uninstalled, cleared cache, upgraded firmware, etc, etc). It looks like Ultimaker now owns Cura or something…true? Anyone have an Ultimaker and do you like them? I am thinking about buying a couple more printers and want something that will be supported.

@voxel thank you. I’m trying to decide if I should downgrade and spend another five days on this wreck. I had an exceptionally unhelpful series of volleys with tech support, and at this point I’m considering selling this and getting a different printer. I need something that works, preferably with people who can write their own software beyond just creating custom presets in an older branch of an open source project.

I sympathize. Glad I got the TAZ 6 so I can use the card reader. Mine came with 21.something on the SD card, and I initially used that on a laptop to run the printer. Worked great. Meanwhile, I had downloaded 2.6 onto my main computer. It seemed to work OK, so for awhile I was using 2.6 to write files to an SD card to use in the printer.

I then loaded 2.6.69 on the laptop. It loaded fine, but wouldn’t run. Hangs at “loading interface” or something like that. I uninstalled Cura entirely from the laptop, and kept using 2.6.69 to write Gcode and sneakernet it to the printer.

Then, 2.6.69 unexpectedly and spontaneously started running like crap on the main computer. It was intolerable. Took 5 minutes to start, and a minute or more to register any mouse action. Since it ran fine for awhile initially, I decided to uninstall and reinstall figuring a disk optimization or something probably corrupted it.

I could not even download 2.69 from the Luzbot site again. My virus software flagged it as malware and wouldn’t let it though. So I went to the old versions section and downloaded 21.xx (08?). That’s what I’m running now, on my main computer in my living room and using SD card sneakernet to drive the printer in my workshop.

2.6.69 LE is really a dog.


Some bright news, before wiping everything and downgrading (or alternatively throwing the printer out the window) I decided to try the alpha of 3.2. It loads much faster and I am still getting to know the update, but right off the bat the quality of prints is far superior to 2.6.69.

Finally decided to try switching from 21.08 to 2.6.

Does anyone know what happened to QuickPrint profiles(Standard, High Speed, High Detail)? Is there any equivalent in 2.6?

They’re still there! While things look different in the latest versions of Cura LulzBot Edition, you can still find exactly what you need.

Find more information on the slicing profile quality options here, under Recommended vs Custom Settings: