New Cura with old Mini?

I don’t do a lot of printing with my original Mini. Today I fired it up and installed the latest Cura and firmware. A couple of things I noticed:

  1. Cura is now showing me a circular area in the build volume and won’t let me place my models outside of the circle. What?

  2. Cura crashes a lot now. It is showing 2 Lulzbot Mini’s in the printers list, and if I try to remove either, it crashes. I’ve had a few others along the way as well.

  3. The USB works now with my laptop. The last time I “upgraded” Cura it didn’t work - which is why I stopped printing for a while.

  4. If the laptop kicks into the lock screen, then the printer hangs up and ruins the print. That’s new, and unfortunate.

Any ideas on how to resolve any of these?

I had a similar experience with my Mini and an earlier Cura LE 3 version, and I went back to Cura 21.08.

At work I can’t get a TAZ6 with flexy dually V2 to work with the latest Cura LE either, so I am looking into Simplify 3D but it does not seem to support the this toolhead out of the box. A standard mini should be supported according to their home page, but I have not tried it.

1.) Cura showing a round bed rather than a square bed is a setting option that is available in your Machine Settings. You can change that by going to Settings > Printer > Manage Printers > Machine Settings and changing the drop down menu for “Build Plate Shape” to rectangular.

2.) When you updated your Cura did you make sure to clear your cache and delete any version of Cura from the 2.x branch? If not the most likely reason for these difficulties will be those old cache files/software and once that has been cleared out it should run much better.

4.) As far as I know this has always been something to be aware of, we recommend adjusting your power saver settings on the computer to prevent it from going to sleep.

@Galadriel - thanks for the tips. I will investigate the cache-files piece.

In addition to disabling the power-saver settings (which control when the machine will turn off the display and/or sleep), I also needed to disable the screen-saver “Start after” setting to “never”.

FYI, if you’re using Windows 10 you’ll find that the Windows update function will do pretty much the same thing as the lock screen function – it’ll destroy whatever you’re printing when it runs.

It’s extraordinarily difficult to make Windows stop updating itself (Microsoft’s new posture seems to be that “You don’t own your PC – we do, and we’ll update it regardless of what you want”). Disconnecting the network (wifi or wired) when you start printing is perhaps useful.

I’d recommend octoprint on a raspberry pi or similar host, or if your Mini supports the SD card, use that instead. Or, if you have Windows 7, stay with that!

I have issues with printing on my old Mini as well. I use cura-lulzbot_3.2.21_amd64 on Ubuntu Bionic (18.04). The new cura doesn’t seem to do z-axis correction like the old one. In one area of my build plate the nozzle is too close to the plate so no filament gets extruded at all. Also I can see LCD commands in the gcode generated by the new cura although the old mini has no LCD, but that’s just a cosmetic thing.

The “no extrusion problem” is really a deal-breaker and has me using the old cura, although I’d really like the oktoprint integration of the newer versions. Am I missing a firmware upgrade or something? I can literally leave the printer as is, start octoprint with the old gcode and it prints beautifully. Gcode from the new version is unusable on my Mini 1. (4.71 MB)