Cura 2.6.66 Hang/Freeze

Hi, all:

I am running into problems with the “new” version of Cura on my Surface Studio. Cura continually hangs, takes a long time (~5 minutes) to start up, and frequently crashes when trying to modify profiles or material properties. Anyone else having these problems? I am beginning to suspect that the Intel firmware update might be generating these bugs.

Thus far, I have done a full uninstall (of this and the legacy copy I downloaded when I first got my TAZ 6). I also found all cura files as indicated on the Windows install instructions and deleted them. The reinstall has done nothing to improve performance.

I love the feature set of the new Cura, but am not able to use it as reliably as the legacy version. Thinking about switching back and losing the new functionality, but hoping someone has run into a fix.


I’ve been running into similar issues with Cura 2 Lulzbot and tended to go back to using Cura 21.8 for reliability.

But If recently upgrade to the AeroStruder and don’t believe I can use the older software with the AeroStruder??

Although the Cura2 issue were annoying, I could always restart the software and setup a print again. But the other evening the software just canned out, closed itself, mid print.

Does anyone know of any compatibility issues with hardware or software with Cura2? I’ve had the same issues on and older Intel I7 Windows seven machine as I have on my newly build AMD Threadripper with Windows 10.

Have either of you tried clearing your computers cache files? It might help with the lag you are experiencing.




HI everyone. We have had a Taz 5 for a few years now but have never had an issue that we could not figure out ourselves. That day has come. We just updated to 2.6.66 and cannot get anywhere with it. It ran fine when we were printing one job on the plate but went for a dive when we tried to do multiple parts on the plate at the same time. ( we routinely did this with the old software) We have tried everything, reload, clear cache, different computer, all the stuff already mentioned here. Now it crashes as soon as we import a part to it. Any ideas? We like the software and do not want to go back.

My list of failures in turd version 2.6.66 just keeps growing. Do the people who write this software have any experience with graphic/display interface in Windows app programming? It runs painfully slow and screen/window refreshes fail until you do something else. It appears to lock up, but it really isn’t crashing (except for the other times when it does crash when you change a simple setting), it just doesn’t know how to do things like most Windows programs do. Many annoying, non-standard things happen, for one stupid example, you enter a temperature for Pre-heat, but nothing happens when you hit the enter key after typing the temp-- you have to use the mouse to click on the Pre-heat button instead. The software designers need a course in Windows application programming. Jeez! this is annoying. Really cumbersome operation, taking much too long to get any damn thing done.

Cura Lulzbot Edition 2.6.66 Bugs and Annoyances in Windows

Why is this version so slow to start and slow in response to many actions?

With Cura running, double-clicking on an (associated) STL file in Windows Explorer causes a new instance of Cura to start instead of loading the file to the already running instance of Cura. And you have to wait a few minutes for the new instance of Cura to start. Bleh!

In the Print Monitor, typing in a temperature and hitting return does nothing – you have to type in the temperture and then click the Pre-heat button with the mouse.

Print Monitor window seems to loose focus at various times making it impossible to make entries, apparently until focus is mysteriously returned by some other action, such as switching to Print Setup and then back to the Print Monitor.

Window redraws are painfully slow, when you have to trick them into happening by pretending to do something else – often that’s the only way out.

Window redraws of the print bed don’t happen after changing the view orientation until some other action is performed, such as a right click on the window and dismissing the pop-up, then it redraws.

Refresh of windows is slow or requires other actions to make it happen, unlike every other program designed for Windows. Probably just as wonky (or worse) on a Mac or other OS. Not a Windows-display-friendly program! Very annoying!

Cura holds connection to Windows Explorer folder until closed, meaning you can’t rename the folder or do other change functions if you’ve opened a file in that folder without first closing Cura, even though you’ve closed the file. Error message says action cannot be done because the file is opened in another program, which it isn’t (Cura being the culprit).

Overall the Windows graphic interface is extremely buggy and non-standard and non-intuitive and very annoying.

Someone should have tested this version before releasing it – obviously no one did! Might be nice if it wasn’t full of bugs.

I’m still using 2.6.66 and I’ve found that most of the time when it hangs, I can un-hang it by clicking back and forth between the Print Monitor and Print Setup icons in the upper right corner of the window. The GUI needs some real basic fixing.

I am having similar problems. We have had Taz6 at work since October and using the older version of Cura there we never had an issue. We picked up another machine and computer last week so we loaded the new version of Cura and new firmware onto both machines and their respective computers. With the new computer and new machine the USB works connection works, with the older computer the USB won’t connect to either machine. I have gone through the computer and checked the USB settings and nothing has changed. This wasn’t an issue with the older Cura.

Also while loading files into Cura, I have had it freeze up multiple times. I tried letting it work itself out, but after 20 minutes I had to restart it, losing all progress. We have deleted everything and reinstalled it twice with nothing helping out.

Any advice is appreciated. We will go back to the older version of Cura tomorrow if we can’t get it to work tonight.

Can you share the details and differences between the two systems? If possible, please attach the Cura logs for computer having the issues, and we may be able to find the cause there.

We had a report that updating your drivers has helped with the runtime error:

I apologize for the late reply. The computer having the issue is a Lenovo W541 running windows 10. The one that is working is a Dell running windows 10, I’ll get the model tomorrow at work. I am not a computer guy at all so if you could tell me how to find the logs I will do that. The computer and printer won’t connect via USB, my mouse and external hard drives all work on every port so it must be a printer issue. We have swapped usb cords and that didn’t make a difference.

Right-click Start button and choose “Run”. Type %appdata%\Roaming\cura-lulzbot\2.6 into the “open:” box and hit enter. That will get you to the folder, and the log file is named “cura-lulzbot.log”.

Hey Everyone,

I’ve had a lot of issues with getting Cura to connect to my printer (Lulzbot Mini) as well. I know it is related to the Windows Creator Update, but my computer continued upgrading regardless of whether I wanted it to or not and now I can no longer revert to the pre-Creator pack.

I installed the latest firmware to the printer before the update reoccurred but it still won’t connect.

It’s becoming very frustrating being unable to print.

Called Lulzbot Support and found a fix until the bug is addressed:

Open Cura and go to settings>printer>manage printer
Select your printer and click on Machine Settings

In the machine settings under Port switch from Auto to the port that is specific to your printer

Identifying your printer’s port can be done by checking the list with the printer plugged in, closing the machine settings window, removing the printer USB, opening machine settings and noting which port has disappeared, close machine settings and plug the printer back in, select the printer port.

This should fix any issues in connecting to your printer if you had a problem similar to my own!