CURA 3.2.27 has PETG 'unsupported'

A couple years ago I printed successfully with eSun PETG on my TAZ 5. After a couple year of no 3D printing, I’m back at it. I installed CURA 3.2.27, but it has PETG ‘Unsupported’. I’ve long forgotten my settings. Does anyone have en eSun PETG profile file that I could get? Thanks!

We have included PETG profiles in Cura 3.2.32 for the TAZ 5 single extruder. We have not thoroughly tested them, and can be found under the “experimental” classification. It should be a good starting point for you!

You can find 3.2.32 at

Okay, thanks for that.

I’ve been experimenting a lot with this eSun PETG, and I have a pretty good profile developed. But now that I have it, I can’t figure out how to save it so I can get it back after printing with other things, like nGen (another of my favorites). I tried ‘Save profile’ which seemed to work, but I could not see a way to find my saved profile later. I tried ‘Save project’ but the profile specs are not restored when I restore the profile! I’m baffled. CURA 2.x had a very simple way to save and restore profiles as .ini files, but those no longer work. Surely there must be a way to save and restore my custom profiles, right? Thank you for any advice!

After making your edits to an existing profile, select “create profile from existing settings/overrides” in the profile drop down menu. This will then tie that profile to whatever material it was created from:
You can also export the modified profile from Settings > Profiles > Manage Profiles

Okay, thank you again. It turns out that the problem was that I was still using the .27 version of CURA, which has profile issues. When I first tried to save my modified profile I did exactly as you suggested here: I created a new profile and gave it a meaningful name. It appeared to work, giving no error, but when I changed to an nGen filament and then came back to the unsupported PETG that I had modified, my named profile was gone without a trace. So this morning I installed the .32 version, and now the profile interface is completely changed, and it works as advertised! Thank you.


Ahh, good catch on the .27! As we didn’t have supported profiles for the TAZ 5 with PETG, you were attempting to update a profile that didn’t exist and would explain why you could not find it later.

Glad to hear you are up and running!