cura crash 1/2 way through print - two computers

while printing this attached file cura LE(3.2.32) crashes about 1/2 way through.

I have printed other versions of this without trouble, but this one has a slight change.
As I am typing this though I am realizing I have not gone back and tried one of my older prints to confirm they are ok still.
I had it crash in the same way on two different PCs at what seemed to be the same part of the print. about 1/2 cura just goes away as an app and the printer is left waiting for more commands.
Any ideas?
I might just submit as a bug report, but wanted to see if anyone had other ideas to try etc…
I did change heads semi-recently to a areostruder - perhaps reverting to the old head might be an interesting test too.
Part Studio 1 - Part 1-castle1.stl (54.2 KB)

ok - I found some other post where a person complained of a similar issue, and in that someone suggested looking at a specific log file. I have grabbed that log file and enclosed here - it shows a Python seg fault :frowning:
I guess I will also open a bug at this point - doesn’t seem like cura should seg fault…
stderr - mid-print-crash.log (308 KB)

Bart, I ran the stl file on my Mini 2 without incident. The file printed completely without any crash. perhaps the Rambo is causing an error? It is hard to tell.