Cura v18.04 crashing

Hello All,

I am a new Lulzbot mini owner and love the printer. However, I’ve experienced consistent crashing from CURA v18.04 on one relatively large print (approx 127mmx138mmx104mm) but well within the build volume of the mini.

The print starts fine goes for about half of its estimated build time of 6hrs, 20mins before crashing with the following message window entitled:
“pythonw.exe has stopped working” with message: “A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available”.

I am using Windows 8.1.

I’ve tried printing this part using three different computers as hosts and the print fails, more or less, at the same point every time. Smaller less time consuming parts print fine.

I’ve checked the output log file and nothing there seems to indicate the problem. The print is not complex and I’ve processed it through Netfabb and gotten the thumbs up.

Has anyone else had this problem? if so, what should i do to fix it?


PS, I’m willing to email the .STL file to anyone that wants to take a look to make sure the crash is not print related

I just updated my software to 18.04, crashes on me while printing anything more than a single small object. I rarely if ever had a failed print, but right now 2 of my last 3 have crashed mid print.

Is there a link for previous versions?

Thanks for bringing this up, and we will be having our software gurus looking into the issue. In order to help diagnose the problem, please provide any specifics that you can.

In the meantime, you can find all of our archived Cura versions here:

I also had this problem with a larger print. I downgraded to Cura 17 and made sure all power saving features on the laptop were disabled. If you have a power profile in windows make sure it does not turn off hard disks & usb power. Unfortunately, I don’t know if Cura 18 or the USB power settings were the cause. I had done longer prints. ~6 hours so i doubt it was the USB power management. Posting to let LULZBOT know there are others with the same Python crash. Printer: LULZBOT Mini

I’ve had no problems with Cura 18.03. I was about to upgrade to 18.04, but I’m thinking I’ll hold off until I hear more about these problems.

Alright, LulzBot Software Engineer here. Thanks for all the reports guys. There is definitely a problem in how 18.04 was packaged for Windows. Could I get confirmation on what version of Windows that everyone here has experienced this problem on? At a minimum I know about Win 8.1 and Win 10.

While we fix this, please revert to 18.03 until a newer version is released. I’ll be sure to update this thread afterwards.

Is the Mac version of Cura 18.04 OK?

Looks like at least one Mac user is experiencing problems with 18.04. See this thread.

This has happened twice to me about 3/4 into a 7 hour run. I’m using 18.04 on a Windows Vista laptop. Short runs of 30 minutes are fine.

Okay, got it sorted out now. Fixed version of Cura is v18.05.

Internally we’ve tested that the windows printing issue has been fixed. I would much appreciate one of you guys re-running one of these failed prints to verify that it works now.

Are release notes available somewhere? I’ve looked around the site and cannot seem to find them? If its worth upgrading…

And as usual, I find it right after posting. Here’s the link for anyone else who’s looking:

No luck, unfortunately the pythonw.exe error happened again on v18.05. This was at 64.7% completed on a 8 hour 11 minute run. 3rd time its happened between v18.04 and v18.05 combined. Any sleep mode on the display, hard drive, USB ports is turned off. Very frustrating to loose that much ABS filament material 2/3 into a run.
Going to go back to v17 to see if its fine.

Can I restart a run at this point somehow? Perhaps cutting G-code parts out?

Tesla00 - that’s a bummer.

Did you have the same problems with Cura 18.03? We’ve had no troubles with that version, though we haven’t done any 8+ hour prints.

If you are attempting long duration prints, you need to adjust the power options of your windows 7 laptop properly. Otherwise you will probably run into similar issues regardless of the program.

To do so, go to the control panel and find the power options section. You need to select “high performance”. You then want to go into the advanced options, and make sure you disable any USB port power saving features, tell it never to turn off display while power is plugged in, and optionally disable all hibernation and suspend features, and tell it not to do anything on lid close.

You may also want to disable your screensaver.

Sorry to hear you ran into the same problem again tesla00! Seems as though we did not identify the real root cause. The screenshots you provided have been quite helpful. Hope to resolve this soon :blush:

easyeric, could you send me the STL you were using? Either PM or email (tait)at(alephobjects)dot(com)

Immediately after that failed print, I uninstalled v18.05, removed the failed print, installed v17.10 and re-ran the job. It had no problems getting through the 8 hr 11 min print. I had the correct laptop power settings from before when I first started printing, therefore its something with the updated Cura version.

I haven’t tried v18.03…I’m afraid to waste a day of printing.

If you are not too busy on the printer, can you run a print under 18.03 some night with no filament installed? You could turn the temperatures down as well. Just do a dry run and see if it crashes.

Fix for this is now included in Cura v19, which just entered Beta. Check it out over here:

I tried the same STL file (8 hr 11 min) on v18.03 and it hanged after ~50% completed. I’ll try v19 this weekend with the same file. Thanks for the software updates and working on the fix!

I was running, quite successfully, on v18.? since I first got my Taz in February 2016.
I was looking at one of the plugins (Tweak at Z) and it became activated.
I hadn’t actually set it to do anything, but it was still active.
I noticed yesterday that upon startup I got a message about an active plug-in from a previous session.
I set out trying to de-activate it. The ‘X’ you click on to close it was hidden on the screen… )c8
I tried a lot of blindly pressing buttons and controls without success.
I ended up with around 10 copies of it in an active state. After googling I discovered the hidden ‘X’ and deleted them.
I quit the program and restarted - still said 10 active plug-ins.
Lather, rinse, repeat and still no joy.
To my horror, I was not able to load any models - completely useless at this point.
I checked and saw that Cura v19 was available at Lulzbot.
Installed v19 and all is well. Probably a reinstall of v18 would have worked as well.
I take the blame for causing this problem, but there are a few bugs and interface issues in Cura that should share the blame.

Best regards,