Cura Crashing on Launch (ALL VERSIONS)

Hi all, I’m a new TAZ 6 operator and new to the forums here.

My problem is just as stated above. I have tried downloading multiple versions of Cure Lulzbot edition for use on the TAZ 6 and all versions have crashed on start up. The splash screen will pop up, the status will say “loading interface”, and then a white window appears and closes a few seconds later. It also does not create a shortcut to my desktop after installation.

Here is some amplifying information:

MSI Raider GE63VR 7RF
Windows 10 Home 64 bit
Intel I7-7700HQ CPU @2.80GHZ
16 G RAM
NVIDIA GeForce GTX 1070

Cura versions I’ve tried- 3.2.21, 2.6.69, 2.6.66, 2.6.63, 2.6.5

This is a brand-new computer, I’ve updated Windows and my Graphics drivers and that’s about it. I’m updating the graphics driver through GeForce Experience and Windows through the basic Windows update menu in settings. I’ve also tried completely reinstalling Windows 10.

I’ve followed the uninstall and cache clearing directions after trying each version of Cura as well.

Full disclosure here, I work at a Marine Corps unit that just purchased more than a few of these printers and I need to get Cura working ASAP so we can put them to use. I’ve been working this issue for a few weeks now and I’m not sure what else to try here.

Any help would be appreciated.

Thanks in advance!



edit: Below is what Event Viewer has to say about my crashes.

Fault offset: 0x0001dd2b
Faulting process id: 0x24e0
Faulting application start time: 0x01d41b3fdf51638d
Faulting application path: D:\Cura\cura-lulzbot 2.6\cura-lulzbot.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_ccf52835a60db6d4\ig9icd32.dll
Report Id: bfd2c4b7-2bc1-433c-a005-a51912bcb0f2
Faulting package full name:
Faulting package-relative application ID:


Make sure you clean your cache:
If this would not help, we would need the content of your CuraLE logs. <-- this is the topic where the logs can be found.

From what you describe it seems like you still have CuraLE v2.6 installed somewhere.

Also I noticed you installed it on D: drive, so changing install to C: drive might help as well.


Also the above error in ig9icd32.dll points out that the problem is actually with your OpenGL driver:
Please update your GPU drivers from here: and make sure you don’t have old drivers leftovers on your system.

Thanks for the reply alexei!

You were right the OpenGL driver fixed the issue. Turned out I was missing quite a few necessary updates.

I downloaded Driver Easy, updated the drivers and restarted.

Cura loaded up like a charm and I’m now well on my way to printing replacement parts.

Thank you for the assist!

I run cura 3.6.18 lulzbot edition on my taz 6 and have had this issue as well even after I searched my entire PC for “cura” and deleted everything then did a reinstall and still had this issue with a user agreement UI crash. I work with computers and electronics professionally so I do have a tiny bit more experience with trouble shooting issues. When I looked over my files under the programs files for cura I noticed something that could be the cause of my problems and when it fixed the issue for me (after a lot of delete and install sessions with cura) I felt I had to share with the community just how to fix it. Sorry to ramble on, so without further delay, here is how I fixed it and it’s really simple and anyone can do this.


  1. navigate to your program files and open your cura files up.

2)Scroll down towards the bottom of the files and look for a folder (it’s a zipped folder with the zipper icon going down the center of the folder) that is called “python35”.

3)Right click the zipped folder and select the option “Extract All…” with a left click while you hover your cursor over it.

You may need to make a new folder named “python35” in the programs files for cura if you get a popup or error message, but if you don’t that is fine so long as the extracted “python35” normal folder pops up in the files in cura program files. If you do get a issue from extracting just back out and create the folder mentioned above then retry to extract from the zipped folder just like the steps above.

4)Verify the new folder was created and that it is not a zipped folder (this is something the program needs to run as far as I can tell) so once that’s done you should be good to go.

5)run the program as you would normally and verify everything is working.

6)If your program loaded the next step is to stand straight up and jump up and down a minimum of 2 times to show your excitement that it is up and running ONCE AGAIN! if it did not work you have 2 options.


  1. start over and make sure to follow instructions as mentioned above with greater care or if that doesn’t work…

2)First uninstall your “cura” program first and then open up your computer panel (the place that shows you all the drives and removable media) and in the search area (on windows 10 it is towards the top right) and be sure to delete all files that have “cura” in it that one aren’t repetitive, since you may have several results that are the same file so delete them as they show up in the search to limit the search results) but DON’T DELETE files that have the word “cura” in it since these can contain files used for other programs you may need so not just the “cura” name alone found somewhere.

2a) Once the program in uninstalled and the search is done with NO remaining"cura" file results found you can continue back to the start.

NOTE: this may not work in every situation and or cura version or model IE “cura lulzbot edition” etc. If that is the case yo have a larer issue/s at hand and may want to contact whoever the software was modified IE lulzbot, Ultimaker etc for further assistance.