Cura for Monoprice Maker Select V2?

I bought a Maker Select V2 several years ago. It either linked to, or came with, a very old version of Cura Lulzbot (21.03 I think?). I’ve been using it on Debian Linux ever since. I’ve tried upgrading Cura over the years but always run into some issues that I end up just going back to 21.03.

Lately I noticed support structure isn’t being generated in my prints anymore. I have the overhang set to “0” which should generate a crazy amount of support.

This is my settings and the part I’m trying to print. The slot at the bottom should be showing support structure. Maybe I’m remembering a different version of Cura but thought the supports show up in blue when viewing the toolpath in “Layers” view.

I’ve downloaded the latest Cura-lulzbot (3.6.37-deb10) but there is no longer an option for the Monoprice Maker Select V2 or Wanhao i3 (a clone compatible of the MSV2, or vice-versa).

A few questions:

  • How can I get support structures generating again in 21.03?

  • The 21.03 interface has settings in so many places it’s dizzying trying to find things. Is there a text file somewhere I can open up and just edit? I found some older ones in ~/.config/cura but the 21.03 and 3.6.37 directories are not there

  • What’s the method for creating a new machine definition in Cura 3.6.37?

  • Anyone have a MSV2 def they would be willing to share?

The printer model specific parts of the profile should be the same so copy them from 21.03 to 3.6.37. Start with Add Printer…, click Other, select Custom FDM printer.

Have you tried Ultimaker Cura 5.1.0? I believe there is a profile for your printer.

Thanks for the info.

Yeah, I tried Ultimaker Cura 5.1 but had a glibc compatibility. Not sure why. I’m on a debian 10 compatible derivative (Devuan) but it doesn’t have systemd so might be something to do with it. Not sure.