Cura-Lulzbot v3.6.13 layer height setting issue

Using 3.6.13 on the Mac with a Taz Pro (standard dual extruding head).

When I create a custom profile for a material, all settings are correctly saved to the the configuration file (included below). However, layer height always defaults back to 0.3mm (the original value in the “Standard” profile from which this profile was copied).

Might this be a bug with dual-extruding heads where the “link” between heads condition forces the layer height parameter to never apply correctly?

As you can see in the config file below, it is correctly set to 0.25mm. Any ideas on where to look next?

version = 2
name = Standard {Bill} #3
definition = lulzbot_quiver_evergreen_bagworm

type = quality_changes
quality_type = standard
setting_version = 4
material = PLA_(Verbatim) #2_lulzbot_quiver_evergreen_bagworm

default_material_print_temperature = 205
layer_height = 0.25
layer_height_0 = 0.35
material_bed_temperature = 60
material_final_print_temperature = 180
material_initial_print_temperature = 185
material_print_temperature = 195
material_print_temperature_layer_0 = 200
material_probe_temperature = 140
material_soften_temperature = 140

…answering my own question – I think.

It’s that the second extruder has “No Material” selected, and thus a different Profile (as profiles are tied to Materials). At load time, I suppose Cura tries to resolve the conflicting layer heights between the Profile selected on Extruder 2 and the profile I’m loading on Extruder 1.

The whole UI around Profiles, Materials, (and now the complication of two different extruders) is a bit fiddly. My gut tells me there’s a better abstraction for all of this, but I don’t yet know what to suggest.

When doing a dual extrusion print, both layer heights need to be set the same in order to prevent collisions of the print head and printed object when switching between the two. In order to ensure that this does not happen, Cura LE will automatically average the two layer heights when set differently. In this case, I suspect you have a high speed profile selected at 0.35mm layer height.

In Cura LE 3.6.15 we fixed the mechanics of “No Material” to ignore all settings for the extruder that is selected for. This should greatly help when only using one extruder for printing and prevent any of the averaging you were describing above. You can find the newest version at

Is “No Material” only available to disable linked extruder settings? Selecting “No Material” can’t change the START GCODE Block so the second extruder will still heat up, purge, and remain heated to the print temp (210C) for the entire print unless you manually shut it off, correct? If this is the case, I believe the best workaround is to use the “No Material” profile with a modified Dual Extruder machine profile with the second extruder GCODE in the start and END blocks removed so that you are not fighting with linked settings and the second extruder remains inactive the entire time.