Does Cura work on Ubuntu/Bionic?

I just purchased a Taz Workhorse, and would like to get a version of cura-lulzbot with the workhorse
printer profile running on my Ubuntu system. My system is completely up to date, and should
be a valid LTS version: Linux 5.0.0-32-generic #34~18.04.2-Ubuntu.

The non-lulzbot version of cura runs fine on my system: version 4.4.1.

The lulzbot website says that 3.6.23 is the current version, but the links on the Ubuntu/Bionic download page point to 3.2.21 ? I download that version and there is no entry for “Workhorse” in the printer list.

On git lab, the most recent release is 3.6.22 (but not .23 ?) I download that version and when I run
it it says version `GLIBC_2.28’ not found. The website Debian download link (not Ubuntu, but compatible) goes to 3.6.22 as well, when I install that one I also get the GLIBC error.

Tried successively to download the following versions, looking for one that does not link to
GLIBC_2.28:

cura-lulzbot_3.2.21_amd64.deb
cura-lulzbot_3.2.32_amd64.deb
cura-lulzbot_3.6.20_amd64.deb
cura-lulzbot_3.6.21_amd64.deb
cura-lulzbot-3.6.22-Buster.deb
cura-lulzbot-3.6.22-Linux.deb
cura-lulzbot_3.6.8_amd64.deb

ldd --version shows: ldd (Ubuntu GLIBC 2.27-3ubuntu1.3) 2.27

Looked for printer description files on gitlab, to no avail.

Q1: Will the Workhorse printer profile work with the non-lulzbot version of cura, and if so can I get a copy of those somewhere? That would be a quick fix and I’ll just use the non-lulzbot version.

Q2: Will the workhorse profile work with with 3.2.21 version? If so, that version works on my system and can I get that profile somewhere?

Q3: Alternately, would the 3.6.23 version work on Ubuntu/Bionic and if so where can I get that?

Q4: Alternately, is there a version of cura-lulzbot that has the Workhorse profile and will work on Ubuntu/Bionic that I’m missing?

My system is completely up to date, and I’ve purged the .config/.cache files before each install,
and purged the previous install before attempting a new one (including the non-lulzbot version of cura).

What can I do to get a working version of cura-lulzbot with a Workhorse profile?

Sorry for the large post, I wanted to show what I have already tried in order to save time.

At this point it takes a bit of work to get Cura LE working on Ubuntu. That is due to the dependencies being out of date. We are working on this issue. As for the debian version of 3.6.23 that is still being built and will be uploaded soon. Cura LE files can be found at https://gitlab.com/lulzbot3d/cura-le/cura-lulzbot . If you have any expertise in the area of updating dependencies or want to try your hand at making your own build of cura you should be able to find resources on our gitlab.

I unpacked the 6.22 version and surgically moved the workhorse files over into the 2.21 install, not for the faint of heart as it involved modifying some source code files.

This seems to work for now. I might try building from gitlab at a later date, but initial/quick attempts to do that last night failed.

I can no longer control the machine from USB, but printing from memory card seems to work. I’ll keep an eye on it in case it escapes and goes on a rampage in the nearby peasant village.

I myself havent tried building cura on ubuntu. I am not the original maintainer/developer of Cura LE so I am working my way through the source code. It seems the original intent was to only build on debian/windows/mac but as there aren’t clear instructions about how they maintained the dependencies it is a bit of a hassle to bring it up to date.

I’m guessing you are the maintainer.

If I get it to build on ubuntu, do you want the changes and procedures (for free)? I can do spot testing, but it would need the full-on testing that you are probably better situated for.

If you are successful it would be a great resource for the community. Feel free to post a guide/walkthrough on the forums, tag me in it if you get there!

Hello Robert and Peter,

Ah, Debian packaging… been there. For a few years, I was the maintainer for the FreeCAD Maintainers Team providing FreeCAD stable and daily builds packages on a Ubuntu PPA. Not being a dev myself, I can’t say I was much good at it, having wide gaps in my understanding of it. I’m also not privy to the newer debian packaging tools. Thankfully more knowledgeable people have replaced me.

I’m currently using the cura-lulzbot 3.2.21 package on Ubuntu 18.04. I sure wish I could use the latest version. Right now cura-lulzbot isn’t properly packaged. There should be a source package to accompany the binary package, making it easier for users to repackage it. There should be a repository available with files used to build the package to Debian guidelines. Of course, that’s the “official way” of doing it, and you may not find it high in your priorities, which I would find completely understandable. :smiley:

I may be mistaken, but that may just be because the package was built with glibc 2.28, a newer version than the one contained in Ubuntu 18.04. All that may be needed would be to build it with the proper dependency versions. This is what the Ubuntu PPA does, it provides specific packages for each active Ubuntu version.

Is Cura-LE diverging much from UltiMaker Cura? It doesn’t look like it, from an end user perspective (the version number discrepancy notwithstanding). UltiMaker Cura is already in the Debian repositories, it might be used as a base to build Cura-Le?

Here’s the webpage for the cura 4.8 Debian package on Sid (unstable): https://packages.debian.org/sid/cura

And here’s the Git repository used to build the package:

All the magic happens in the /debian sub-folder. The “control” file for example lists the dependencies. With this method, cura-engine and uranium are built as separate packages (uranium having 3 packages). When the user installs the cura package, it automatically pulls out the cura-engine and uranium dependencies.

Of course, packaging it the same way would require you to set up your own Debian repository, as providing multiple packages with a specific install sequence wouldn’t be practical. Having yet another service to set up and maintain might not be what you wish if your workload happens to encompass other things than this packaging task. Canonical freely provides the Launchpad.net service to distribute Ubuntu packages through PPAs (don’t know how long it will last considering their push to snap packages), but they won’t work for Debian.

One thing you might consider instead in the long run is looking at providing AppImages, which are usable across a wide range of Linux distributions, and which solve a lot of dependency headaches, because they contain their critical libraries.

Food for thought…

Cheers,

Norm

I don’t think you needed to do that. I’ve been looking at creating a setup for my old (and obsolete) LulzBot AO-100 printer. Doing it through the GUI does not provide enough settings.

I found that you can create new profiles and add them to ~/.local/cura-lulzbot/3.2/ (or whatever version you have) under the appropriate sub-folders, and at launch, Cura-LE will scan this folder.

So all that you would need to do is to drop the workhorse json files in /definitions/, /extruders/, /materials/ and /meshes/, the latter if there’s an STL of the workhorse print bed, but it’s only optional.

See https://github.com/Ultimaker/Cura/wiki/Adding-new-machine-profiles-to-Cura

I’m still trying to figure this all out. My first tries prevented Cura-LE from launching! Now I’m at the point it launches and my printer is there, but is unusable because no material is available. I’ve reverted to using Printrun for now because I really wanted to 3D print again, but I’m going to get back to it at some point. Cura-LE has a very nice modern UI.

Hope this helps!

I’ve decided not to fix up Cura-LE. My modified version works well enough, and I can wait until lulzbot updates their version. Or not, as the case may be.

I do open source development and AI research, and have the choice of doing that or fixing up Cura-LE.

Fixing an administrative problem, for a company for free, who considers linux low-priority, and that would probably be superseded by their next release, and for which I don’t have proper testing facilities, and putting off my open source projects and research… doesn’t hold a lot of interest for me.

We all know what the right solution is, doing it the right way would reduce lulzbot’s software burden to a minimum and avoid all these issues going forward. It would save them a bunch of money over time.

Let’s hope that they decide to do that at some point.

I understand you completely. My reply was mostly addressed to Robert, who seems to be employed by Lulzbot?

Well, you can see it that way: Lulzbot does provide an open source software with source, and even if the Linux version lags behind the Windows one, at least it’s something most other manufacturers don’t do. Also, I get the feeling this is a small to medium business, considerably scaled down from the good years of Aleph Objects (which went under a year ago and was bought by another company and moved to ND). Having worked 30 years for SMBs, I can tell you that if they’re anything like the companies I’ve been with, they’re constantly short-staffed, and people get to wear many hats. Case in point: I had to spend the last two weeks before Christmas producing technical specs sheets of our product line rather than actually do the job I’m paid for (product design).

I’m not trying to be confrontational, I’m just curious about what you would consider the “right” solution, because I don’t know it. Would it be to stop maintaining a fork of Cura and contribute to the original Cura by UltiMaker? Since they’re competitors, I’m not sure that would work. I’ve noticed that UltiMaker’s version has many printer configurations from other companies, but none for Lulzbot printers. There’s also the matter of branding.

I do like the Lulzbot green theme better than the UltiMaker one. And the cura-lulzbot deb package is better integrated to my GNOME desktop than UltiMaker’s AppImage or the unofficial snap package from the Ubuntu store (which both show severe anti-aliasing issues and small font size).

Cura versions newer than 3.2 are released again in the stable PPA.So it works.

Yeah, but not for the workhorse.

The original post was looking to use the workhorse on ubuntu. You still don’t support that.

I finally got around to checking this and… no workhorse profiles in
the ubuntu version of your software.

You’re still not supporting workhorse for Ubuntu users.

UPDATE: The debian version (3.6.23) will install on Ubuntu systems, although that’s not something to recommend to casual users. It seems to work OK.

It gets the wrong machine type, with the following message:

“Expected that MACHINE_TYPE was TAZ Workhorse Edition Rev B, but got TAZ Workhorse Edition instead”:

My printer firmware is current (per the upgrade panel), so this might be just a name difference. I’ll try a print and see if it’s OK.

Looking at the file “lulzbot_redgum_base.def.json” seems to imply that the 2 machine types are the same.

Can someone confirm?

(Seems to be working, hasn’t crashed the head or anything.)