Dual V3 and Simply3D

Anyone have a good config for Simply3d and the new dual v3? I tried the gcode off set but it does not seem to work or I am doing it wrong. This is what I have:

M218 T0 X0 Y0 ; set T0 offset
M218 T1 X-6.5 Y6.5 ; set T1 offset

Any help would be great. Simply gave me a new FFF Profile but the head just crashed into the leaving washer side.

You want either:

M218 T0 X0 Y0 ; set T0 offset
M218 T1 X13 Y0 ; set T1 offset


M218 T0 X-6.5 Y0 ; set T0 offset
M218 T1 X6.5 Y0 ; set T1 offset

or neither. The TAZ knows where the nozzles are from the firmware (for wiping and probing), and using M218 can easily cause that to go off the rails. In the G-Code page in S3D, look for the “Toolhead Offsets” section and set the X=-6.5 for T0 and X=+6.5 for T1. Make sure you check the “Apply toolhead offsets…” box so that your offsets get used.

There are dual toolhead alignment patterns on thingiverse. You can use them to fine tune the nozzle spacing numbers.

Make sure you execute an M218 T0 X0 Y0 and M218 T1 X0 Y0 followed by M500. This will clear out any stray toolhead offsets.

As mentioned above, dont write offsets to the machine, just set them in the tool params and apply to gcode.
Starting GCode :

G26                          ; clear potential 'probe fail' condition
G21                          ; set units to Millimetres
M107                         ; disable fans
G90                          ; absolute positioning
M104 S140 T0               ; soften filament
M104 S140 T1               ; soften filament
M140 S[bed0_temperature]; get bed heating up
G28 X Y                      ; home X and Y
G1 X-17 F3000                ; clear X endstop
G1 Y258 F3000                ; move over the Z_MIN switch
G1 X-19 F3000                ; move left as far as possible
M117 Heating...              ; LCD status message
M109 R140 T0               ; wait for temp
M109 R140 T1               ; wait for temp
T0                           ; return to first extruder
G28 Z                        ; home Z
T0                           ; select this extruder first
M82                          ; set extruder to absolute mode
G92 E0                       ; set extruder to zero
G1  E-15 F100                ; suck up XXmm of filament
T1                           ; switch extruders
M82                          ; set extruder to absolute mode
G92 E0                       ; set extruder to zero
G1  E-15 F100                ; suck up XXmm of filament
M104 S140 T0                 ; set to wipe temp
M104 S140 T1                 ; set to wipe temp
M106                         ; Turn on fans to speed cooling
G1 X-17 Y100 F3000           ; move above wiper pad
M117 Cooling...              ; LCD status message
M109 R140 T0                 ; wait for T0 to reach temp
M109 R140 T1                 ; wait for T1 to reach temp
M107                         ; Turn off fan
T0                           ; switch extruders
G1 Z1                        ; push nozzle into wiper
G1 X -18 Y95 F1000                   ; slow wipe
G1 X -18 Y90 F1000                   ; slow wipe
G1 X -18 Y85 F1000                   ; slow wipe
G1 X -17 Y90 F1000                   ; slow wipe
G1 X -18 Y80 F1000                   ; slow wipe
G1 X -17 Y95 F1000                   ; slow wipe
G1 X -18 Y75 F2000                   ; fast wipe
G1 X -17 Y65 F2000                   ; fast wipe
G1 X -18 Y70 F2000                   ; fast wipe
G1 X -17 Y60 F2000                   ; fast wipe
G1 X -18 Y55 F2000                   ; fast wipe
G1 X -17 Y50 F2000                   ; fast wipe
G1 X -18 Y40 F2000                   ; fast wipe
G1 X -17 Y45 F2000                   ; fast wipe
G1 X -18 Y35 F2000                   ; fast wipe
G1 X -17 Y40 F2000                   ; fast wipe
G1 X -18 Y70 F2000                   ; fast wipe
G1 X -17 Y30 Z2 F2000                ; fast wipe
G1 X -18 Y35 F2000                   ; fast wipe
G1 X -17 Y25 F2000                   ; fast wipe
G1 X -18 Y30 F2000                   ; fast wipe
G1 X -17 Y25 Z1.5 F1000              ; slow wipe
G1 X -18 Y23 F1000                   ; slow wipe
G1 X -17 Z15                         ; raise extruder
M109 R140                   ; heat to probe temp
M204 S100                    ; set accel for probing
G29                          ; probe sequence (for auto-leveling)
M204 S500                    ; set accel back to normal
M104 S[extruder0_temperature] T0 ; set extruder temp
M104 S[extruder1_temperature] T1; set extruder temp
G1 X98 Y-18 Z0.5 F3000       ; move to open space
M400                         ; clear buffer
M117 Heating...              ; LCD status message
M109 R[extruder0_temperature] T0 ; set extruder temp and wait
M109 R[extruder1_temperature] T1; set extruder temp and wait
M117 Purging...              ; LCD status message
T0                           ; select this extruder first
G1  E0 F25                  ; undo retraction
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F25                  ; purge XXmm of filament
T1                           ; switch to second extruder
G1  E0 F25                  ; undo retraction
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F25                  ; purge XXmm of filament
G1 Z0.5                      ; clear bed (barely)
G1 X98 Y0 F5000              ; move above bed to shear off filament
T0                           ; switch to first extruder
M190 [bed0_temperature]; get bed temping up during first layer
G1 Z2 E0 F75
M400                         ; clear buffer
M117 TAZ Printing...         ; LCD status message

Any progress or luck on this? I’m REALLY interested, trying to post and find these. My settings from trying last week caused significant crashing into the bed that left deep gouges before I could stop it. It probed just fine too! I have an FFF file that doesn’t work, but I’m still trying! (It’s attached as .txt that needs to be renamed to .fff).

I’m really confused too, it took me a while to get the z offset fixed once I had the v3 in, but porting code from cura and subtracting useless bits (my working cura code), just caused attempted suicide for no reason! (That’s the gcode linked). The cura code is crap with far too much retraction and other garbage (though I still ported it and deleted most of the retraction).

I’m not certain if the FFF file will get all the settings:
-did the offsets as -6.5 and +6.5, it homes properly
-then it goes to heat properly
-then it crashes into new extended z probe before trying to crash through the bed
-I tried adding a z offset of 2 mm to start figuring out where to go from, but haven’t had time to figure it out.

Official lulzbot help would be appreciated too!
Taz 6 v3 Dual Extruder.txt (38.8 KB)

I think this is wrong. I tried setting 0 offsets when I first got this toolhead and never had luck with it in S3D, my prints would be skewed by 13mm because of the physical offset. I have searched the firmware code and don’t see any references that would set the offsets for the V3 in firmware. Checking the ‘apply toolhead offsets’ option just offsets the output G-code for the paths. You can see if you hover over the option that it says to only use if the firmware does not support setting offsets.

Another thing I never had any luck with is setting the X offset for E1/T0 head. The firmware code won’t let you set offsets for the first nozzle, and using M218 it never sticks, so my E1 nozzle comes out with 0 and the E2 end up with only 6.5 resulting in failed prints. The only luck I have had is setting T1 X13 Y0 (Actually just went through the dual extruder calulator and found I actually need to use: T1 X13.05 Y-0.175)

I noticed the slight Y offset trying to print a fidget toy, but the hinges (second color) were fused to the main cubes.

I agree with utah. I’m nearly at a shareable s3d fff file, but I need a little longer (today at best, next week at worst).

Right now I’ve taken the bed leveling starting script off to make it a macro. Part of that is so I can figure out a different macro for purging and priming (current cura one is garbage I think). It’s also to set one place to change the probe and wipe temp. I’ll probably make another macro just to wipe?

Definitely not sure why a few of the things I’m doing now didn’t work when I did them the first time - but the printer isn’t trying to destroy the bed so that’s progress! I’ll definitely suggest everyone try setting a z offset of up a mm or two, then lowering the head to make sure the offset is fine (had a huge problem with that).

So My solution is about the same as your’s - I set the hotend offset to t1 X13 - but I make sure to NOT save it in the firmware using m500. I just set it at the start of each print. I found that if I didn’t do that, it wouldn’t align with the wipe block anymore. So there’s a miscommunication with s3d and the Taz over when to use which one.

Currently I’m messing with the toolchange scripts and retraction settings. But at least it’s getting some prints and not wiping my settings when I change anything or driving me as insane as cura was!

I use the M218 X13 Y0 T1 command to get the X offset… then stumbled on this thread.

Using the toolhead offset of T0=6.5 and T1=-6.5 (as specified by GJennings) works, but the GCODE preview doesn’t look as though the object is merged correctly.

Using M218 X-6.5 Y0 T0, M218 X6.5 Y0 T1 also works and the GCODE preview looks correct. Since it uses T0 as home, offsetting by 6.5 seems to shrink the print area.

I’ll probably stick with the M218 X13 Y0 T1 since it generates the proper preview and prints correctly…

Been struggling with this issue as well. I really like the S3D software for its more advanced capabilities, but this offset problem is a pain. I’ll be trying the “M218 T1 13” tonight to see if that solves the offset problem.

Using the latest FFF file from S3D support (got it 3 days ago) and the starting GCode they have has:

M218 T0 X-6.5 Y0 ; set T0 offset,
M218 T1 X12 Y0 ; set T1 offset

This caused my machine to crash, as I see others have had the same experience.

Guess what I don’t get, I search through the gcode the Cura puts out, and there are no M218 commands. I’m starting to wonder if the Cura slicer does the offsetting. In other words, the gcode offsets are added to each extruder move.

Would be nice to know:
Why does the machine crash after issuing the M218 commands from the default S3D file?
Does the Cura slicer offset each extruder move so that’s why you don’t see a M218 command?

If I learn any more I’ll report back.

Using M218 shows up correctly in the S3D gcode preview, because it ignores the M218 and doesn’t understand that T0 and T1 are in different locations. The preview looks funky if you enable toolhead offsets (since they are applied to all gcode coordinates that aren’t in the scripts), but the actual print is correct.

Any M218 settings (other than 0) before the bed leveling will screw up the touch points and lead to crashing. The wiping (and built-in rewiping) scripts assume no M218 and will also crash.

The only way I got dual prints with M218 to work was:
Clear any M218 settings in the start script
Apply the M218 values just before the real printing starts
Clear any M218 settings in the end script

It just worked out easier to use the gcode offsets and ignore the preview. If you want to see everything aligned, just turn off the offset enable temporarily.

Well… I suppose the G-code offsets would be easier with the autolevel.

But then again, pasting the M218 commands isn’t that hard:
M218 X0 Y0 T0
M218 X0 Y0 T1
M218 X13 Y0 T1

Got a working fff for everyone needing it for s3d! Definitely need some testers for it and probably some small tweaks. Some warnings first:
-Check your z offset! First switch to s3d kept crashing into the bed and left me some deep gouges after nearly ripping off my extended z probes. I recommend taking these FFF files, then adding in a +2 mm z offset to start, press print, then stop it and lower your z height to the bed using machine control to make it so that you get the z offset to exactly 2mm below.
-I removed the auto leveling code from the starting script and put it in as a macro (attached as text). This makes it so you have ONE time to level it and you don’t have to wait on nearly as many heating restarts. This is really helpful to remove a bunch of purges and if you want to use the fff file for only ONE extruder printing. Go into firmware configuration in s3d then paste the text in the text file into the macro. Definitely open to help if someone wants to make this a simple gcode file so I can decouple this onto an SD card again (maybe just change this to .gcode and I’m done? I’m not sure)
-Understand that the autoleveling and the starting scripts are slightly decoupled - DON’T save the offsets later with M500 or it can mess up the routine (I fixed it at least once by reflashing firmware from Cura). s3d doesn’t like -X offsets, so it makes it work with Y+13, but that’s not the way it’s done in the firmware and I haven’t made the two fit.
-Note that s3d seems to pull from one then the other oddly, so I have two possibly slightly different processes for the right then the left. The left is the start scripts and the right is the end scripts priority wise, I’m not certain though.

The files are as follows, delete .txt to get just the fff file (upload won’t take fff here):
Taz 6 Dual v3.fff.txt - The code working for s3d, I’ve had to use this one and the RE version for the Right side, might have slight differences I’ve been tweaking?
Taz 6 Dual v3 Right Extruder.fff.txt - Should be the same as the left, but not 100% certain. S3d ignores some code in one and not the other
Right Extruder print only.fff.txt - Use this to just print from the right extruder if you want single extruder working.
bed level macro.txt - paste into the firmware under a macro you like, just press it and it will do the whole leveling sequence

These are working for PLA, still trying to tweak for the Polydissolve, and keep getting distracted. But this stuff works at the moment. Help, feedback, improvement all welcome!

Is it just me or are there no attachments? If its me, please reply with instructions on how to get the attachments.

Not just you, I think it’s not posting them here for some reason - here’s my s3d forum post with them: