E3D hot end installed- max temp "safety" errors above 235C

Ok I got my E3D installed and printing, next question, how do I adjust the max temp on the TAZ console to allow for extrusion above 235C? The dials on the TAZ only take it up to 235C before it stops, and even through Pronterface, it errors out as MAX temp if you try to tell it to go higher. My new hot end the E3D can go to 299C stock, and according to online sources even higher with a specialty thermistor (399C). I want to free flow fast print Nylon, and you cannot do it at 235C, as a matter of testing I found the Buddaschnozzle ineffective for printing nylon and the flow looked like a cold extrusion by the clouding of the filament (Bridge Nylon). I tried slowing the print down to 20-30% of PLA, but the nozzle clogged, so the prints were aborted. I don’t want to wait 2 days for a print that takes an hour in PLA, higher temps will fix this issue.

Any help would be appreciated I need to change the MAX temp to whatever I want it to be.



To reiterate, I am only getting “max temp” errors when trying to set the temp above 235C, otherwise it works fine, how/where do change this setting?

You have to adjust the maxtemp value in the firmware inside of configuration.h and then re-flash the machine. Will look something like:
#define HEATER_0_MAXTEMP 235 //{SD Patch}
#define HEATER_1_MAXTEMP 275
#define HEATER_2_MAXTEMP 275
#define BED_MAXTEMP 120 //{SD Patch}

There may be a command to adjust it from inside your printer interface, but I don’t know what it is.

ok done, now during the verify/compile I’m getting errors, ignore and flash?


No, it’s annoyed at your LCD module for some reason. it thinks there should be a comma there somewhere.

http://ohai-kit.alephobjects.com/project/marlin-resistor-update/#step_1, follow instructions.
Install Arduino ver 1.0.5 run updates.
reflash TAZ after updating Marlin configuration.h to 315C for extruder 0,
marlin_TAZ4_2014Q2.tar.gz (2.42 MB)
set temp sensor 0 to type 5 (for E3D)
print above 245C!!

Thanks everyone,