Electronics fan always on full.

A little while back I got myself a second hand LulzBot Mini off eBay.
I’ve had to replace a few parts, including the RAMBo Mini board from http://www.3dmakerworld.com/mini-rambo-electronics.
Luckily, doing all of this has fixed the problems that were present in the printer.

On the downside, the fan to cool the electronics is constantly going at full pelt as soon as the power is switched on.
When connecting to Cura, it stops & then spins up again (as it would normally do) but then continues to go on at full speed again.
I’ve checked it’s plugged into the correct pins.

I’m wondering if it’s because the new RAMBo Mini board is faulty, or if there’s something I should change in the firmware, or something else I’ve not thought of. Any suggestions?

I do have a second, fully working LulzBot Mini which I can swap parts from.
Tonight I plan on plugging the fan from the working printer into the other to rule out a faulty fan.

I replaced the stock mini Rambo with version 1.3a – I noticed this fan issue immediately and after quadruple checking the fan connection, I disconnected it from the board, led the wire out through the case, and hooked it up to a variable power supply so I could back it off some.

I had planned to look into the issue further, but have been using this interim solution for many months now. I should probably just put a pot in the line between the board and the fan and take care of it that way.

Anyway, if you have a newer version of the board, it is operating just like mine does, so not likely defective.

Edit–just followed the link you posted, we have the same boards. That one says 1.3a in the description.

not sure… but I think that jrhuboot firmware keeps the fan off and only turns it on during the printing process.


Interesting, I’m using his firmware (it’s awesome BTW) – I’ll have to reconnect the fan to see if this is so. That would be great.

I just checked it out.
It only turns fan on during the printing process.

Thanks, I’ll have a go with that firmware & see how things look then :slight_smile:

Just given it a go & it does leave the internal fan off until I start actually moving any motors, then it goes on full again & doesn’t turn off again until I switch off the power :frowning:

Considering the firmware ramps the motor up from 0 to a specific speed & then down again upon connection to cura, could the speed the fan is running at all times be a setting I can change? I know it would involve re-compiling the source for the firmware, but I’m willing to try that as the fan is making so much noise.

Interesting – on mine with the mini rambo v 1.3a, the box fan stops after the piece is cooled and presented, but then kicks on about a minute later. However, if I close the print window and then reopen it, the fan goes off. So maybe you don’t need to do a full shutdown.