Enabling Servo causing limit switch problem

I’m trying to enable a servo for a z-probe. I am wiring it to the MX1 header. I get it to work ok by uncommenting the following line in configuration.h (Sebastian’s latest Marlin version).

#define NUM_SERVOS 1 // Servo index starts with 0 for M280 command

The servo works fine, but then the TAZ starts ignoring the z limit switch for homing. I don’t have a z-probe set up yet as I am testing the setup. But the z limit switch are still enabled and hooked up. It just seems to ignore them.

Any idea what is going on?

Further investigation: When I go ahead and enable the feature all the way (#define AUTO_BED_LEVELING_FEATURE), then G28 works okay and it responds to the z-limit sensor. There must be something odd with the code so that when I only enable the servo (without the auto leveling to partially test it), things don’t work right.