Marlin 1.1.x for Taz 5

Disregard the above. The z-hop bug is still in there. I believe 1.1 is still unusable.
Marlin 1.1 (1.02 MB)
Stock (1 MB)

Have you seen a noticeable improvement with it? I’ll probably have to grab that one and add the blinky front light code into it. Linear advance seems very useful.

So far it seems to be noticeable in corners and top layer thanks to linear advance. The Blinky lights and status led code is in there just not enabled in what I posted


Recompiled a build today and the bugs seem to be worked out. I have a build with autoleveling, FW retract, yada yada working. I haven’t figured out the new vendor boot screen yet so it’s not included. The file below is for a taz with a capacitive toolhead mounted probe like i have in my Taz 5 hybrid toolhead. So far everything seems to be working. I disables Linear Advance for now as it was a bit aggressive on the retracts for me.


EDIT… The bug is still in there

When I install this firmware and home my axis. My servos make a grinding sound almost like I jogged too far on one of the axis.

PS. Sorry I’ve been away from the forums for a while :smiley:

Which servos do you mean, a servo mounted probe? Or do you mean the end stop isn’t stopping the stepper of the homed axis?

I had to double check just now, I guess I should’ve said motor instead of servo. It’s my Z axis. Anytime it moves up or down (only when homing) it sounds like it’s struggling and doesn’t move

I’ll check the build again its the one I’m using on my printer currently

I was told that the noise is the motor oscillating. It happens for about 3-4 seconds upon pressing the home button, and I think it moves normally after that. I don’t really know because I shut off my machine as soon as I heard that noise.

Once again the z-hop bug has resurfaced. Looks like it’s still not ready…

Any updates on this? You seem to be our only hope since Lulzbot seems to have no intention of supporting their own product. I may get a different printer just so I can get real support.

Someone that calls himself marcio is employed by AO and is testing 1.1 builds at the moment, you can follow his progress on a public AO git repository:

Whether this will result in new Taz 5 firmware I can’t tell of course.

Anyone know if there any updates on a working version of this firmware, or any firmware that will support g29?

I’ve lost that ability quite some time ago and I’ve tried to get my probe to work ever since.