Homing G28 Z0 not working: why are all axes are homing???

My Lulzbot Taz 5 is doing weird things. I first noticed it while using Octoprint, but it turns out it is not related to Octoprint or Cura or Univesral Gcod Sender, because they all exhibit the same problem:

When I try to home JUST the Z axis, the X & Y axis homes too.
The command is G28 Z0

G28 X0 Y0 will work, and just homes the x & y. But I can’t home the Z all by it’s self. Which is what I need to do for bed leveling.

Is there a setting in Marlin firmware that is messing with this perhaps? Maybe it is looking for a sensor or some auto leveling feature??

Any help appreciated

While it doesn’t seem like you’re new, I always jump back to https://www.simplify3d.com/support/articles/3d-printing-gcode-tutorial/ for commands.

I’ve got the Taz 6, but my working code omits the Z axis because it messes up the bed leveling. However, I used to use a separate G28 Z at some point I remember I think (it’s different now that I mostly use the V3 head which makes things odd) and I think it was throwing off the autoleveling settings.

See if you can run the code without the attached “0” just a G28 Z, that might be a better thing? Are you just coding an empty print with a G28 Z and then a simple G1 X100 Y100 Z5 ? (I always like to lift Z a bit in move commands)


Actually jump to this thread, think I’m wrong and others have this issue too.