Extruder Rises endless after a print! in Cura!

So i’ve been using Cura for some time, but I recently ran into a problem where the Tool head keeps rising up with no intension of stoping.
If i’m not there to turn off the printer after the last layer it would go very poorly. Most likely my printer would be out of commission and a mangled mess. I’ve isolated the problem to nGen standard and high speed profiles. Does anyone have a solution to fix this? maybe some gcode that will work?

This is what it looks like in layer readout

I don’t see the problem.
My machine does the same thing after a print. That’s just how it finishes.
The blue line is showing the nozzle path, but it is not extruding while it goes to a position that will allow you to remove the print later.
Can you expand on what is going wrong?

There is a “go to this position when done printing” setting in those profiles. Find it and change the z value to 40 or something instead of what it is now

I would leave it taking the extruder up near the top to prevent possible crashes into your newly printed model if you brought it down near the bed.

the tool head keeps following that path… to the point where the extruder would crash into the frame and brake. It will end up tearing itself apart and I would not longer have a working printer.

There should be a couple G1 commands near the end of the Gcode file what do they contain, and what type of printer is this.

yeah i had to edit the profile. something was screwy with it. copied the g code form anther profile and now it works.

had to change this:
end.gcode = M400
M104 S0 ; hotend off
M140 S0 ; heated bed heater off (if you have it)
M107 ; fans off
G92 E0 ; set extruder to 0
G1 E-3 F300 ; retract a bit to relieve pressure
G1 X5 Y5 Z250 F10000 ; move to cooling positioning
M190 R60 ; wait for bed to cool
M140 S0 ; turn off bed
G1 X145 Y275 Z200 F1000 ; move to cooling positioning
M84 ; steppers off
G90 ; absolute positioning

To This:
end.gcode = M400
M104 S0 ; hotend off
M140 S0 ; heated bed heater off (if you have it)
M107 ; fans off
G91 ; relative positioning
G1 E-1 F300 ; retract the filament a bit before lifting the nozzle, to release some of the pressure
G1 Z+0.5 E-5 X-20 Y-20 F3000 ; move Z up a bit and retract filament even more
G90 ; absolute positioning
G1 X0 Y250 ; move to cooling position
M84 ; steppers off
G90 ; absolute positioning
M117 TAZ Ready.

Ah, makes sense now. Glad you were able to fix it easily!

The " Z250" bit was what was tripping you up. i bet you copied from a full Taz profile. The mini doesn’t have 250mm of Z travel.

A Mini has an upper Z limit switch so would be ok with you telling it to go up, but would stop when the upper limit switch was triggered. But the Taz 5 and older would chew up the belt when it went too far. but 250 is below its upper Z height allowance.

The code is the same as I use without issues.

yeah, it’s got two Z raise sections as well, the Z200 followed by Z250. I’m guessing it was a paste error somewhere down the chain of wherever it came from?

I just stumbled across this problem myself, after a few other people using the printer had been having it for a while. I realise the problem now. It appears the weird end.gcode has crept into the nGen quickprint profiles for the TAZ 5, and since nGen is the default filament when you open Cura, if people forget to select the filament when slicing, they run in to this. I’ve just started printing with nGen again, so I’ve started to get the same problem.

While technically the Z-height of the printable area is 250, I’m guessing if the Z endstop is set to anything but the lowest possible value, a move to Z250 will result in the X axis hitting the top of the printer, at least it does on our machine. This invariably ends up in the two threaded rods getting out of sync and knocking the X axis out of alignment with the bed.

It seems to be a bad choice for profiles that should “just work”.

/usr/share/cura/resources/quickprint/lulzbot_profiles $ grep -lr Z250 *

This is with version 21.04-2228 of the package. In earlier version of the package (eg 19.12-00054) this end.gcode was only in the medium-quality and high-speed versions of the 0.5mm nozzle profiles. It has since begun to spread :wink: