Extruder Stepper doesn't move anymore...


It is a sad day. My extruder stepper no longer moves.

I guess over the past couple of weeks the nut holding the hobbed bolt in worked loose and it began to grind notches into the filament and quit printing. I didn’t realize this and was thinking it was the PLA or humidity.

After the latest failure the stepper no longer responds so out comes the multi-meter and my dearstalker!

  1. I verified the wires all the way from the controller board connector to the stepper connector by testing the resistance, passed
  2. I verified that the two winding’s generate voltage when you twist the stepper back and forth, passed
  3. I verified that the fans and nozzle heater all work by turning them on and observing them, passed
  4. I could NOT verify the stepper by commanding it to move from the menu, failed

Is it the controller? Is it the stepper?

I did notice I had this little gooey heat sink that had melted and fallen off the Z access chip on the board. I looked it up and apparently there was a directive to take it off because it over heated and caused failure of the board. It was the Z axis which appears to work correctly so maybe that was just a stroke of luck.


Any ideas about my poor Extruder?


The stepper on the extruder has anti movement without the horned at temperature code, unless you have the horned at temperature nothing will happen. If it’s at temperature and it’s still not moving, try powering off and swapping the motor to a different harnes point (plug it in where the bed motor normally goes) and see if the motor goes. If it doesnt, its the motor, if it does its probably a fuse or the harness. Its possible the falling z heat sink shorted something on the board too.

Cool! Does this mean I get the Moron of the Week Award? :wink:

It was too cold to move…

My printer thanks you for fixing me!


Nah, many of us discover that one the hard way. Now you know! You’re welcome!