Help needed for troubleshooting extrusion problem

The stepper motor on my Mini’s extruder fails to do anything (not even a noise or wiggling). I unmounted the motor and tried to turn the shaft by hand as it was unmounted. It seems to be stuck, or at least there is more resistance than I can overcome with my bare fingers on the shaft (no pun intended). The x-/y-/z-steppers all work fine. I assume my printer is a Mini v1.03 on account of it not having connectors directly on the stepper and having bought it in Sept. of 2015.

Where do I begin to troubleshoot? Is there a way to test if signals/power get to the motor, e.g. using a multi-meter? Could it be a blown fuse, i.e. is the extruder motor fused in some way? I want to be sure it is the motor and not the driver board/wiring, before ordering a new one.

Also I couldn’t find instructions on replacing the EXTRUDER stepper. I only saw stuff on replacing the y-axis and x-axis steppers. It isn’t a problem, since the motor is reasonably easy to unmount, but some people might profit from detailed instructions. After all, there is one for replacing the wiper pad :wink:

I checked the cabling from stepper to board with the continuity tester of my multimeter. Cables should be okay. It’s either something on the board or the motor.

There is code in the firmware that prevents the extruder stepper from moving if it isn’t at least at minimum temperature . If that got set to something odd, it would prevent extrusion. You can try temporarily swapping the extruder motor with a different motor lead, (remove the belt) and see if you can send a command that way. The fuses would affect all the motors do that’s not likely it. It could be a driver chip but that’s very rare. It’s usually a setting or a wire short.

You either have a 1.03 or a 1.02 most likely. It’s not a 1.04 for certain.

In addition to piercet’s comments…

If you can’t move the motor by hand with the POWER OFF, then there is something wrong with the stepper motor and it needs to be replaced. With the power off, the shaft should turn easily. (If you tried to move it by hand with power ON, then the motor may be energized and actively holding position – so that could be normal.)

Okay, thank you guys. I will get at it again tomorrow. Is there a way to test the motor signals from the controller with just a multimeter? Seems less work than swapping out motors.

Could you elaborate on the firmware settings? Regarding the minimum temperature, I assume the hotend needs to be at that temperature or higher as a mechanism to prevent the extruder eating away the filament when it’s to cold to actually extrude it, right? How would I go about changing that setting and what is the default?

I don’t want to spoil it, but I was relieved to hear, that the motor is more likely to be faulty, than the motor driver chips. I’d hate to get at all the cabling. It was annoying enough just to test continuity from driver board to motor. Also the board is likely much more expensive than a single motor.

Oh yeah, good catch. You might be looking at one of the bad shafts motors. That would have been right about the time those were shipping. The shafts on some minis of that Era would shatter inside the motor housing, possibly due to improper heat treatment by the motor manufacturer. If it is shattered, call support, they might replace it even outside warranty.n

Opened the motor. The portion of the shaft that is visible seems fine. No wiggle but alott of resistance when turning.

I can’t answer about the multimeter testing. But Marlin has a “cold extrude” limit which will stop any extrusion commands unless the head is at minimum temperature (default is about 140c as I recall). But you can temporaily turn it off by issuing “M302 S0”, which sets the minimum to 0c. The default will be restored at next power cycle or firmware boot.

Edit: I checked, and for the mini firmware the default minimum temp is 120c.

Sounds like there is your problem, with the printer off it should only take a little force to turn the shaft, similar to how much force it would take to turn the year axis motor.

With the power off and the idler latch opened so you are not driving the filament, you should be able to turn the large gear by hand fairly easily. If not your motor has failed. It sounds like you are grinding on the winding’s and the magnets inside.

Well son of a diddly. Not only was my extruder motor broken, but Octoprint was fooling me too.

Here is my short story, in case it helps someone:

Using Octoprint:

  • Extruder stops extruding in the middle of print. Not even a hint of a movement nor any noise, when I use Octoprint’s extrude button.
  • Check wiring from board to servo with multimeter’s continuity tester. All fine.
  • Unmount stepper completely and try to turn the shaft. It is stuck.
  • Open it. No visible damage, but gear grinds hard on the casing. Maybe shaft is bend? I don’t care, steppers are $6, so I replace it.
  • New stepper won’t extrude either. Multimeter gets 24 V on the working stepper outputs (i,e. X-/Y-/Z-axis), but no voltage on the extruder pins.
  • Panic, because board might be broken.
  • Carry printer from my narrow storage cabinet to the bench, were there is more light and space. Prepare for length debugging/repair session.
  • Connect laptop with Cura to printer

Now using Cura:

  • Connect multimeter to “defective” outputs for the extruder stepper
  • Holy cow, I get 24V.
  • Connect stepper. IT WERKS! IT’S ALIVE
  • Reconnect printer to Octoprint. No extrudy, Trudy.
  • Reinstall Octoprint. WERKS AGAIN!

Turns out stepper was broken AND Octoprint had a strange bug. Who knew?

What I learned:

  • I can check the stepper outputs with my multimeter in DC-mode (since stepper drivers have pulsed outputs, that might not be the case for slower multimeters). Of course the meter’s leads must be connected to a corresponding pair of output pins, i.e. pins that are normally connected to the ends of the SAME coil in the stepper. In my case either red+blue or green+black worked fine, while e.g. blue+black did nothing.
  • The cables are wired logically and retain color from server to board, which is nice. Thanks for the good assembly, Lulzbot!
  • Don’t trust any software until you have verified it works.

I dearly miss an “Out of Filament/Extruder not extruding” detection for my Mini. Please come up with some upgrade kit and include it per default in v1.05.
Thanks to everyone, who helped me in this thread!