Extrusion delay - TAZ 6

Hi All,

I’m new to 3D printing. I’ve dedicated many hours of reading and, as a result, have a good understanding of printer anatomy, associated terminology and slicer settings.

My TAZ 6 worked well right out of the box. I’ve got a couple hundred hours on it with no problems. Recently I started having first layer issues. Before going nuts changing parameters in the printer, slicer, etc., I figured I’d better calibrate everything and proceed from there.

So, I’ve been following this write-up:


I’ve completed steps 1-4.

During the printing portions of the steps in the write-up and during most all of my prints with this printer I notice that there is a long delay between when the tool head begins following the print path and when plastic starts to extrude. In a few rare cases filament never began to extrude so I cancelled those prints within the first minute or so. This isn’t so much an issue when printing a large skirt or brim as the hotend will eventually prime itself and begin to extrude. But, on smaller prints such as the temperature calibration towers in step 5 of the write-up, the issue becomes more pronounced since filament is not being extruded once the actual model begins to be printed.

Is it possible this issue is related to excessive retraction during the beginning of the bed calibration sequence, possibly adding to the time it takes to pull filament back into the hotend and, subsequently, delaying extrusion?

Would love to get some input on this.


This was discussed here: https://forum.lulzbot.com/t/filament-not-extruding-right-starting-print/4623/1

I’ve had the best luck with changing my starting gcode, here is my text from that thread:

"I started having the same issue with my TAZ6 so I just tweaked the starting code a tad at the end.

I replaced:

G1 Z2 E0 F75 ; extrude filament back into nozzle


G1 Z2 E5 F75 ; extrude filament back into nozzle < changed this so it pushes back an extra 5mm
G92 E0 ; set extruder position to 0 < added this to reset extruder so it doesn’t try and go back 5mm’ish to start first layer

What I think is happening is the ending script is retracting the filament 6mm:

G1 E-1 F300 ; retract the filament a bit before lifting the nozzle, to release some of the pressure
G1 Z+20 E-5 X-20 Y-20 F3000 ; move Z up a bit and retract filament even more

then when you start a new print it resets the absolute position to zero, retracts 30mm for cleaning/leveling, then returns back to 0 before printing, but that doesn’t compensate for 6mm retraction at the end of the previous print."


Thanks for the quick response. I’ll give that a try this evening.


I’ve had my Taz 6 for 3 days. Really like it.

Noticing this same issue. I started making 3 line skirts, with big 10mm offset so I can try and grab the little piece of filamemt that doesn’t stick to bed and prime the nozzle.

I will try modding the gcode like suggested.

Thanks to pyrokld, this did resolve my issue. Now it lays a blob down in the corner before proceeding with the skirt, brim or part.

Glad to hear it works for others too, I first tried to dial it back a bit so I didn’t get too much of a blob, but I kind of like that it helps my skirts start cleaner (though that does somewhat defeat the primary purpose of the skirt).