Firmware for Mini 1.3

I was given a Mini v1.3. Trying to get it up and running I used the newest version of Cura and flashed to the latest firmware. This seems to have caused a big issue with my Y-axis. The LCD screen shows the Y-axis at location 185 regardless of where the bed is located.

To address this I started with the stop switches and worked my way to the mobo. I have new stop switches, new wiring harness for Y-axis, and put a new Rambo 1.3 in. Flashed the latest firmware and am still having the Y-axis at 185 problem.

Support team told me that i needed to use Cura 3.6.20 as that is what is compatible with my machine. Soooo my qustion is what version of he firmware was compatible with Cura 3.6.20? Or for those still using the mini 1.3 what version of firmware is working for you?

I am using 3.6.20 for my old original Mini but with Octopi. Not sure which firmware is installed though. You might want to reflash the firmware. There may have been a glitch. Does the print head drive to the extreme of the Y axis. Mine did when I bought it used and I found the red wire to the limit switch was broken inside of the insulation but close to the switch.

Does your mini have and LCD? If so you can go to the machine info and it will tell you what version you are using.

I replaced all of the switches, the y wiring harness, and the mobo. Flashed a couple time to latest version. Regardless of where to bed is located y shows at 185. When i try to print the octopus to test it will not home properly.

I read in a post somewhere that someone was given and old mini and was told not to flash it. That the mini would only run on the older firmware. So I’m trying to find out what firmware version is working on the old Mini.

Could you try to find out what firmware version you have?

I will try but not sure how to tell

Now I see it’s M115. I will check in the morning.

When I type in M115 it returns P15 B4. I don’t know if that makes sense. I don’t have the lcd so I run it through Octopi on a RaspberryPi 3B+.