Firmware problems...

I have installed the alpha version of Cura, and as part of that, updated the firmware of my TAZ 6.
The first print I attempted gave me hints that I need to re-calibrate the z Height offset, and the extruder scaling factor.
I have partially disassembled my extruder so I could measure the amount that the filament moves without any back pressure from forcing it through the extruder. Unfortunately it seems that extruder motion is disabled.
I tried running the “auto home” (faking the z axis by pressing the z fiducial switch with my finger), but the extruder motor remained unpowered.

What is the correct procedure for calibrating the extruder?

Were you trying to extrude without heating to extrusion temp? The firmware normally prevents “cold extrudes”. If you want the extruder to move when cold, you can temporarily override with “M302 P1” or “M302 S0”. (These won’t survive a power reset, so they’ll go back to normal at next startup; or you can use “M302 P0” or “M302 Sxxx”, where xxx is desired min extrusion temp, to reverse).

But I’ve always found it best to do E-step calibration at temp/speed representative of normal printing.

You want to calibrate under operating conditions really.

You might try one of the TAZ 6 calibration files located here.

I don’t keep my printer attached to my computer, so I am limited to what the firmware allows me to do.
My previous attempts to calibrate the extruder were at temperature, but the firmware did not allow me to manually adjust the extrusion speed, and extrudes much faster than most of my printing. This left me with some slight over extrusion. (There probably need to be some correction factor that slightly scales up the amount of extrusion when extrusions are faster to account for the drive slippage caused by back pressure).
This is why I was trying to extrude with the extruder partly disassembled to allow the extruder to extrude without having to force the filament through the nozzle.
I tried setting the extrusion temperature to 25 degrees C, but the extrusion motor still did not turn on.
I’ll try setting the nozzle temperature higher to see if that works.
I have not yet found a way to manually enter gcodes on the printer.

I actually edit the calibration file and put in a printing speed that I normally use in the nozzle calibration files. Then you would just put in on an SD card and run it from the LCD on the printer. I have a calibration folder on my SD card that holds the extruder calibration files I use.

I set the print head temperature to 160 degrees, and I was then able to move the extruder.
The calibration value I arrived at was 827 steps/mm.

It turns out that the z adjustment was also way off. I found it was set to -1.2, but I had to change it to -1.51 be for the first layer thickness was correct.

The Z-axis offset is going to be machine & material specific. Like the other posts have mentioned, fine tune your esteps at your typical extrusion temperature. How does your current esteps compare to the calibrated esteps included with your stock printer tool head?

My machine had previously been calibrated on an older version of firmware. I was surprised to find that the calibration had been overwritten. I did not see any warning that this would happen.

That will happen when Flash EEPROM is selected. How is it working for you now?