Help with Raspberry Pi / Octoprint set up

I recommend re-flashing your SD card and going through Tom’s set up video again… You need to start from a known good point.

Are the lights blinking on the Ethernet port of the RPi when cable connected? Try a different Ethernet cable… Make sure the Ethernet cable clicks when you plug it in.

Just to be sure, you downloaded a copy of octopi from the github site… Use the mirror site to get the zip:

What happens when you ping the address from the command line of your windows box.

OK I give it at try and re-due everything, when you say reflash the SD card are you just saying to reformat it again?

Yes the lights are both on and flashing 1 amber 1 green

I tried 2 different cables

When I originally downloaded the copy of ocopi i used the mirror link and downloaded the zipped file, it is the mirror link

I followed Toms video exactly

when i ping the ocotpi IP I get destination host unreachable :cry:

To summarize the facts:

  • The pi is connected to the router, so it looks like your ethernet interface is OK
  • The router can see the pi and has given it an IP address, so likely not a DHCP problem
  • You have been trying to reach the pi using its IP address directly, so its almost certainly not a DNS problem
  • You are unable to reach the pi from your computer which is also on the same network

Considering the above, I predict that re-flashing the SD card and starting over will bring you back to the same place, but it certainly wont hurt to try. It seems to me that there might be settings on your router preventing inbound traffic to the pi.

If, after restarting your pi, it is not visible on the network, try the sudo ifup eth0 command on the pi again.

You might try pinging your computer FROM the pi. On the pi, you just need to run ping <your.ip.address>. You can get your computers address easily:

OK guys

I reformatted the sd card using partition master
I reinstalled the ocopi image, using Win32disk Imager
booted up the Pi
typed octopi.local in my browser got same results (server not found error)
looked at device list im my router (No octopi in the list)
rebooted the Pi a couple times and checked router with same results (NO there)
oh and tried 2 more Ethernet cables

Do you think a hammer will make it work?

Here is the boot screen to show you there are 2 errors, NTP server

I ran the sudo ifup eth0 command
and now see the pi on the network in the routers device list

I type in octopi.local in browser (same results sever not found)
If i Ping from cmd I get a response
If I type Ocopis IP in browser I get unable to connect error

If i Ping my computer FROM the PI I get network is unreachable

Anyone want to come by my place and help me out this is getting old!

Could you possibly do the following please?

run ifconfig on the pi again and attach the output?
Try pinging a known website such as the bbc from the pi - ‘ping
(You’d be expecting an output of something like 64 bytes from icmp_seq=1 ttl=50 time=29.423 ms)

If both of those are fine you could try to open octopi from the pi (doesn’t matter if its connected to the printer). To do this first run ‘startx’ from the command line to boot into the desktop and then use one of the web-browsers and use ‘localhost’ as the address.

Also to make sure, the IPs you’ve tried using have no final . at the end - (so it’s ‘’ not ‘’)

I ran ifconfig also pinged the BBC here is a screen shot of both.

When I type in an IP address into my browser it’s automaticly adding the . At the end.

OH and BTW NOW the PI is NOT in the routers device list. It’s gone!

Hows it it connected to the network? Is it just a single ethernet to the router? Could you possibly try another port on the router, reboot (‘sudo reboot’ from command line) and and try to ping the bbc again?

You are not pulling an IP address. Did you sudo ifup eth0 as DustMason suggested? Do that and then ifconfig and post the result.

Things to try:

  1. Download a different Octopi (not octoprint) image (either nightly or devel). Flash to sd. Boot, Setup (expand file system, boot to gui), reboot, and see if it boots to command prompt. If at that point you are able to ssh in to the pi, proceed.

  2. install tightvnc, vnc in from main computer, try to load octopi.local in RPi browser

*at this point do not apt-get update or apt-get upgrade. Do not update or switch branches on octopi.
*If the RPi boots to gui but octoprint still will not load, rm / rn the config.yaml file in the .octoprint folder and let octoprint recreate it. This can be done by restarting the service… sudo service octoprint restart

I’m wondering if toymaker’s issues stem from using an OctoPi image with a RPi v2. I have a v2, but haven’t ever tried putting OctoPrint on it, and I’m wondering if there is a difference somewhere. Perhaps I’ll give that a shot tonight and see if I have any issues.

I am running the newest stable release on a V2… no problems.

No issues at all using a RPi2 model B here. I feel like it’s a corrupt download / build issue

BTW: my model is a B+ newest one.

Up till now I was plugging into a switch in my office, I just now plugged it directly into the router (same thing not in the device list)

Here is the results of a full round of testing

I ran the sudo ifup etho0 and (I now see the Ocotpi in my device list)
Enter octopi.local into browser same results ( server not found)
Enter into browser same results ( unable to connect)
Not going to get excited yet, last night I saw the octopi in the list at one point then it was gone.

I ran ifconfig (Octopi is still in my device list)
Enter octopi.local into browser same results ( server not found)
Enter into browser same results (I now get a yahoo search results page) Is this what is suppose to come up?

I shut down the Pi and then rebooted it to see if it gets an ip on reboot. (Nothing Pi is now GONE from the device list) So rebooting its not pulling an ip address. Looks like the only way it dose is by running sudo ifup eth0, i will try it again.

Run sudo ifup eth0 (now I see the octopi in the device list)

So its getting dropped on reboot and not getting an ip

Its strange that you have to perform the “sudo ifup eth0” each time. Almost seems like your eth0 isn’t coming up on its own. Do you have the USB wireless dongle attached, by chance? If so, you may need to unplug if the plan is to used the wired ethernet.

My unix/linux is rusty, but there’s a file to enable /disable devices on bootup… maybe some one can point out the file and you can can check the contents.

Also check that your PC or browser isn’t blocking access to the RPi.

Looking closer at your last screenshot… you need to type: “” (without quotes). Looks like the its trying to “search” for the IP address from the address bar…

I do not have the wifi dongle attached. MY goal is to set the RPi up via wired connection, I dont want to be dealing with wifi issues I need it to be hard wired.

as far as typing in the ip address Ive done it both ways with and with out http://

HOW do i check that my pc or browser isn’t blocking access to the RPI?

Any input on why I can not access the Octopi web interface?

Do you guys have any suggestions on who can can call to help me get this resolved? im not seeing any phone contact info on but I guess there in the UK anyway right?

Guys can you take a look at this, wondering if this is the problem.


Please redownload a different build of octopi and reflash your sd card. This should be your first troubleshooting step at this point.

I am running from

I agree with discojon, download it again and get a fresh start…